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About the Book
At a Glance

Document Scope This is Online Help for TwidoSoft.

Validity Note The information in this manual is applicable only for Twido programmable 
controllers.

Product Related 
Warnings

Schneider Electric assumes no responsibility for any errors that appear in this 
document. No part of this document may be reproduced in any form or means, 
including electronic, without prior written permission of Schneider Electric.

User Comments We welcome your comments about this document. You can reach us by e-mail at 
TECHCOMM@modicon.com
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Introduction to TwidoSoft 
At a Glance

Overview This chapter provides an introduction to TwidoSoft - the software used to program 
and configure Twido programmable controllers. Instructions are also included for 
updating the operating system for your controller.

What's in this 
Chapter?

This chapter contains the following topics:

Note: For communication between TwidoSoft and the controller to function 
correctly, the TCP/IP protocol must be installed.

Topic Page

What is TwidoSoft? 12

Connecting a PC to a Twido controller 14

Updating the Operating System 17
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Introduction to TwidoSoft
What is TwidoSoft?

Introduction  TwidoSoft is a graphical development environment for creating, configuring, and 
maintaining applications for Twido programmable controllers. TwidoSoft is a 32-bit 
Windows-based program for a personal computer (PC) running Microsoft Windows 
98 Second Edition or Microsoft Windows 2000 Professional operating systems. 
Versions of TwidoSoft of v. 1.13 or later also run on Microsoft Windows XP.

Software 
Features

Main software features of TwidoSoft:
� Standard Windows Interface
� Application browser and multiple window views
� Programming and configuration support
� Communication with controller

Standard 
Windows 
Interface

Key standard Windows features:
� Easy use of keyboard or mouse
� Dockable windows and toolbars
� Standard menu organization
� ToolTips, status bar, and shortcut menus
� Online help including context-sensitive help

Programming 
and 
Configuration

Major programming and configuration features:
� Reversible ladder and list programming
� Two-step, point and click ladder programming
� Offline and online programming
� Program and/or data animation
� Easy configuration by using the Application Browser
� Editors for main programming and configuration features
� Cut, copy, and paste program editing
� Symbolic programming
� Cross references
� Printouts of programs and configuration

Controller 
Communication 
and Control

Main TwidoSoft features for controller support:
� Connecting and disconnecting a controller
� Operating the controller
� Monitoring application use of memory by the Resource Monitor
� Downloading and uploading controller programs
� Backing up controller programs to optional EEPROM
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Introduction to TwidoSoft
Additional 
Information

Refer to the following for additional information:
� For information on standard Windows interface features, refer to Microsoft 

Windows documentation and help files.
� For information on Twido controller hardware and programming using the List 

and Ladder languages, see the TwidoSoft User Reference Manual.
� For context sensitive help, click on the Help buttons in dialog boxes.

Conventions The following typographic conventions are used in this operation guide.

Format Represents

bold For user input, enter words or phrases shown in bold exactly as 
they appear. Menu names and options, commands and toolbar 
names, and dialog box names and options are also shown in 
bold type.

UPPER CASE Keyboard names, combinations, and sequences are shown in all 
uppercase letters. For example, the keyboard shortcut for 
creating a new application is CTRL+N. To perform this shortcut, 
press and hold the CTRL key and then press the N key.

File → Open The arrow indicates a menu selection. In this instance, go to the 
File menu to select the Open command. 
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Introduction to TwidoSoft
Connecting a PC to a Twido controller

Introduction A communications cable is required to connect a PC to a Twido controller.
Connections can be made in two ways. Either: 
� using special multi-function cables for connecting the COM or USB serial port on 

the PC to Port 1 on the controller:
� The TSX PCX 1031 (2.5m) cable converts signals between RS-485 and RS-

232 devices,
� The TSX PCX 3030 (2.5m) cable converts signals between RS-485 and USB 

devices.
� or using a telephone connection linking a receiving modem connected to port 1 

on the controller and a modem connected to the COM serial port on the PC (or 
internal modem to the PC).

Port 1 for all Twido controllers is a built-in RS-485 port, which must be used to 
communicate to the TwidoSoft programming software. When the cable is connected 
to Port 1, protocol is automatically set for TwidoSoft communications (see Using the 
Communications Cable, p. 140).

Note: TSX PCX 1031 and TSX PCX 3030 communication cables are equipped 
with a four-position rotary switch allowing the cable to be used for different modes. 
Set the switch to the position labeled 2 for TwidoSoft communications.

CAUTION

Possible electrical damage to controller components.

Do not connect the communications cable to the controller before 
connecting it to the PC. Always connect the cable to the PC first.

Failure to follow this precaution can result in injury or equipment 
damage.
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Introduction to TwidoSoft
Connecting the 
TSX PCX 1031 or 
TSX PCX 3030 
Communication 
Cable

The following diagram shows an example of the communications cable connecting 
a PC to a Twido controller. The location of Port 1 depends on the model of the Twido 
controller. Consult your PC documentation for details on using COM serial ports. 

PC

Communications cable
(TSXPCX1031 or TSX PCX 3030)

Twido controller

Rotary switch
(Set to 2 for Twido)

miniDin
male connector

Connect to COM serial port
(on rear panel of PC)

D-sub 9-pin
female connector

Connect to 
Port 1
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Introduction to TwidoSoft
Telephone Line 
Connection

The following diagram shows an example of a telephone connection between the 
modems of a PC and a Twido controller. The location of Port 1 depends on the 
model of the Twido controller. Consult your PC documentation for details on using 
modems. 

PC

Telephone line

Twido controller

Receiving modem

miniDin
male connector

Connect to COM serial port 
(on rear panel of PC)

Sub-D 9 pin female 
connector

Connect to 
Port 1

External modem
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Introduction to TwidoSoft
Updating the Operating System

Overview The Twido Windows Executive Loader Wizard is a Windows-based program that 
guides you through the steps needed to update the Firmware Executive in your 
Schneider Electric Twido programmable controller. The Firmware Executive is the 
operating system that runs your applications and manages controller operation.
The wizard provides an intuitive point-and-click interface that progressively steps 
you through the updating procedure to quickly download the latest version of the 
executive for your controller. 
See the Executive Loader Wizard User Guide for detailed instructions. This guide 
can be accessed using the Exec Loader utility.

Opening the 
Exec Loader 
Wizard

You can open the Executive Loader Wizard from TwidoSoft by selecting Tools → 
Update Controller Firmware from the main menu, or by double-clicking on the 
program to open it directly. The wizard program, TWEL.EXE, is included in the 
TwidoSoft installation and can be found in the \bin sub-directory of the default 
installation directory.

Basic Steps There are four steps required to upgrade your executive. The wizard provides a 
screen for each step and online help is available for each screen. The following table 
summarizes each step:

Step Screen Function

1 Welcome Introduces the Executive Loader Wizard.

2 Parameters Selects the correct executive file to transfer to your 
controller, and selects the PC serial port to communicate 
with the controller.

3 File and Device 
Properties

Compares the hardware IDs and the executive version 
information for the executive file and the controller.

4 Transfer Progress Monitors the transfer of the executive file to the controller.
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Introduction to TwidoSoft
Supported Twido 
Controllers

The following table lists all Twido devices that are supported by the Executive 
Loader Wizard program:

Controller Module Description

TWDLCAA10DRF Base Unit AC, 6 In DC, 4 Out Relay, Terminal Block

TWDLCAA16DRF Base Unit AC, 9 In DC, 7 Out Relay, Terminal Block

TWDLCAA24DRF Base Unit AC, 14 In DC, 10 Out Relay, Terminal Block

TWDLMDA20DUK Base Unit DC, 12 In DC, 8 Out Transistor Sink, Connector

TWDLMDA20DTK Base Unit DC, 12 In DC, 8 Out Transistor Source, Connector

TWDLMDA20DRT Base Unit DC, 12 In DC, 8 Out, 6 Relay, 2 Transistor Sink, Terminal 
Block

TWDLMDA40DUK Base Unit DC, 24 In DC, 16 Out Transistor Sink, Connector

TWDLMDA40DTK Base Unit DC, 24 In DC, 16 Out Transistor Source, Connector
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2

Software Features 
At a Glance

Overview This chapter provides details on using the software features of TwidoSoft. 

What's in this 
Chapter?

This chapter contains the following sections:

Section Topic Page

2.1 User Interface 20

2.2 Editors and Viewers 29

2.3 Operating Modes 53
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Software Features
2.1 User Interface

At a Glance

Overview This section provides an introduction to the main components of the TwidoSoft user 
interface.

What's in this 
Section?

This section contains the following topics:

Topic Page

Key Concepts 21

Main Window 22

Application Browser 24

Status Bar 27

Preferences 28
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Software Features
Key Concepts

Introduction TwidoSoft provides an intuitive Windows-based user interface consisting of 
standard Windows features including ToolTips and online help.

Key TwidoSoft 
Concepts

The following are key concepts for using TwidoSoft.
� Application browser

Use the Application Browser to view, configure, program, and maintain an 
application. Conveniently perform the same commands that are available from 
menus. Configure hardware using a graphical representation of controllers, 
expansion I/O, and options.
See Application Browser, p. 24.

� Memory allocation
View the status bar memory usage indicator (visible in the memory editor) to 
determine the percentage of total memory used by a program. A warning is 
provided when available memory is getting low. See Status Bar, p. 27.

� Online and offline operations
In offline operation, TwidoSoft is not connected to the controller and changes can 
only be made to the application in the PC memory. Use offline operation to 
develop and configure an application. 
In online operation, TwidoSoft is connected directly to the controller and changes 
can be made to the application in the controller memory. Use online operation to 
run the controller and debug and modify an application. 
See Offline and Online Operation, p. 54.

� Application protection
An application can be protected to prevent unauthorized viewing, changing, or 
duplication. See Security Features, p. 61.
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Software Features
Main Window

Introduction The TwidoSoft Main Window provides easy access to menus and commands, 
windows and toolbars, and views of an application.

Main Window The following illustration shows the TwidoSoft Main Window. 

Application
Browser

 TwidoSoft - Example

My Application

Software

TWDLMDA40DUK
Hardware

Port 1: Remote Link, 1

Port 2: Modbus, 1
Expansion bus

1 : TWDDDO8UT
2 : TWDDDI8DT

Constants (KD)
Constants (KF)

Timers

%PLS/%PWM

Drum Controllers

Program

Animation tables
Documentation

Symbols

LIFO/FIFO registers

Counters

Constants

Very fast counters

Schedule blocks

123

123

77

123

D

F

PI PID

32

RT TWDXCPRTC
TWDXCPMFK32

1: Modem

Fast Counters (FC)

Controller Connected TWDLMDA40DUK: 0 Stop Online

RUNG 0

%I0.1 %Q0.3

Ladder Editor  - Edit Rung

75% ??

RUNG

F2 F3 F5
P

F6
N

F7 F8 F9 F11 F12 F2 F3 F5
R

F6
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%TM

F11
%C

F12
+... ??
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IN Q

TYPE  TOF
TB       100 ms
ADJ     Y
%TM1.P 1000

ESC

Title bar Menu bar Main toolbar

Application browser Status bar Editors and Viewers

File Edit WindowDisplay Tools Hardware Software Program Controller Help
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Software Features
Description of 
Main Window

The following table describes the above components of the Main Window. 

Component Description

Title bar Displays TwidoSoft application icon and title, application path 
and file name, and the current editor or viewer if maximized in 
display area. 

Menu bar This is the main menu displayed in the form of a horizontal bar 
near the top of the main window containing the names of 
TwidoSoft menus.

Main toolbar Panel beneath menu bar containing buttons for frequently used 
menu commands. 

Application browser Provides a convenient, tree-like view of the structure of an 
application.

Editors and Viewers Editors and viewers are TwidoSoft windows that organize 
programming and configuration controls for efficient 
development of applications.

Status bar Displays information about the application, the controller, and 
TwidoSoft.
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Software Features
Application Browser

Introduction The Application Browser is a dockable window that provides a tree view of an 
application. Windows and toolbars that are dockable can be moved around and 
attached to the borders of a parent window. Elements of an application appear in a 
logical hierarchy based on their relationship in the application. The elements are 
organized as an indented outline that can be expanded or collapsed. The 
Application Browser conveniently organizes items in an application so that you do 
not have to search for these items individually.
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Software Features
Application 
Browser Window

The following illustration is an example of the Application Browser.  Selections will 
vary for each application depending on configuration choices. 

My Application

Software

TWDLMDA40DUK

Hardware

Port 1: Remote Link, 1

Port 2: Modbus, 1

Expansion bus

1 : TWDDDO8UT

2 : TWDDDI8DT

Constants (KD)

Constants (KF)

Timers

%PLS/%PWM

Drum Controllers

Program

Animation tables

Documentation

Symbols

LIFO/FIFO registers

Fast Counters

Counters

Constants

Very fast counters

Schedule blocks

1 2
3

1 2
3

77

1 2
3

D

F

PID PID

Controller 
Model

Software
configuration

Program
Editor

Animation Table
Editor

Application name

Print
Setup

Symbol
Editor

Hardware
configuration

Close boxBrowser bar

Serial ports

Expansion 
modules

Hardware 
options

32K

RTC TWDXCPRTC

TWDXCPMFK32

1: Modem
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Software Features
Description of 
Application 
Browser

The following table describes the components of the Application Browser.

Component Description

Application name This is the top most item in the tree structure. Displays the name 
of the open application.

Controller Model The model number of the base controller.

Hardware configuration Displays the hardware configuration for the base controller: 
communications setup, expansion modules, and hardware 
options. Right-clicking on hardware items displays shortcut 
menus for commands on the Hardware menu.

Software configuration Displays configuration of software resources such as timers and 
counters. Right-clicking on software items displays shortcut 
menus for some commands on the Software menu.

Program Opens the default program editor (see Preferences, p. 28). Right-
clicking displays a shortcut menu for some commands on the 
Program menu.

Symbol Opens the Symbol Editor.

Animation Opens the Animation Tables Editor. 

Documentation Opens the Print Setup dialog box to configure printing options.

Browser bar Click and hold the left mouse button to move the Application 
Browser in the display area. Double-click to reduce the browser to 
a small, floating window.

Close box Click to close the Application Browser.
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Software Features
Status Bar

Introduction The Status Bar is a panel at the bottom of the main window that displays information 
about the application, the controller, and TwidoSoft. The Status Bar can be turned 
on or off by selecting Display → Status Bar from the main menu bar.

Status bar The following illustration shows the TwidoSoft Status Bar. 

Description of 
Status Bar

The following table describes the components of the Status Bar.

Controller Connected TWDLCAA10DRF: 0 Stop Online

Message area

Controller model, firmware version, 
and address

Controller memory usage indicator

Controller state TwidoSoft
state

Component Description

Message area Displays status messages and prompts.

Controller model, 
firmware version, and 
address

If TwidoSoft is online: displays controller model number, version 
number of the firmware (version and patch numbers), and the 
controller address.

Controller memory 
usage indicator.
(double click to access 
the memory viewer)

Displays a graphical indication of controller memory usage. The 
indicator bar moves from left to right to indicate the amount of 
controller memory that is being used by an application. The color of 
the bar changes to warn of scarce memory resources. When the bar 
fills more than 50% of the available space, the color changes from 
green to yellow. When the bar fills more than 75% of the available 
space, the color changes to red. 

Controller state Displays controller state: run, stop, or error. TwidoSoft must be 
online.

TwidoSoft state Displays TwidoSoft state: initial, offline, online, or monitor.
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Software Features
Preferences

Introduction Use the Preferences dialog box to select user preferences for using Ladder and List 
editors and viewing toolbars. 

Displaying 
Preferences

With an open application, click on File → Preferences from the main menu bar to 
display the Preferences dialog box.

Selecting 
Preferences

The following table describes the options available for user preferences. 

Option Description

Default Program Editor Select the List or Ladder editor as the program editor to display 
when opening an existing application or creating a new 
application.

Ladder Information Select a format for ladder entries.

Close Ladder viewer on 
Edit Rung

Select to close Ladder viewer when editing a rung.

List/Ladder Animation Select Hexadecimal or Decimal format for display of data when 
animating a program.

Display Attributes Select the default attribute, symbols or addresses, for display of 
variables in List and Ladder editors.

Display Toolbars Select to display toolbars for editors.

Auto Line Validate Select to fix errors before leaving a List instruction. With Auto Line 
Validate selected, any errors in an instruction will stop the List 
editor from moving to another instruction until the errors are fixed. 
If Auto Line Validate is not selected, you can leave a line with 
errors to create or edit other lines and a question mark (?) is 
inserted at the front of a line indicating that it contains a program 
error,.

Connection Select from one of the connections previously configured on the 
serial port to be used to connect the PC to controller.

Add/Delete Connection Used to manage configurations for the Connection option
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Software Features
2.2 Editors and Viewers

At a Glance

Overview This section is an introduction to the editors and viewers used to create, modify, and 
debug TwidoSoft applications.

What's in this 
Section?

This section contains the following topics:

Topic Page

Editors and Viewers 30

Ladder Viewer 32

Ladder Editor 34

Extended Ladder Palette 36

Rung Header 37

List Rung Editor 39

List Editor 40

Configuration Editor 42

Symbol Editor 44

Find Symbol 46

Object Browser 47

Program Errors Viewer 49

Cross References Viewer 50

Animation Tables Editor 51
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Editors and Viewers

Introduction TwidoSoft provides specialized windows called editors and viewers for performing 
important tasks in developing an application. A TwidoSoft application consists of a 
program, configuration data, symbols, and documentation. These components can 
be used in any order when creating an application. For example, an application can 
be developed in the following order:
� First, define configuration data,
� Next, define symbols,
� Then, write program instructions,
� Finally, add comments and print documentation.
This is just one method to organize these tasks; these could just as easily been done 
in reverse order. Developing each part of an application using separate editors 
makes the application development process more systematic, resulting in more 
clearly defined applications.

List and Ladder 
Editors

Use the List Editor, p. 40 and the Ladder Editor, p. 34 to develop the main program 
which is the core of an application. The development of the main program includes 
creating the order in which the program is executed.

Selecting List or 
Ladder

You can write a controller program in either List or Ladder format. Selecting one 
method over the other is a matter of preference and does not affect the application.
� Ladder language consists of diagrams that use both graphics and text.
� List language is a text-based instruction set.
In either list or ladder language, you write the program in the logical order required 
to control a machine or process. You can automatically convert or reverse ladder 
instructions to list instructions. You can also reverse list to ladder instructions if the 
program structure and instructions comply with reversibility rules. See Reversing a 
Program, p. 77.
 In either language, document your program by using comments in both the List and 
Ladder editors. Comments consist of text that you insert into instructions to 
document the meaning and purpose of the program.

Animation 
Tables Editor

Use the Animation Tables Editor, p. 51 to create and save animation tables. A 
animation table lists all or part of the data variables used in the main program, and 
consists of addresses of variables, current and retained values, and associated 
symbols. This information is useful for adjusting and debugging an application. See 
Animating a Table, p. 266.
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Configuration 
editor

Use the Configuration Editor, p. 42 to assign specific values to the hardware and 
software resources of the controller to control these resources, such as timers, 
counters, latched inputs, external run/stop switches, and so on. These assigned 
values are called configuration data. See Hardware and Software Configuration , 
p. 117.

Symbol Editor Use the Symbol Editor, p. 44 to document a program by assigning tag words 
(symbols) to the data variables used in the program. Symbols are easier to 
remember than the memory addresses of variables. Use the Symbol Editor to define 
and edit symbols. See Defining Symbols, p. 74.

Cross 
References 
Viewer

The Cross References Viewer, p. 50 provides a convenient list of application 
elements: operands, symbols, rung or line numbers, and operators. Cross 
references identify program elements used in an application, and where they are 
used. During troubleshooting or debugging an application, these items can be easily 
located and cross-referenced to other elements in the program without searching 
through the entire program. See Cross Referencing an Application, p. 102.

Program Errors 
Viewer

The Program Errors Viewer, p. 49 displays the results of the program analysis of an 
application. The following information is provided for each error: type of error 
message (error or warning), number of rung or line, and description of error. See 
Analyzing a Program, p. 72.
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Ladder Viewer

Introduction The Ladder Viewer window provides a graphical view of a ladder program and its 
component rungs. Use it to scroll through and view a ladder program. To edit or 
modify rungs, use the Ladder Editor.
See Programming in Ladder Language , p. 181.

Available 
Commands

Functions available in the Ladder Viewer:
� View a ladder program. 
�  Customize the view of ladder diagrams. 
�  Open the Ladder Editor to create and edit rungs. 
� Open the List Rung Editor to edit a non-reversible list instruction.  
� Insert or delete a rung. 

Ladder Viewer 
Window

The following is an example of the Ladder Viewer window. 

Ladder viewer

%% IL LD STEP 75% ??ABCABC

RUNG 0    THIS IS THE TITLE OF RUNG HEADER 0.
                  THIS IS THE FIRST COMMENT FOT RUNG HEADER 0

RUNG 1    THIS IS THE TITLE PAGE FILE FOR RUNG 1.
%L5:         THIS RUNG CONTAINS A LABEL

RUNG 2    THIS RUNG ONLY CONTAINS ONE HEADER TITLE

%I0.1 MR101

%I0.0 M101%M10

%M101 %MW20 := %KW2 * 16

%I1.3

%Q0.5

I0.13
P

%Q0.5

Toolbar

Comments Rung header

Programming gridLadder elements

Rung

Title bar
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Parts of the 
Ladder Viewer

The following table describes the parts of the Ladder Viewer:

Part Description

Title bar A bar at the top of the window that displays the name of the editor or 
viewer.

Toolbar A bar below the title bar that displays frequently used commands for the 
Ladder Viewer.

Rung Panel that contains graphic elements and connections for a single 
ladder rung.

Rung header A panel located immediately above a rung which identifies the rung and 
can include user comments. 

Programming grid Each rung consists of a matrix of 7 rows by 11 columns of cells. Each 
cell can contain a ladder element. Displayed area is from the first row to 
the last row in which there are ladder elements. Double-click on an 
empty cell to open the Ladder Editor. Double-click on a ladder element 
to edit the properties for that element.

Ladder elements Symbols for functions in ladder programs such as, coils, contacts, and 
function blocks. When selected in the programming grid, elements are 
surrounded by a red rectangle.
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Ladder Editor

Introduction The Ladder Editor is a graphics-based, program editor used to create and edit 
ladder diagrams.
See Programming in Ladder Language , p. 181.

Ladder Editor 
Window

The following is an example of the Ladder Editor window. 

RUNG 0

%I0.1 %Q0.3

Ladder Editor  - Edit Rung

75% ??

RUNG

F2 F3 F5
P

F6
N

F7 F8 F9 F11 F12 F2 F3 F5
R

F6
S

F7 F8 F9
%TM

F11
%C

F12
+... ?? Normally Open Contact

%TM1

IN Q

TYPE  TOF
TB       100 ms
ADJ     Y
%TM1.P 1000

Toolbar Ladder Palette ToolbarRung header

Programming grid
for one Rung

Extended Ladder
Palette Button

Title bar

Ladder elements

Rung

ESC
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Parts of the 
Ladder Editor

The following table describes parts of the Ladder Editor.

Part Description

Title bar A bar at the top of the window that displays the name of the editor or 
viewer. Indicates if editing or inserting a rung.

Toolbar A bar below the title bar that displays buttons for frequently used 
commands.

Ladder Palette 
Toolbar

A bar beneath the toolbar that displays buttons for most commonly 
used ladder elements. A single left click on a symbol selects the 
element, then right-click in a cell to insert the element.

Extended Ladder 
Palette Button

A special selection on the instruction bar that opens a dialog box with 
additional options for special contacts, function blocks, and special 
coils. See Extended Ladder Palette, p. 36.

Rung Panel that contains graphic elements and connections for a single 
ladder rung. The Ladder Editor displays the programming grid for only 
one rung at a time.

Rung header A panel located immediately above a rung which identifies the rung 
and can include user comments. 

Programming grid Each rung consists of a matrix of 7 rows by 11 columns of cells. Each 
cell can contain a ladder element. Double-click on a ladder element to 
edit the properties for that element.

Ladder elements Symbols for functions in ladder programs such as coils, contacts, and 
function blocks. When selected in the programming grid, elements are 
surrounded by a red rectangle.
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Extended Ladder Palette

Introduction The Extended Ladder Palette dialog box provides additional ladder elements that 
are not available from the Ladder Palette Bar. This dialog box is selected by clicking 
the button just next to the help button on the Ladder Palette Bar (Maj+F12). The 
ladder elements are organized into three groups in the dialog box:
� Special contacts
� Function blocks
� Special coils
See Using the Extended Ladder Palette, p. 199.

Making 
Selections

To make selections from the Extended Ladder Palette, left-click on an item and then 
left-click again in a cell in the programming grid to insert the element.
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Rung Header

Introduction Use the Rung Header dialog box to edit a Rung Header. A Rung Header appears 
directly above a rung and documents the purpose of the rung in a ladder diagram.
See Using Rung Headers, p. 195 and Programming in Ladder Language , p. 181.

Opening the 
Rung Header 
Dialog Box

To open a Rung Header dialog box, double-click on the Rung Header in the Ladder 
Viewer or double-click or right-click on the Rung Header in the Ladder Editor. If Rung 
Headers are not visible when using the Ladder Viewer, select Tools → Toggle 
Rung Headers from the main menu. Rung Headers are always visible when using 
the Ladder Editor.

Display Options The following options can be selected to display in the rung header. Enter selectable 
numbers in the Label/Subroutine/Step Number box:
� Standard 

Select to display the number of the rung in the ladder program (for example, Rung 
1). The number is automatically determined by the numeric order of the rung in 
the program.

� Label %Li:
Select to display a label number in the rung header (for example, %L1:). This 
number is selectable.

� Subroutine SRi:
Select to display a subroutine number in the rung header (for example, SR10:). 
This number is selectable.

� Initial Step =*=i
Select to display the Initial Step of a Grafcet program in the rung header (for 
example, =*=10). This number is selectable.

� Begin Step -*-i
Select to display the Begin Step of a Grafcet program in the rung header (for 
example, -*-7). This number is selectable.

� =*= POST
Select to display the Post-Processing Step of a Grafcet program in the rung 
header.

Label/
Subroutine/Step 
Number

Enter a number for the selected display option. Rung numbering is automatic when 
selecting Standard.

Title Enter one line of text for the name or description of the rung. Can consist of 1 to 122 
characters.
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Comment Enter up to four lines of text for comments about the purpose of the rung. Each line 
can consist of 0 to 122 characters.
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List Rung Editor

Introduction The List Rung Editor is a secondary program editor opened from the Ladder 
Viewer to edit rungs that could not be reversed to Ladder language.
This dialog box consists of two sections:
� The upper area contains the list program segment that could not be reversed to 

ladder.
� The lower area contains program errors and reversibility warnings.
See Programming in Ladder Language , p. 181.

List Rung Editor 
Window

The following is an example of the List Rung Editor window. 

Analyzing 
Modifications

After making changes, press Analyze to check the list program segment and update 
the Errors/Reversibility Warnings section. Press OK to accept modifications, 
close the dialog box, and return to the Ladder Viewer.

(  *  THIS LINE IS THE TITLE HEADER LINE  *  )
(  *  THE COMMENTS ARE PLACED BETWEEN  *  )
(  *  BRACKETS AND ASTERISKS  *  )

BLK        %TM1
LD          %I0.1
IN
OUT_BLK
LD          Q
ST          %Q0.3
LD          %I0

List Rung Editor

<ERROR>:  THE OBJECT  "%I0"  IS NOT A VALID OBJECT FOR THIS CONTROLLER
<REVERSIBILITY WARNING>:   THE RUNGS CONTAINS AN INSTRUCTION 

Errors / Reversibility Warnings

OK

Cancel

Validate

Help

List instructions

Display of errors and reversibility warnings
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List Editor

Introduction The List Editor is a simple line editor for creating and editing instruction list 
programs in List language.
See Programming in List Language , p. 227.

List Editor 
Window

The following is an example of the List Editor window. 

------      (*    THIS LINE IS THE TITLE HEADER LINE   *)
------      (*    THE COMMENTS ARE PLACED BETWEEN  *)
------      (*  BRACKETS AND ASTERISKS *)
     0      BLK         %TM1
     1      LD           %IO.1
     2      IN
     3      OUT_BLK
     4      LD          Q
     5      ST          %Q0.3
     6?    LD          %IO
------      (*    THE QUESTION MARK IN LINE 6    *)
------      (*    INDICATES A PROGRAM ERROR *)
     7      END_BLK

List editor 

F2 F3 F5
LD

F6 F7 F8 F9 F11 F12 F2 F3 F5 F6 F7 F8 F9 F11 F12
ST AND OR XOR IN MPS BLK SR JMP %I %Q %M %S %TM MRD OUT RETBLK

AF2 AF3 AF5
%L %IW %QW

AF6 AF7
%MW %SW

AF8 AF9
%C %MPP

List instruction bar CommentsTitle bar

Program instructions Editing area
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Parts of the List 
Editor

The following table describes parts of the List Editor.

Part Description

Title bar A bar at the top of the window that displays the name of the editor.

List instruction bar A bar beneath the title bar that displays symbols and associated 
keyboard shortcuts for instructions. A single left click on a symbol 
inserts the selected instruction at the location of the cursor in the 
editing area.

Editing area Contains instructions and comments. Instructions are entered and 
modified here.

Program instructions Line of instruction includes a line number, instruction code, and 
operand.

Comments Text you enter to document the program. Comments must be 
inserted within parenthesis and asterisks such as: (* comments 
go here *). 
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Configuration Editor

Introduction Use the Configuration Editor to view and assign configuration values for software 
resources and some hardware resources (see the Configuration Editor toolbar to 
identify which resources can be configured.)
� For configuring hardware not available from the toolbar, see Configuring 

Hardware, p. 125.
� See Using the Configuration Editor, p. 121.

Configuration 
Editor Window

The following is an example of the Configuration Editor window. 

Configuration editor

%R0        No        FIFO
%R1        Yes         LIFO
%R2        No        FIFO
%R3        No        FIFO

123
12377123 ??1

0
1
0

%R Util Type Symbol

Toolbar Column headings

Configuration data

Title bar

Display area
42    



Software Features
Parts of the 
Configuration 
Editor

The following table describes parts of the Configuration Editor.

Part Description

Title bar A bar at the top of the window that displays the name of the editor or 
viewer.

Toolbar A bar beneath the main menu bar that displays buttons for selecting 
software and hardware resources. Allows switching between configuring 
resources without closing the Configuration Editor.

Configuration data Displays current configuration for all available resource entries. Data is 
derived from the configuration dialog box for each resource.

Display area Configuration data is displayed here.

Column heading A panel above the configuration data with headings identifying the 
associated column of data. Some headings are displayed as part of the 
configuration data. The Used?column identifies which resources are 
used in the current application.
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Symbol Editor

Introduction  Use the Symbol Editor to create and manage symbols used in a program. The 
Symbol Editor can be viewed in both online and offline modes, but it is not available 
in the monitor state. The Symbol Table consists of columns for Symbols, Comments, 
and Addresses, organized like a spreadsheet with rows for defining individual 
symbols.
See Defining Symbols, p. 74.

Symbol Editor 
Window

The following is an example of the Symbol Editor window. 

TIMER

Symbol Editor

??

%TM0

INPUT0 %I0.0

1

2

3

Symbol Address Comment

Toolbar Column headings

Symbol table

Symbols

Title bar

Addresses Comments
44    



Software Features
Parts of the 
Symbol Editor

The following table describes the parts of the Symbol Editor.

Part Description

Title bar A bar at the top of the window that displays the name of the editor or 
viewer.

Toolbar Displays symbols for frequently used commands.

Symbol table Consists of Symbol, Comment, and Address columns. Displays 
information for currently assigned symbols.

Column headings A panel above the symbol data with headings identifying the 
associated column of data.

Address Column containing addresses of variables for assigned symbols.

Symbol Column containing the alphanumeric characters that describe a 
variable.

Comment Displays text you enter to describe a symbol.
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Find Symbol

Introduction Use the Find dialog box to locate a symbol or address in the symbol table of the 
Symbol Editor. This dialog box is opened from the Symbol Editor, p. 44.

Finding an 
Address or 
Symbol

To find an address or symbol:

Step Action

1 Enter the symbol or address in the Find box.

2 Select OK to close the box.

3 If found, the entry will be highlighted in the symbol table.

4 If you have searched for an address and it is not found, a warning box is displayed 
asking if you would like to create the address. Click on OK to open the Object 
Browser, p. 47 which you can use to create the address. 

5 If searching for a symbol and it is not found, a warning box is displayed asking if 
you would like to create the symbol. Select OK to open the Object Browser. See 
Defining Symbols, p. 74.
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Object Browser

Introduction The Object Browser dialog box is used to insert or edit symbols when using the 
Symbol Editor.
See Defining Symbols, p. 74.

Object Browser 
Dialog Box

The following screen is an example of the Object Browser dialog box. 

Object Browser

Filtering:

OK

Cancel

Configure

Previous

Next

Help

%I

%I0.0
%I0.1
%I0.2
%I0.3
%I0.4
%I0.5
%I0.6
%I0.7

Address:

%I0.0.2

This is an example of a symbol (TEST_I0)

Comment

Symbol:

TEST_I0

Symbol

Filter Comments

Title bar Address

Address List box

Configuration Button

Previous and 
Next Buttons
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Parts of the 
Object Browser

The following table describes parts of the Object Browser.

Part Description

Title bar A bar at the top of the window that displays the name of the editor or viewer.

Address Unique identifier of a controller variable. All addresses start with a percent 
(%) character.

Symbol An alphanumeric name associated with the corresponding address. A 
symbol can use a maximum of 32 characters and can only consist of the 
following characters: 0 to 9, A to Z, and underscores (_).

Filter Select from this list of all variables to display a specific type of variable.

Address List 
box

Displays all instances of variable type selected in the Filtering box.

Comments Optional text to provide a more detailed description of the symbol.

Configuration 
Button

Click to open the configuration dialog box for the selected variable.

Previous/Next 
Buttons

Select Previous or Next to scroll to the previous or next item without closing 
the dialog box.
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Program Errors Viewer

Introduction The Program Errors Viewer window displays program errors and warnings when 
analyzing a program by selecting Program → Analyze Program from the main 
menu.
See Analyzing a Program, p. 72.

Program Errors 
Viewer Window

The following is an example of the Program Errors Viewer window. 

Types of Errors There two categories of errors reported in the Program Errors Viewer window:

<ERROR>   Line   1   :     UNABLE TO ACTIVATE OR DEACTIVATE A GRAFCET STEP WHICH HAS NOT BEEN DECLARED.
<ERROR>   Line   2   :     INVALID INSTRUCTION FORMAT
<ERROR>   Line   4   :     UNABLE TO ACTIVATE OR DEACTIVATE A GRAFCET STEP WHICH HAS NOT BEEN DECLARED.
<ERROR>   Line   5   :     UNABLE TO ACTIVATE OR DEACTIVATE A GRAFCET STEP WHICH HAS NOT BEEN DECLARED.
<REVERSIBILITY WARNING>   Line  2   :      A LINE CONTAINING AN INVALID INSTRUCTION CANNOT BE REVERSED

Program Errors

??
Err.

Part Description

Errors Indicates a problem in the application that prevents creation of an 
executable program.

Reversibility warning Reports on instructions that are not reversible or may cause 
operational uncertainties.
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Cross References Viewer

Introduction The Cross References Viewer displays a list of operands, symbols, line or rung 
numbers, and operators.  This simplifies locating these items in the application for 
troubleshooting and debugging. 
See Cross Referencing an Application, p. 102.

Cross 
References 
Viewer

The following is an example of the Cross References Viewer window. 

Parts of the 
Cross Reference 
Viewer

The following table describes the parts of the Cross References Viewer.

Cross Reference

Q

Operand Symbol

%I0.0 WATER_TEMP

%I0.1

%Q0.3 WASHER_ON

Rung Operator

3

7

5

0

2

6

IN

BLK:   END

LD

LD

LD

ST

Ref-
Cross

4 BLK:   OUT

%TM1 START_TIME_DELAY 1 BLK

Column headings

Operands Symbols Line Numbers Operators

Part Description

Title bar A bar at the top of the window that displays the name of the editor or 
viewer.

Column headings A panel above the display area with headings identifying the 
associated column of data.

Operands Addresses of variables.

Symbols Alphanumeric characters that describe a variable.

Lines Line or rung numbers of the item in a program.

Operators Indicate the operation to be performed.
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Animation Tables Editor

Introduction  Use the Animation Tables Editor to view values of variables when a PC is 
connected to a controller which is either running or stopped. Animating variables is 
useful for Debugging and Adjusting an Application , p. 251. You can view changes 
in variables as a program runs to compare the actual values against expected 
values.
See Using the Animation Tables Editor, p. 254. 

Using Animation 
Tables

Use the Animation Tables Editor to:
� Monitor the current value of any variable in the controller.
� Force inputs and outputs.
� Change the value of variables independent of calculated values, until they are 

updated again.
� Backup the current values of all variables in an animation table.
� Restore the retained values of all variables in an animation table to the controller.
See Defining Symbols, p. 74.

Animation 
Tables Editor 
Window

The following is an example of the Animation Tables Editor window. 

%TM0.P

Animation Tables Editor

??

* MYTIMER0.P

%I0.0.0 *

%TM0.Q * MYTIMER0.Q

1

2

3

Address Current Symbol

%TM0.V * MYTIMER0.V

%Q0.0.1 * OUTPUT1

4

5

6

Retained Format Valid

0

0

0

0

0

Decimal

Decimal

Decimal

Decimal

Decimal

1 0

Toolbar Column headingsTitle bar

Address Animation table
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Parts of the 
Animation Table 
Editor

The following table describes the parts of the Animation Tables Editor.

Item Description

Title bar A bar at the top of the window that displays the name of the editor or 
viewer.

Toolbar Displays buttons for frequently used commands.

Animation table Consists of data in the editor: Address, Current, Retained, Format, 
Symbol, and Valid.

Column headings A panel above the table with headings identifying the associated 
column of data.

Address Unique identifier of a variable always preceded with a percent symbol 
(%).

Current During animation, displays the Current value of the corresponding 
variable.

Retained Retained value to be written to the controller when a Write retained 
values action is performed.

Format Identifies the number format of the data variable. Options are Decimal, 
Hexadecimal, Binary, Floating Point or ASCII.

Symbol Alphanumeric characters associated with the address, if any.

Valid Indicates if the variable or object has been validated. If not validated, 
the variable has not been allocated memory space in the controller 
and cannot be animated. A green check mark indicates a valid variable 
or object that is part of the currently opened application, while a red X 
identifies a variable or object as not valid and is not part of the currently 
opened application.
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2.3 Operating Modes

At a Glance

Overview This chapter describes the operating modes and operating states of TwidoSoft.

What's in this 
Section?

This section contains the following topics:

Topic Page

Offline and Online Operation 54

Operating States 55
   53



Software Features
Offline and Online Operation

Introduction TwidoSoft operations are either Online or Offline depending on the connection 
between the PC and the controller.
� In Online operation, the PC is connected to the controller.
� In Offline operation, the PC and controller are disconnected. 
See Connecting a PC to the Controller, p. 89.

Offline Use Offline operation to develop an application.
The PC is not connected to the controller. Changes are made only to the application 
in PC memory. The application must be transferred from the PC memory to the 
controller memory to run the application on the controller (see Transferring an 
Application, p. 80).

Online Use Online operation to debug and adjust an application.
The PC is connected to the controller. The application in the PC memory is the same 
as the application in the controller memory. Changes can be made directly to the 
application in the controller memory (see Debugging and Adjusting an Application , 
p. 251).
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Operating States

Introduction Operating States indicate the offline or online status of TwidoSoft, and specify the 
operations that are allowable. There are four operating states:
� Initial
� Offline 
� Online 
� Monitor
The current operating state is displayed at the rightmost of the status bar. 
See Offline and Online Operation, p. 54.

Initial State The Initial state is the startup state when TwidoSoft is first started or when an 
application is closed. Available options:
� Open an existing application.
� Create a new application.
Only one application can be open at the same time. 

Offline State When you open a new or existing application, the operating state changes to the 
Offline state. Available options:
� Create and edit program instructions and configuration data.
� Create and edit data variables, symbols, and comments.
To connect the PC to the controller, select Controller → Connect from the main 
menu.

Online State An application in the Online state is directly connected to the controller memory. 
You have unrestricted access to an application, and changes to the application 
program and data variables are directly written to controller memory. Program 
documentation such as symbols and comments remain in the PC memory. Available 
options:
� Operate the controller.
� View animation of program and data.
� Limited access to program for debugging.
Both of the following conditions are required for the online state:
� The controller application must not be protected.
� The application in the PC must match the application in the controller.
There are two methods for matching applications: 
� Download the application from the PC to the controller.
� Upload the application from the controller to the PC.
To return to the Offline state, select Controller → Disconnect from the main menu 
bar. You can also select the Close option from the File menu to return to the Initial 
state without passing through the Offline state. If you select Close, you will be 
prompted to save your changes.
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Monitor State In the Monitor state, you can change operating states and make adjustments to the 
controller. Available options:
� Start or stop the controller.
� View, modify, or transfer data using the Animation Tables Editor.
You can not use the List or Ladder editors, Symbol Editor, or the Configuration 
Editor in the Monitor state. If the controller is protected, the Monitor state is the only 
online state available. 
If the controller is in the Offline state, and you want to monitor an unprotected 
application in the controller that is different than the application in PC memory, enter 
the Monitor state.
To return to the Offline state, select Controller → Disconnect from the main menu 
bar.
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Managing Applications 
At a Glance

Overview This chapter provides details for creating and managing applications for Twido 
programmable controllers. 

What's in this 
Chapter?

This chapter contains the following sections:

Section Topic Page

3.1 Accessing Applications 58

3.2 Creating and Developing Applications 65

3.3 Transferring Applications 79

3.4 Running Applications 87

3.5 Cross Referencing an Application 101

3.6 Printing Applications 105
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Managing Applications
3.1 Accessing Applications

At a Glance

Overview This section provides procedures for accessing TwidoSoft applications.

What's in this 
Section?

This section contains the following topics:

Topic Page

Starting and Exiting TwidoSoft 59

Opening and Closing Applications 60

Security Features 61

Set Security Level 62

Change Password 64
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Starting and Exiting TwidoSoft

Starting 
TwidoSoft

The installation procedure for TwidoSoft created one or more of the following options 
for starting the software, depending on selections made during installation.
Select one of the following options to start TwidoSoft:
� Double-click on the TwidoSoft icon on the Windows desktop.
� Select the TwidoSoft program from the Windows Programs menu.
� Select Run from the Windows Start menu and browse for the TwidoSoft program. 
TwidoSoft starts and the main window is displayed (see Main Window, p. 22).

Exiting 
TwidoSoft

To exit TwidoSoft:

Step Action

1 Select File → Exit from the main menu. 
If there no changes, the application closes and TwidoSoft exits to the Windows 
desktop.
If there are changes, an Exit Warning dialog box is displayed prompting you to 
save changes.

2 Select Yes to save changes and exit TwidoSoft. Select No to discard changes 
and exit TwidoSoft, Select Cancel to return to TwidoSoft with changes intact,

3 If this is the first time the application has been saved, see Save As, p. 71.
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Opening and Closing Applications

Introduction Only one application can be open at the same time. If you attempt to open a second 
application, a dialog box is displayed prompting you to close the current application 
before opening another.

Opening an 
Application

From the main window, perform the following steps to open an application.

Closing an 
Application

From the main window, perform the following steps to close an application.

Step Action

1 Select File → Open from the main menu.

2 Type a file name of the application file or browse to locate the file (default 
extension is .TWD).

3 When the application file is located, press Open.
The file opens with the Application Browser displayed and the List Editor or the 
Ladder Editor displayed depending on the status of the settings saved in user 
preferences (see Preferences, p. 28).
On the status bar, the state has changed from initial to offline. The file name and 
path of the application file appears in the title bar of the main software window. 

Step Action

1 Select File → Close from the main menu. 
If there are changes to the open application, the Exit Warning dialog box will be 
displayed.

2 In the Exit Warning dialog box, select Yes to save changes, select No to discard 
changes, or select Cancel to return to the application file without exiting the 
software.
If there are no changes, TwidoSoft closes and returns to the Windows desktop.
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Security Features

Introduction TwidoSoft provides two options for protecting an application:
� Controller application protection: The controller application cannot be viewed, 

changed, or transferred. 
� Password Protection: Passwords are used to control access to an application.

Controller 
Application 
Protection

Controller application protection prevents access to the controller application, but 
not to the PC application. This option prohibits unauthorized transfers of an 
application and is selectable when transferring an application to the controller (see 
Transferring an Application, p. 80).
A controller application that is protected:
� Cannot be modified.
� Cannot be transferred to PC RAM memory.

Password 
Protection

Password protection controls access to both the PC and the controller application 
after an application has been transferred from the PC to the controller. A controller 
application that is password protected:
� Cannot be modified unless the password is entered.
� Cannot be transferred to PC RAM memory unless the password is entered.
� Cannot be overwritten by the application in PC RAM memory unless the 

password is entered.
� Can be erased.

See Set Security Level, p. 62.

Note: It is very important to remember the password. Without it, you will not have 
access to the application!
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Set Security Level

Introduction Use the Set Security Level dialog box to apply password protection to an 
application. Password protection controls access to an application to prevent 
unauthorized changes.
See Change Password, p. 64.

Password 
Protection

Defining a password restricts access by creating two Security Levels:
� Operator Level: Does not allow changes to the application program and 

configuration data. Allows changes only to symbols and animation tables.
� Supervisor Level: Allows changes to any part of an application.
A password must consist of from one to eight characters.

Applying 
Password 
Protection

To apply password protection to an application:

Removing 
Password 
Protection

To remove password protection from an application:

Note: At the Operator Level,  you must enter the password to transfer a password-
protected application from the PC to the controller. 

Step Action

1 Open an application requiring password protection.

2 Select Program → Change Password from the main menu.

3 Type a password in Enter New Password. 

4 Select OK to close the box.
The application must be saved to retain the password.

Step Action

1 Open an application with password protection.

2 Select Program → Change Password from the main menu.

3 Type the current password in Enter Old Password. Do not enter a new password, 
tab through the other boxes.

4 Select OK to close the box.
The application must be saved to remove password protection.
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Opening an 
Application with 
Password 
Protection

Security level can be selected when opening an application. A password is required 
to use the Supervisor Level. To set the security level to Operator or Supervisor:

Changing from 
Operator to 
Supervisor

In an open application, you can change the security level in order to modify the 
application. The Supervisor Level is required to make changes to an application. To 
change from Operator to Supervisor level:

Changing from 
Supervisor  to 
Operator

The security level must be reset to Operator Level after making changes to ensure 
unauthorized changes are not made by anyone else using the application. The Set 
Security dialog is not available at the Supervisor Level, so you will need to save 
your changes, close the application, and then reopen it at the Operator Level. To 
change from Supervisor to Operator level:

Step Action

1 Open an application that has password protection.
An information box dialog box is displayed allowing you to change security levels.

2 To open application at Operator Level, select Cancel.
The application opens at the Operator Level.

3 To open the application at the Supervisor Level, select OK.
The Security dialog box is displayed.

4 Type in the password and select OK to open the application at the Supervisor Level.

Step Action

1 Open an application at the Operator Level.

2 Select Program → Set Security Level from the main menu.

3 Type the password in the Security dialog box.

4 Select OK to close the box.
The application must be saved to retain the Supervisor Level.

Step Action

1 Open an application at the Supervisor Level.

2 Save any changes and close the application.

3 Reopen the application.
An information box dialog box is displayed allowing you to change security levels.

4 Select Cancel to open the application at the Operator Level.
You will need the password to change the security level to Supervisor in order to 
make changes to the application.
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Change Password

Introduction Use the Change Password dialog box to change an existing password.
See Security Features, p. 61.

Changing a 
Password

To change a password:

Step Action

1 Open an application with password protection.

2 Select Program → Change Password from the main menu.

3 Enter the old password. 

4 Enter the new password.
A password must consist of from one to eight characters.

5 Confirm the new password by entering it again.

6 Select OK to close the box.
The application must be saved to retain the new password.
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3.2 Creating and Developing Applications

At a Glance

Overview This section provides procedures for creating and developing TwidoSoft 
applications.

What's in this 
Section?

This section contains the following topics:

Topic Page

Creating an Application 66

Developing an Application 67

Naming an Application 70

Saving an Application 71

Analyzing a Program 72

Defining Symbols 74

Reversing a Program 77

Importing and Exporting ASCII 78
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Creating an Application

Introduction A TwidoSoft application consists of a program, configuration data, symbols, and 
documentation. These components can be used in any order when creating an 
application. For example, an application can be developed in the following order:
1. Define configuration data.
2. Define symbols,
3. Write program instructions,
4. Add comments and print documentation.
This is just one method to organize these tasks; these could just as easily been done 
in reverse order. The TwidoSoft editors and viewers allow separate development of 
each part of an application, as a result, the application development process is more 
systematic with more clearly defined applications.

Creating a New 
Application

From the main software window, perform the following steps to create a new 
application.

Step Action

1 Select File → New from the main menu. 
The Application Browser is displayed and either the List Editor or the Ladder 
Editor is opened depending on the default editor selection (see Preferences, 
p. 28). On the status bar, the state has changed from Initial to Offline Mode.

2 Select File → Save or File → Save As from the main menu.
The File Selection dialog box is displayed.

3 Enter a file name for the application file. This is the file name external to the 
application. The application can also have an internal name which is different 
from the file name (see Naming an Application, p. 70).
The file name is created with the default extension of .TWD. Unless another 
directory is selected, the file will be saved in the \applications sub-directory of the 
TwidoSoft installation directory. The file name and path are displayed in the title 
bar of the main software window.

4 See Developing an Application, p. 67 for guidelines in developing an application.
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Developing an Application

Introduction The following flow charts identify recommended steps and associated sections in 
this manual for creating applications using TwidoSoft.

Development 
Phases

In general, developing an application requires two phases:
� Design Phase

This is the first stage of development and requires a careful analysis of 
requirements for your application. Once a plan is created, the application is 
created requiring configuration, program creation, and archiving.

� Debug and Adjust Phase
The final stage begins once an application is created. The application is 
transferred to the controller, started, and checked for errors or any required 
adjustments or modifications. Further backups and transfers may be needed.
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Design Phase The following flow chart illustrates the design phase for an application. 

• Program
• Requirements

• Hardware
• Function blocks
• Inputs
• Outputs
• Constants

• Create
• Insert
• Modify
• Delete
• Duplicate

• To EEPROM
• To hard drive
• To floppy drive

See Developing a Ladder Program

See Archiving an Application 

See Developing a List Program

Configure schedule blocks See Software Configuration

Step #1

Step #2

Step #3

Step #4

Preliminary
Planning

Configure resources

Analyze

Enter program

Archive

See Hardware Configuration

See Software Configuration

Note: An optional approach is to perform Steps #1 and #2 in parallel with Step #3. 
The application can be configured at the same time the program is created.
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Debug and 
Adjust Phase

Perform the debugging and adjusting phase in the online or monitor state. The 
following flow chart illustrates debugging and adjusting an application. 

• Adjust clock
• Initialize
• RUN application

• Animation table entry
• Forcing
• Modification in RUN

• To EEPROM
• To hard drive
• To floppy drive

Application 
in

 online mode

See Transferring an Application

See Starting an Application

See Debugging and Adjusting 
an Application

Application 
in

 offline mode

See Archiving an Application

See Transferring an Application

Archive

Startup

Transfer application

Debug and adjust
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Naming an Application

Introduction An application can have two names:
� File Name

The external name for a TwidoSoft application with a 3-letter extension indicating 
that it is an executable program. Used by the Windows operating system for file 
management operations and must follow Windows guidelines for file names. For 
example, NEW_APP.TWD.

� Application name
The internal name for a TwidoSoft application. An application name can be 
modified without any effect on the external file name. Provides more flexibility for 
application names. For example, car wash #2. 

File Name A file name can contain up to 255 characters, including spaces. But, it cannot 
contain any of the following characters: \ / : * ? " < > . Use File → Save or File → 
Save As to assign a file name for an application.
See Saving an Application, p. 71.

Application 
name

A new application has a default name of untitled. Use the Application Name, p. 179 
dialog box to change an application name. To open this dialog box, select Program 
→ Rename from the main menu, or right-click on the application name at the top of 
the Application Browser, p. 24.
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Saving an Application

Introduction An application can be archived by selecting Save or Save As commands from the 
File menu.

Save As Select File → Save As from the main menu for the initial save of an application, or 
to save the application to a different file name (see Naming an Application, p. 70). 
From the main window, perform the following steps.

Save Select File → Save from the main menu to save changes to an open application 
after the initial save or rename of the application. Changes will be made to the open 
application file in the current directory. Selecting Save for an application that has not 
yet been saved will open the Save As dialog box.

Step Action

1 Select File → Save As from the main menu.

2 Select a directory. The default current directory is the installed directory for the 
TwidoSoft program.

3 Enter a file name for the application. File names can be up to 255 characters.
Note: Do not use any of the following characters: \:*?<>|". 

4 Click the Save button.
The application file name is saved with the default extension of TWD. The file 
name and path are displayed in the title bar of the main window. 
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Analyzing a Program

Introduction Programs must be free from errors to be transferred to the controller. Select 
Program → Analyze Program from the main menu to compile a program and check 
for errors.

Analyze Program In addition to compiling a program, Analyze Program performs the following:
� Checks that the application will fit in available PLC memory.
� Checks for correct syntax of each program line or rung.
� Checks that each symbol used in a program has a corresponding address.
� Checks that the structure of the program is correct.
� Checks that the resources used by the program are compatible with the hardware 

configuration (I/O addresses are valid for the configured PLC, expansion 
modules, and so).

� Displays messages in the Program Errors window.

Analyzing a 
Program

Use the following steps to analyze a program in the offline or online states.

Viewing Program 
Errors

Select Program → View Program Errors from the main menu to display the 
Program Errors window.
The format for each message:
� The type of message - error or warning.
� The number of the line or rung containing the error or warning.
� An explanation of the problem.

Step Action

1 Offline state: Select Program → Analyze Program from the main menu to 
check and compile a program at any time and from any editor.

2 Online state: In the online state, each program line is automatically validated as 
it is entered and before it is sent to the PLC. Programs entered in the online state 
do not need to be validated. (You can still validate a program as a precaution.)

3 If a program does not contain any errors, an Information dialog box will be 
displayed stating the following: 
� The program contains no errors or warnings.
� The program is executable and CAN be transferred to the PLC.

4 If a program contains any errors, an Information dialog box will be displayed 
stating the following: 
� The number of program errors and warnings.
� The program is not executable and CANNOT be transferred to the PLC.
� See Program Errors Viewer, p. 49.
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Types of Error 
Messages

There are two types of error messages:
� Error

An error message indicates a problem in the application that prevents the 
creation of an executable program. 

� Warning
A warning message reports on instructions that are not reversible or may cause 
erratic operation.

Note: Double-clicking on the error returns you to the location of the error program 
(list or ladder) window.
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Defining Symbols

Introduction Use the Symbol Editor, p. 44 to assign easy-to-recognize alphanumeric names 
called symbols to data variables in a program. Using symbols allows for quick 
examination and analysis of program logic, and greatly simplifies the development 
and testing of an application.
For example, WASH_END is a symbol that could be used to identify a timer function 
block that represents the end of a wash cycle. Recalling the purpose of this name 
should be easier then trying to remember the role of a program address such as 
%TM3.

Guidelines for 
Using Symbols

When to define symbols:
� You can define symbols using the Symbol Editor before, during, or after writing a 

program.
� A symbol without a variable address is an unresolved symbol. You can write a 

program with unresolved symbols while you are designing program logic. You 
can complete the symbol table once you complete the program.

Rules for 
Defining 
Symbols

Defining a symbol requires:
� A maximum of 32 characters.
� Letters (A-Z), numbers (0 -9), or underscores (_).
� First character must be an alphabetical or accented character.
� No spaces or special characters.
� Not case-sensitive. For example, Pump1 and PUMP1 are the same symbol and 

can only be used once in an application.
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Creating a 
Symbol

To create a new symbol:

Editing a Symbol To edit an existing symbol:

Step Action

1 Open the Symbol Editor.

2 Left-click on an empty Symbol cell and enter a variable or object.

3 Press ENTER.
The Object Browser, p. 47 opens.

4 If you know the address of the variable, enter in the Address list box, or use the Filter 
box to narrow your choices to one type of variable.

5 Enter an alphanumeric name for the variable in the Symbol box. A symbol can be up 
to 32 characters and consist of the following: 0 to 9, A to Z, or underscores.

6 Optionally, enter text in the Comment box describing the symbol usage in more detail 
(up to 128 characters.)

7 A variable can be configured directly from the Symbol Editor by clicking on the 
Configure button.

8 Use the Previous and Next buttons to select other instances of the variable.

9 Click on OK to save changes and close the dialog box and return to the Symbol 
Editor.

Step Action

1 Open the Symbol Editor.

2 Double-click on a symbol entry in a cell to open the Object Browser, p. 47. 

3 Make changes to the symbol using the Object Browser.

4 Click on OK to save changes and close the Object Browser dialog box.

5 Optionally, enter text in the Comment box describing the symbol usage in more detail 
(up to 128 characters.)

6 A variable can be configured directly from the Symbol Editor by clicking on the 
Configure button.

7 Click on OK to save changes and close the dialog box and return to the Symbol 
Editor.
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Deleting a 
Symbol

To delete a symbol:

Sorting the 
Symbol Table

Entries in a symbol table can be sorted by address or symbols:
� To sort by address, select Tools → Sort by Address from the main menu or click 

on the toolbar shortcut.
� To sort by symbol, select Tools → Sort by Symbol from the main menu or click 

on the toolbar shortcut.

Finding a Symbol To search for a symbol in the symbol table:

Step Action

1 Open the Symbol Editor.

2 Click on the symbol cell of the entry you want to delete.

3 Select Tools → Delete Row, or click on the toolbar shortcut, or click on the DELETE 
button.
The symbol row is deleted.

Step Action

1 Open the Symbol Editor.

2 Select Tools → Find Symbol from the main menu, or click on the toolbar shortcut.
The Find Symbol dialog box is opened.

3 See Find Symbol, p. 46 for instructions.
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Reversing a Program

Introduction An application written in ladder language can be converted or reversed to list 
language. A program written in list language can be reversed to ladder language if 
the instructions follow the Reversibility Guidelines which are located in the 
Software Reference portion of the Twido User Reference Manual.

Reversing a 
Program

Reversing a program is simply alternating the selection of the list and ladder editors 
from the Program menu. Use the following steps to reverse a program in the offline 
or online states.

Note: Any portions of a List program that do not meet the rules for reversibility will 
not be displayed as Ladder rungs in the Ladder Editor but as List instructions in the 
List Rung Editor, p. 39. 

Step Action

1 With an open application, select Program → Ladder Editor from the main menu.
The Ladder Viewer is displayed, and the program is displayed as ladder rungs. 

2 To reverse the program to list language, select Program → List Editor from the 
main menu.
The List Editor is displayed, and the program is displayed as list instructions.
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Importing and Exporting ASCII

Introduction Program instructions that have been exported in ASCII text format from a TwidoSoft 
application can be imported into another TwidoSoft application program. Only 
program instructions can be imported or exported. These ASCII files are saved with 
a file extension of TXT. 
If you try to import ASCII text created in a program other than TwidoSoft (e.g. 
PL707), you must carefully check that the user application continues to function 
correctly.  You should note that the following PL707 instructions have been deleted 
or re-defined in TwidoSoft: %FC, MCR, MCS, EXCH, %MSG, %PLS, %PWM.

Exporting ASCII 
Text

To export an ASCII text file from an open application:

Importing ASCII 
Text

To import an ASCII text file into an open application or a new application:

Step Action

1 Select Program → Export ASCII Program from the main menu.
The Save As dialog box opens.

2 Enter a name for the text file and press Save. 
The program instructions from the open application are saved in ASCII format.

Step Action

1 Select Program → Import ASCII Program from the main menu.
The Open dialog box opens.

2 Select an ASCII text file with the file extension .txt, and press Open. (This file must 
have been exported from a TwidoSoft application.)
The program instructions are inserted as new instructions for a new application, or 
are added to the end of a program in a open application.
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3.3 Transferring Applications

At a Glance

Overview This section provides procedures for transferring TwidoSoft applications.

What's in this 
Section?

This section contains the following topics:

Topic Page

Transferring an Application 80

Transferring an Application: PC => Controller 81

Backup 82

Restore 83

Memory Backup Cartridges 84

Erase 86
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Transferring an Application

Introduction An application can be transferred to or from the following hardware storage areas:
� PC RAM
� Controller RAM
� Controller EEPROM
� Backup cartridge

Types of 
Transfers

The following table describes the types of application transfers that are available 
from the Controller menu. Applications can be transferred in the Offline and Online 
states, but the controller must be stopped to transfer applications in the Online state 
(see Operating States, p. 55).

Selection Description

Transfer PC => Controller Transfers a copy of an application from PC RAM memory to 
controller RAM memory.
See Transferring an Application: PC => Controller, p. 81.

Backup Transfers a copy of an application from controller RAM 
memory to the internal EEPROM and to the optional external 
backup cartridge (if installed).
See Backup, p. 82. 

Restore Transfers a copy of an application from the internal EEPROM 
to controller RAM memory.
See Restore, p. 83. 

Erase Although not a transfer procedure, the Erase command 
selectively erases the contents of the above storage areas. 
Erase has two options:
� Erase all
� Erase backup cartridge only
See Erase, p. 86. 

Note: 
If there is no application in TwidoSoft at the time of connection, the application is 
transferred from the controller automatically.
If there is an application in TwidoSoft, a window is displayed asking you to choose 
the direction of transfer. You can either overwrite the application in the controller 
with that from the PC (PC=>Controller transfer direction), or you can update the 
application in TwidoSoft (Controller =>PC transfer direction).
This type of transfer is only performed at the time of connection.
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Transferring an Application: PC => Controller

Introduction To run an application, you must first connect the PC to the controller then transfer 
the application to the controller.

Transfer PC => 
Controller

To transfer an application from the PC RAM to the controller RAM:

Symbols and program comments are not transferred to the controller.

Step Action

1 Select Controller → Transfer PC => Controller from the main menu.
If the controller application is password protected, you are prompted for a 
password.

2 Enter the password and select OK to continue the transfer.
If the controller is running, a warning box is displayed stating that to continue the 
transfer, the controller must be stopped.

3 If the controller is stopped, the transfer begins. If the controller is running, select 
OK to stop the controller and continue the transfer. Select Cancel to close the box 
and cancel the transfer. 
A warning dialog box is displayed indicating that the contents of the controller 
application will be overwritten.

4 Select OK to continue the transfer.
A controller menu option can be used to protect the application (see Security 
Features, p. 61).

5 To run the application, select Controller → Run (RUN) from the main menu. 
See Run, Stop, and Initialize, p. 96.
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Backup

Introduction The Backup command copies an application (program and constants) from the 
controller RAM memory into the internal EEPROM memory and the optional Backup 
Cartridge (if installed). It is strongly recommended that an application be backed up 
to EEPROM as soon as it is debugged. Backup must be performed in the Online 
state.
See Memory Backup Cartridges, p. 84. 

Backing Up an 
Application

To Backup an application from controller RAM to internal EEPROM memory and a 
backup cartridge (if installed):

Note: While a backup is in progress, the controller cannot be running, and no other 
operations can be performed by TwidoSoft. While the backup is being performed, 
the controller is in STOP mode.

Step Action

1 Select Controller → Backup from the main menu.
The controller must be stopped to perform a backup. If the controller is running, 
a dialog box is displayed allowing you to stop the controller.

2 If the controller is stopped, the transfer begins. If the controller is running, 
select OK to stop the controller and continue the transfer. Select Cancel to 
close the box and cancel the transfer.
During the transfer, Backing up application is displayed in the message area 
of the Status Bar, p. 27. 
When the transfer is complete, Backup complete is displayed in the message 
area. The application is now in EEPROM memory and the backup cartridge (if 
installed).
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Restore

Introduction The Restore command copies an application from the internal EEPROM to 
controller RAM memory. Restore must be performed in the Offline state. 

Restoring an 
Application from 
Internal EEPROM

To Restore an application from the internal EEPROM to controller RAM:

Note: While a restore is in progress, the controller cannot be running, and no other 
operations can be performed by TwidoSoft. While the restore is being performed, 
the controller is in STOP mode.

Step Action

1 Confirm that a Backup Cartridge is not installed, and select Restore from the 
Controller menu.
The controller must be stopped to perform a restore. If the controller is running, 
a dialog box is displayed allowing you to stop the controller.

2 If the controller is stopped, the transfer begins. If the controller is running, 
select OK to stop the controller and continue the transfer. Select Cancel to 
close the box and cancel the transfer.
During the transfer, the message Restoring application is displayed in the 
message area of the Status Bar, p. 27.
When the transfer is complete, Restore complete is displayed in the message 
area. The application is now in controller RAM memory.
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Memory Backup Cartridges

Introduction Twido provides optional Memory Backup Cartridges for the following functions:
� Backing Up an Application
� Expansion Memory

Available 
External Backup 
Cartridges

There are two options available:
� 32 KB Memory Backup Cartridge
� 64 KB Memory Backup Cartridge
The 32K cartridge can be used by all controller models, while the 64K cartridge is 
available for the following models:
� TWDLMDA20DRT
� TWDLMDA40DUK
� TWDLMDA40DTK

Using Backup 
Cartridges

An application can be transferred between a backup cartridge and controller RAM 
by the following methods:
� Manually by using Backup, p. 82. 
� Automatically at powerup if the optional backup cartridge is installed. At powerup, 

the application in the controller memory is compared to the application in the 
backup cartridge. If they do not match, the application in the backup cartridge is 
automatically downloaded to the controller memory and the EEPROM.

Restoring an 
Application from 
a Backup 
Cartridge

To Restore an application from an optional external Backup Cartridge to controller 
RAM:

Note: The memory cartridge overwrites the RAM and internal EEPROM at power 
up. Any application in RAM and EEPROM will be lost. Be sure to remove the 
memory cartridge when this functionality is not desirable.
If the internal battery is no longer charged, when you restart Twido after a power 
interruption, you will restore from either the external cartridge or the internal 
EEPROM. The external cartridge takes priority.

Step Action

1 Insert a Backup Cartridge into the controller, if not already installed.

2 Powerup the controller.
If the application in the cartridge and the application in the controller memory 
do not match, the application in the cartridge is automatically transferred to 
both the controller memory and the internal EEPROM.
84    



Managing Applications
Expansion 
Memory

The 64K cartridge provides memory expansion as well as backup. With the 64K 
cartridge installed, you can create an application that is up to 64K in size. The 64K 
cartridge must remain installed for running and backing up the application.

Programs Larger 
than 32K

The 64K Expansion Cartridge is required to run applications larger than 32K. The 
64K Expansion Cartridge must be "permanently" installed to provide this function. 
That is, if you are planning to create an application larger than 32K, install a 64K 
memory cartridge and leave it installed throughout development and configuration 
of the application.
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Erase

Introduction This is a command that can be used in two ways:
� To delete the contents of the controller RAM, the controller internal EEPROM, 

and the installed optional backup cartridge, all at the same time.
� To delete the contents of the installed optional backup cartridge only.

Options There are two options available in this dialog box:
� Erase all

This is the default selection. Selecting this option erases the contents of the 
controller RAM, the controller internal EEPROM, and the external backup 
cartridge (if installed).

� Erase backup cartridge only
Selecting this option erases the external backup cartridge only (if installed). 

Using Erase To Erase an application:

Note: Use the Erase backup cartridge only option when you do not want to lose 
your application when you reinsert the backup cartridge. If the applications do not 
match, the controller memory will be overwritten with the contents of the external 
cartridge.

Note: While an erase is in progress, the controller cannot be running, and no other 
operations can be performed by TwidoSoft. While an erase is being performed, the 
controller is in STOP mode.

Step Action

1 Select Erase from the Controller menu.
The Erase dialog box is displayed.

2 Select Erase All or Erase backup cartridge only in the dialog box, and select 
OK to close the dialog box and start the command.
The controller must be stopped to perform an erase. If the controller is running, 
a dialog box is displayed allowing you to stop the controller.

3 If the controller is stopped, the erase begins. If the controller is running, select 
OK to stop the controller and continue the erase. Select Cancel to close the 
box and cancel the erase.
During the erase, Erasing application is displayed in the message area of the 
Status Bar, p. 27. 
When the erase is complete, Erase complete is displayed in the message 
area.
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3.4 Running Applications

At a Glance

Overview This section provides procedures for running TwidoSoft applications.

What's in this 
Section?

This section contains the following topics:

Topic Page

Controller Operations 88

Connecting a PC to the Controller 89

Connect 91

Disconnecting a PC from the Controller 93

Controller Operations 94

Run, Stop, and Initialize 96

Set Time 97

RTC Configuration 98

Controller Operations - Advanced 99
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Controller Operations

Introduction TwidoSoft allows use of the PC to control the operation of the programmable 
controller. The dialog box is accessed by selecting "Controller" then "Operate 
Controller...". This switches you into Online mode if you were in Offline mode before. 
You can:
� Connect the PC to the controller.
� Disconnect the PC from the controller.
� Use the PC to Run, Stop, and Initialize the controller.
� Use the PC to operate the controller.
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Connecting a PC to the Controller

Introduction The following conditions are required to connect a PC to the controller:
� The hardware configurations and the application on the PC must be compatible 

with those on the controller.
� The controller is not protected (see Controller Application Protection in Security 

Features, p. 61).
If the PC fails to connect, see Connect, p. 91.

Overview of 
Connect Process

When connecting a PC to the controller, the following occurs:
� The application is analyzed for program errors. 
� TwidoSoft attempts to connect to the controller.
� The application in the PC is compared to the application in the controller. If they 

do not match, the Connect, p. 91 is opened. If they are the same, the PC is 
connected to the controller.

Connecting a PC 
to the Controller

To initiate communication between a PC and a controller:

Step Action

1 In an open application, select Connect from the Controller menu, or right-click on 
the Application Name in the Application Browser and select Connect.
"Connecting to the controller" is displayed on the Status bar.

2 The Connect, p. 91 dialog box is displayed when connecting to the controller if:
� Hardware configurations do not match for the PC and the controller.
� Applications do not match for the PC and the controller.
� The application in the controller is protected.

3 Select Cancel to exit the Connect dialog box and return to the Offline state.

4 Select Monitor if you only want to access Animation Tables and do not want to 
modify the program, configuration, and symbols for the application in the controller. 
The operating state changes from Offline to Monitor.

5 If the application in the controller is protected, the only available option is to click on 
the Monitor button to connect to the controller in Monitor state.

6 If the applications do not match, select one of the following:
� PC => Controller: transfer the open application in the PC to the controller.
� Controller => PC: transfer the application in the controller to the PC. 

7 If you selected PC => Controller, the download of the application from the PC to the 
controller is started. An information dialog box opens to confirm the following:
� Controller is running
� Overwrite the controller
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Application 
protection

By default, the application in the controller is not protected.
To protect an application:

8 Select OK to continue the transfer, or select Cancel to abort the transfer. If you have 
selected OK the transfer is completed and the PC connects to the controller. The 
main window is displayed, the status bar displays Controller Connected, and the 
operating state changes from Offline to Online.

9 If you selected Controller => PC, the application in the controller is transferred to 
the PC. The operating state changes from Offline to Online. The main window is 
displayed, the status bar displays Controller Connected, and the operating state 
changes from Offline to Online.

Step Action

Step Action

1 Select the Controller menu then Protect application.

2 Check the box to protect the application or uncheck to cancel the protection.
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Connect

Introduction This dialog box is displayed if a PC failed to connect to the controller because the 
application on the PC is different from that on the controller.
See Connecting a PC to the Controller, p. 89.

Reasons for 
Failing to 
Connect

The following will cause a PC to fail to connect to the controller:
� Hardware configurations for PC and controller do not match.
� The application on the PC does not match that on the controller.
� Application in controller is protected (see Security Features, p. 61).

Additional 
Messages

The Connect dialog box also displays the following:
� Hardware configuration different (cannot transfer PC => Controller)
� Controller application protected (cannot transfer Controller => PC)
An applicable condition is indicated by a checked box.

Options The following options are available from the Connect dialog box:
� PC => Controller

Transfer the application in the PC to the controller. Not available if the hardware 
configurations are not compatible.

� Controller => PC
Transfer the application in the controller to the PC. Not available if the controller 
is protected. See Controller Application Protection in Security Features, p. 61.

� Monitor
Enter the Monitor state without a transfer for a limited access to an application 
running in the controller. See Operating States, p. 55.

� Cancel
Exit the Connect dialog box.

Hardware 
Configurations

If the hardware configuration of the controller is not compatible with the configuration 
specified in the application on your PC, you cannot transfer the application to the 
controller. You can enter the Monitor state to perform a subset of controller 
operations (see Operating States, p. 55).

Controller 
Application 
Protected

If the application in the controller is protected, then the option to transfer from the 
controller to the PC is disabled. You can also enter the Monitor state in this case.

Matching 
Applications

If the applications do not match, there are two options:
� Transfer the application in the PC to the controller (PC => Controller).
� Transfer the application in the controller to the PC (Controller => PC).
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PC => Controller Select this button to transfer your application on the PC to the controller. If the 
application on the controller is protected, you can choose to overwrite it. You can 
also select to protect the application you are currently transferring. 

Controller => PC Select this button to transfer the application on the controller to the PC. If you have 
an open application, you will be prompted to save any changes before the transfer 
begins.

Monitor If the application and configuration on the PC do not match exactly those on the 
controller or the controller is protected, you can still connect in the Monitor state. 
This allows access to the application data pages and to operate the controller. You 
will be restricted from accessing the application program, configuration, or symbols.
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Disconnecting a PC from the Controller

Disconnecting 
PC From the 
Controller

To disconnect a PC from the controller:

Step Action

1 Select Disconnect from the Controller menu, or right-click on the Application 
Name in the Application Browser and select Disconnect.

2 When completed, "Controller Disconnected" is displayed on the status bar and 
the operating state changes to Offline.
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Controller Operations

Introduction Use this dialog box to remotely operate and view your controller. From this dialog 
box, you can:
� View status and system information.
� Run, Stop, and Initialize the controller.
� Enter time and date settings for the optional RTC.
� Configure the RTC Correction Factor.
� Perform Advanced Operations.

Status 
Information

The Status check boxes indicate the following:
� One or more input or output bits are forced to either a 1 or 0.
� An executable application is stored in the controller's RAM.
� The controller's RAM protection bit was set to 1 during the transfer process.

Switches The Switches boxes display the settings for all the potentiometers available on your 
controller. This is one 10-bit value for each of the controllers. All controllers have at 
least one potentiometer with the exception of the TWDLCAA24DRF which has two. 
For the TWDLCAA24DRF, the second  potentiometer can be set between 0 and 
511.

Scan Time The Current box in Scan Time displays the time in milliseconds that is required to 
solve the user logic, process inputs/outputs, and service the system and outstanding 
communications. This is the actual measured time required to complete the tasks to 
support the user application. This is different than the requested Periodic Scan 
Period that you can specify as the maximum allotted time to complete a scan (see 
Scan Mode, p. 177).
The minimum (Shortest) and maximum (Longest) scan times since the last power 
down are also displayed in milliseconds.

Real Time Clock 
(RTC)

These boxes are only valid when an RTC option cartridge (TWDXCPRTC) is 
installed on the controller. The Real Time Clock box display the current date, time, 
and the RTC correction factor set. You can change the date and time by selecting 
the Set Time button.

Configure RTC This button is only enabled when the Real Time Clock (RTC) optional cartridge 
(TWDXCPRTC) is installed on the controller. Click on this button to enter the RTC 
Correction Factor for the RTC.
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LED Display The LEDs on the base controller are simulated in the Controller Operations dialog 
box (for details about these LEDs, see the Twido Hardware Reference Guide).
The following are states of the simulated LEDs as they appear in the Controller 
Operations dialog box. For all simulated LEDs in the dialog box, a question mark 
(?) indicates communication has yet not been established.
For Inputs/Outputs (IN and OUT) LEDs:

For RUN and ERR LEDs:

The operation of the STAT LED is defined by user logic.

LED State Description

Extinguished I/O point is Off

Steady green I/O point is On

Has a lock symbol I/O point is forced to a 0 or 1
0 is extinguished with lock, and 1 is green with lock

RUN LED ERR LED Description

Extinguished Blinking red No valid configuration in 
controller

Blinking green Extinguished Controller is stopped

Steady green Extinguished Controller is running

Blinking green Blinking red Controller is halted

Extinguished Steady red Hardware or system error. 
Must cold restart
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Run, Stop, and Initialize

Introduction You can use the PC to issue the following commands to the controller:
� Run
� Stop
� Initialize
You must confirm the command in order for it to be performed.

Selecting These 
Commands

These commands can be selected from:
� The Controller menu.
� The toolbar of the main menu.
� The Application Browser, by right-clicking on the controller model number.
� The Controller Operations dialog box.

Run When the controller is running, the application program is executing. The controller's 
inputs are updated and data values are set according to the application instructions. 
This is the only state where the actual outputs are updated.

Stop When the controller is stopped, the application is not being executed. The 
controller's inputs are updated and internal data is held at its last values. Outputs are 
not updated in this state.

Initialize (Init) When the controller is initialized, the application is not executed. The controller's 
inputs are updated and data values are set to their initial state. No outputs are 
updated from this state.
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Set Time

Introduction Use the Set Time dialog box to enter time and date settings for the controller’s Real 
Time Clock (RTC). This button is only enabled when an RTC option cartridge 
(TWDXCPRTC) is installed on the controller.
See RTC Configuration, p. 98.

Setting the RTC To set the time and date for the RTC:

Step Action

1 Select Set Time from the Controller Operations dialog box.

2 Enter the current date in Controller Date. A valid date is in the format of day/
month/year (DD/MM/YY). For example, March 28, 2002 is entered as 28/03/02. 

3 Enter the current time in Controller Time, A valid time value is standard "military" 
format HH:MM. For example, 2:15 PM is 14:15.
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RTC Configuration

Introduction Use the RTC Configuration dialog box to enter the RTC Correction Factor for the 
Real Time Clock (RTC) option. The RTC option allows the controller to have a 
hardware Time of Day clock.
The RTC will keep the time even when the controller is not powered for a limited 
amount of time. When the RTC is not powered by the controller, the time will 
continue to be updated for 1,000 hours at 25 °C and 300 hours at 55 °C using a fully 
charged battery.
The RTC option cartridge (TWDXCPRTC) must be installed on the controller. This 
option is also required for using Schedule Blocks.

RTC Correction 
Factor

Configuring the RTC option requires entering the RTC Correction Factor. Each RTC 
has a correction value in decimal located on the part label. This correction value 
must be entered in the RTC Configuration dialog box so that TwidoSoft can 
initialize the RTC cartridge.

RTC Display When there is an RTC installed on the controller and it has a valid correction value, 
the Controller Operations dialog displays the following:
� Controller Date
� Controller Time
� RTC Correction
� Set Time button is enabled
If there is no RTC installed or is has an invalid correction value the date and time 
displays are blank and the Set Time button is disabled.

Configuring the 
RTC

To configure the RTC option:

Step Action

1 Click on the Configure RTC button in the Controller Operations dialog box. The 
installed RTC option is required.
The RTC Configuration dialog box is displayed.

2 Enter a decimal value between 0 and 127. See the label on the RTC part for this 
value. Default value is 0.

3 Select OK to accept the entered value and close the dialog box. Select Cancel to 
close the dialog box without making any changes.
The entered RTC Correction Value is added to the configuration of the PC and the 
controller (if connected).

4 The Controller Operations dialog now displays the current date and time and the 
current correction value and enables the Set Time button. Select Set Time to enter 
the current time and date for the RTC.
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Controller Operations - Advanced

Introduction The Controller Operations - Advanced dialog box displays the controller state 
system information in read-only. Use this information to check the controller RAM, 
internal EEPROM, and backup cartridge status and to diagnose problems.

RAM The following table describes the checked state of items in the RAM section.

EEPROM The following table describes the checked state of items in the EEPROM section.

PLC The following table describes the checked state of items in the Controller section.

Item Description

Executable A valid application is in controller RAM.

Protected The application in controller RAM is protected.

Compatible with Exec The version of the operating system in the controller is 
compatible with the application in controller RAM.

Different than EEPROM The application in the controller RAM is different than the 
application in the internal EEPROM.

Different than Cartridge The application in the controller RAM is different than the 
application in the backup cartridge. Only checked if there 
is a backup cartridge installed.

Item Description

Executable A valid application is stored in the internal EEPROM.

Protected The application in the internal EEPROM is protected.

Compatible with Exec The version of the operating system in the controller is 
compatible with the application in the internal EEPROM.

Item Description

Watchdog time-out The scan time of a program exceeded the maximum time 
allowed causing the controller to stop.

Real-time clock The controller has the Real Time Clock option cartridge 
(TWDXCPRTC) installed.

I/O Forced One or more base input or output bits were forced on or off.

Last Controller Stop Displays date and time of last controller stop.
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Backup cartridge The following table describes the checked state of items in the Backup Cartridge 
section.

Item Description

Executable A valid application is stored in the backup cartridge.

Protected The application in the backup cartridge is protected.

Compatible with Exec The version of the operating system in the controller is 
compatible with the application in the backup cartridge.
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3.5 Cross Referencing an Application

At a Glance

Overview This section describes how to Cross Reference an application.

What's in this 
Section?

This section contains the following topics:

Topic Page

Cross Referencing an Application 102

Generate Cross References 103
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Cross Referencing an Application

Introduction Cross referencing consists of selecting items in a program such as an address that 
you want to track in an application. Once the items are selected, then a list is 
generated displaying where the items are used in the application.
Cross referencing provides a useful list of the operands, symbols, lines and 
operators used in all or part of an application. Its primary use is during 
troubleshooting or debugging. It allows any item of interest to be easily located and 
cross-referenced to its locations in the application without having to search through 
the entire program.
See Generate Cross References, p. 103 and Cross References Viewer, p. 50.

Tips Some tips for using Cross References:
� Analyze the program before generating cross references.
� The Cross Reference List is not saved when the application is closed. You will 

have to regenerate it when the application is opened again.

Basic Steps There are five basic steps for cross referencing an application (see comment 
relating to Generate Cross References, p. 103):

Step Action

1 Select either list numbers or rung numbers for use as line references. 

2 Select the scope of the display by specifying a range of lines. 

3 Select the sort order of the list to be generated. 

4 Select the specific program items to included in the display.

5 Generate the cross reference list.
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Generate Cross References

Introduction Use this dialog box to create a list of cross references. You can:
� Select references using either line or rung numbers.
� Select the range of lines to include when generating the cross reference list.
� Select a sort order to display selected items.
See Cross Referencing an Application, p. 102 and Cross References Viewer, p. 50.

Opening the 
Generate Cross 
References 
Dialog Box

You can open this dialog box by selecting Program → Cross References from the 
main menu. However, once a cross reference list is created for an open application, 
you will have to select Tools → Generate Cross Reference from the main menu to 
regenerate the list.

When to 
Regenerate

In general, an existing cross reference list will need to be regenerated when any of 
the basic elements of an application are modified or the scope of the cross reference 
changed. Examples of these changes include:
� Lines or rungs have been added or deleted.
� Changes to the content or symbols for an application.
� The scope of the lines to include in the cross reference list has changed.
� The list of elements to include in the cross reference list has changed.

Reference By This box determines whether you want the line references to be by List line number 
or by Ladder rung number. By default, Ladder Rung Number is selected.

Range You can specify a range of lines by clicking on Start and entering the starting line 
number of a range in the Start box and an ending line number in the End box. The 
default selection is All: the cross reference list will use all lines of the application.

Sort By This selection determines the sort order to use when the cross reference list is 
displayed. These values correspond to the options in the Tools menu. By default, 
Operand is used to determine the sort order.
When the list is sorted by operand or symbol, a separation line is used to frame the 
information to make it easier to read.

Elements These boxes allow you to narrow the scope of the program items in you application 
to be displayed. For example, you can choose to list program lines or rungs that 
have timer function blocks by only selecting the Timers check box.
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Generating a 
Cross Reference 
List

To generate a cross reference list:

Step Action

1 In Reference By, select either rung or line numbers to use as line references.

2 Select a Range to use for generating the cross references.
Options: Select All Elements to include all lines in the program. Select Start to set 
a range by entering a Start line number and an End line number.

3 In Sort By, select the item to use for the sorting order.
Options: Operand, Symbol, Operator, or Line/Rung Number.

4 In Elements, select the items in the application to be displayed in the cross-
reference list. Select All Elements to check all selections.

5 Select OK to generate the cross-reference list and close the dialog box. Select 
Cancel to close the dialog box without changes.

6 If there are no occurrences for the selected elements, an information box is 
displayed with the following message: Cross Reference Empty. Select OK to close 
the information box.

7 If there are occurrences for the selected elements, the Cross References Viewer, 
p. 50 is opened displaying the cross-reference list.
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3.6 Printing Applications

At a Glance

Overview This section provides procedures for printing TwidoSoft applications.

What's in this 
Section?

This section contains the following topics:

Topic Page

Printing an Application 106

Page Setup Box 107

Print - Header/Footer 108

Print - Cover Page 109

Print - Comments 110

Print Dialog Box 111

Configuration Print Settings 112

Symbol Print Settings 113

Cross Reference Print Settings 114

Instruction List Print Settings 115

Ladder Print Settings 116
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Printing an Application

Overview TwidoSoft allows you to print an entire application or only a specific part of an 
application.

Basic Steps There are five basic steps for printing an application:

Step Action

1 Set the correct paper margins. See Page Setup Box, p. 107. 

2 Specify content for the cover page, header, footer, and comments. See Page Setup 
Box, p. 107. 

3 Select the output file or device. See Page Setup Box, p. 107. 

4 Select the parts of an application to print. See Print Dialog Box, p. 111.

5 Start the print operation. See Print Dialog Box, p. 111.
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Page Setup Box

Introduction Use this dialog box to select printer and page layout settings for printing your 
application. You can:
� Set paper margins.
� Enter content for cover page, header, footer, and comments.
� Select an output device or file.
See Print Dialog Box, p. 111.

Margins Use margins settings to select page layout for each page. Add space to the edges 
of each page by specifying the number of characters for the Left and Right margins. 
Specify the number of lines to adjust the Top and Bottom of each page. Be sure 
that this space corresponds with the requirements for the headers and footers.

Save Default Select Save Default to store the current settings in the Page Setup dialog box for 
future printing operations.

Restore Default Select Restore Default to overwrite the current settings in the Page Setup dialog 
box with the values saved previously.

Header/Footer Select Header/Footer to open the Print - Header/Footer, p. 108 dialog box and 
enter text at the top or bottom of each page.

Cover Page Select Cover Page to open the Print - Cover Page, p. 109 dialog box and setup a 
cover page to print with your application.

Comments Select Comments to open the Print - Comments, p. 110 dialog box and add a page 
with details about your application. 
   107



Managing Applications
Print - Header/Footer

Introduction Use this dialog box to select text for the Header and Footer for each page when 
printing an application.
See Print Dialog Box, p. 111.

Available 
Selections

Enter up to three lines of text each for the Header or Footer to display at the top or 
bottom respectively of each page. Additionally, you can add other footer information 
by entering text in the following boxes:
� Designer
� Company
� Date
� Program
� Revision
� Controller
108    



Managing Applications
Print - Cover Page

Introduction Use this dialog box to setup a cover page when printing an application.
See Print Dialog Box, p. 111.

Setting Up a 
Cover Page

Enter a title and a brief development history of the application. The development 
history contains the following boxes:
� Date
� Author
� Version
� Comments
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Print - Comments

Introduction Use this dialog box to enter a detailed description of an application. Comments 
appear on a separate Comments page, which is printed immediately after the cover 
page and before other pages.
See Print Dialog Box, p. 111.
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Print Dialog Box

Introduction Use the Print dialog box to select the parts of an application to print. You can:
� Print all of an application.
� Print a summary of the application.
� Print only a selected portion of an application.
The selections are printed using the printer and page layout information specified in 
Page Setup Box, p. 107.

Available 
Selections

The following selections can be printed:
� Covers/Comments - print separate cover and comment pages.
� Configuration - print configuration information from the Configuration Editor.
� Symbols - print the symbol table for application sorted by address or symbol.
� Cross Reference - print all or part of the elements in an application.
� List - print all or a range of lines in a List program. 
� Ladder - print all or a range of rungs in a Ladder program. 
� Summary - print a table of contents listing print selections and page numbers. 
� Print All - print all of the above items.

Printing 
Selections

To print selections:

Step Action

1 Select check boxes for parts of the application you want to print.
Note: Selecting Print All will automatically check all boxes. There are no settings for 
Summary and Covers/Comments. See Page Setup Box, p. 107 to setup cover and 
comments pages, You can not change the setup for a summary page. 

2 Some selections have an associated Settings button. Click on this button to specify 
how the selection prints.

3 When all settings are completed, select OK to close the dialog box and print 
selections. Select Cancel to close the box without printing any selections.

4 A dialog box is displayed indicating the output device (printer or file name) and the 
current page number being printed. Select Cancel to stop printing.
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Configuration Print Settings

Introduction Use this dialog box to select the configuration data you want to print.
See Print Dialog Box, p. 111.

Selecting 
Settings

To make selections:

Step Action

1 Select check boxes for configuration data you want to print.
Note: Selecting Print All will automatically check all boxes. 

2 When all settings are completed, select OK to close the dialog box and return 
to the Print Dialog Box, p. 111 dialog box. Select Cancel to close the box and 
lose any changes.
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Symbol Print Settings

Introduction Use this dialog box to select the sorting order for printing symbols.
See Print Dialog Box, p. 111.

Sorting Order By default, the Resolved Address option is selected to sort operands by address. 
Selecting Symbol Name will sort operand names alphabetically.

Selecting a 
Setting

To make a selection:

Step Action

1 In Order By, select Resolved Address to print operands sorted by address, 
or select Symbol Name to print operands sorted by symbol.

2 Select OK to close the dialog box and return to the Print Dialog Box, p. 111 
dialog box with the new setting. Select Cancel to close the dialog box and 
return to the Print dialog box without making a change.
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Cross Reference Print Settings

Introduction Use this dialog box to print all or part of the elements in an application. By default, 
all elements are selected.
See Print Dialog Box, p. 111.

Selecting a 
Setting

To make a selection:

Step Action

1 In Program Elements, select one of the following:
� All to print all elements,
� Selected to print only those elements appearing in the Generate Cross 

References dialog box.

2 Select OK to close the dialog box and return to the Print Dialog Box, p. 111 
dialog box with the new setting. Select Cancel to close the dialog box and 
return to the Print dialog box without making a change.
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Instruction List Print Settings

Introduction Use this dialog box to print all or part of the program lines in a List program.
See Print Dialog Box, p. 111.

Range of 
Program Lines

By default, Range is set to all program lines. You can set a range of lines by 
selecting By Lines. Enter a starting line number in the From box and the last line 
number in the range in the To box. 

Attributes In Attributes, select one of the following to specify how the program is printed:
� Select 1 Column with Addresses to print program code with addresses of 

objects.
� Select 1 Column with Symbols to print program code with symbols associated 

with objects.
� Select 2 Columns with Addresses to print a condensed two-column form of the 

program code with addresses of objects.

Selecting 
Settings

To select settings:

Step Action

1 Select a Range:
� Select All to print all program lines;
� Select By Lines to print only a specified range of lines. Enter values for From 

and To.

2 Select an option for Attributes:
�  1 Column with Addresses
�  1 Column with Symbols
�  2 Columns with Addresses

3 Select OK to close the dialog box and return to the Print Dialog Box, p. 111 dialog 
box with the new setting. Select Cancel to close the dialog box and return to the 
Print dialog box without making a change.
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Ladder Print Settings

Introduction Use this dialog box to print all or part of the program rungs in a Ladder program.
See Print Dialog Box, p. 111.

Range of Rungs By default, Range is set to all rungs. You can set a range of rungs by selecting By 
Rung. Enter a starting rung number in the From box and the last rung number in the 
To box. 

Attributes In Attributes, select one of the following to specify how the program is printed:
� Select 4 lines with Addresses + Symbols to print program code with addresses 

and symbols of objects. Three lines are available to display the entire symbol, 
and one line for the address. The four lines are displayed above the graphic 
element in the Ladder rung.

� Select 1 line with Addresses to print program code with addresses of objects.
� Select 1 line with Symbols to print program code with symbols associated with 

objects.

Selecting 
Settings

To select settings:

Step Action

1 Select a Range:
� Select All to print all program lines,
� Select By Rung to print only a specified range of rungs. Enter values for From 

and To.

2 Select an option for Attributes:
�  4 line with Addresses + Symbols
�  1 line with Addresses
�  1 line with Symbols

3 Select OK to close the dialog box and return to the Print Dialog Box, p. 111 dialog 
box with the new setting. Select Cancel to close the dialog box and return to the 
Print dialog box without making a change.
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Hardware and Software 
Configuration 
At a Glance

Overview This chapter provides details on how to configure hardware and software for Twido 
programmable controllers. 

What's in this 
Chapter?

This chapter contains the following sections:

Section Topic Page

4.1 Configuration Overview 118

4.2 Configuring Hardware 125

4.3 Configuring Software 159

4.4 Configuring Program Parameters 176
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4.1 Configuration Overview

At a Glance

Overview This section provides an overview of configuring hardware and software for Twido 
programmable controllers.

What's in this 
Section?

This section contains the following topics:

Topic Page

Configuring Hardware and Software 119

Methods for Configuring Controller Resources 120

Using the Configuration Editor 121

Validating a Configuration 124
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Configuring Hardware and Software

Introduction Configuring Twido programmable controllers consists of selecting options for the 
hardware and software resources of the controller. These resources can be 
configured at any time while creating a program. 

Hardware 
resources

Hardware resources are: the controller itself, hardware that connects to the 
controller, and the connections to the hardware.
Types of hardware resources:
� Base and Remote controllers
� Expansion I/O
� AS-Interface V2 bus interface module and its slave devices
� Options
See Configuring Hardware, p. 125.

Software 
resources

Software resources consist of configurable and non-configurable functions:
� Configurable software functions

Function blocks (also called variables) are blocks of addresses that are created 
in memory to perform special functions that can be used by a program. For 
example, when a counter function block is configured, memory addresses in the 
controller are assigned to hold values that represent the associated character-
istics of a hardware counter: current count, preset count, and so on.

� Non-Configurable software functions
These are internal memory blocks: system bits and words, memory bits and 
words, and network exchange words. 

Configurable 
Function Blocks

The following is a list of configurable function blocks:
� Timers
� Counters
� Fast counters
� Very fast counters
� Drum controllers
� LIFO/FIFO registers
� PLS/PWM pulse generators
� Schedule blocks
Constants are also configurable, but they are not function blocks.
See Configuring Software, p. 159.
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Methods for Configuring Controller Resources

Introduction Controller resources can be configured using the following:
1. Hardware or Software menus from the main menu
2. Application Browser, p. 24
3. Ladder Editor, p. 34 or the Ladder Viewer, p. 32
4. Object Browser, p. 47 in the Symbol Editor, p. 44
5. Configuration Editor, p. 42

Direct 
Configuration

The Configuration Editor provides a comprehensive look at all configurations in one 
window. The other methods allow a quick and easy method to directly configure one 
resource at a time while creating an application.

Configuring 
From the Main 
Menu

To configure controller resources individually and directly from the main menu:
� Select the Hardware or Software menu.
� Select a specific hardware or software resource to configure. 

Configuring 
From the 
Application 
Browser

To configure controller resources from the Application Browser:
� Right-click on the base controller model number to change the base controller or 

configure base I/O.
� Right-click on Hardware to add options.
� Right-click on Expansion bus to add expansion modules.
� Right-click on the Serial Port entries to edit the controller communications setup 

or add a Remote controller.

Configuring 
From the Ladder 
Editor/Viewer

To configure software resources from the Ladder Editor or the Ladder Viewer, 
double-click on a function block to display the associated configuration dialog box.

Configuring 
From the Symbol 
Editor

To configure software resources from the Symbol Editor:
� Insert or edit a symbol to display the Object Browser dialog box.
� Click on the Configure button to configure a function block (the Configuration 

Editor must not be open). 
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Using the Configuration Editor

Introduction The following resources can be configured directly from the Configuration Editor: 
� Software resources

All software resources: timers, counters, constants, drum controllers, fast 
counters, LIFO/FIFO registers, PLS/PWM, schedule blocks, very fast counters 
and event reports.

� Hardware resources
Some hardware resources: digital inputs and outputs, expansion modules 
(analog modules and AS-Interface master module) and controller 
communications setup.

� Program settings
Scan time and application name.

Configuring 
Resources From 
Configuration 
Editor

How to configure a resource using the Configuration Editor:

Saving Changes How to save changes to a configuration from the Configuration Editor:

Note: When canceling changes made in the Configuration Editor, all configuration 
changes made since the Configuration Editor was opened are discarded.

Step Action

1 With the Configuration Editor open, select a resource from the toolbar or from 
the Hardware or Software menus from the main menu.

2 Select a specific entry from the list of the selected resources in the display. If 

necessary, click on the Configure button  and use the Previous and 

Next buttons to locate a specific selection in the dialog box.

3 Open the configuration dialog box (if not already open) for the selected 
resource by doing one of the following: double-click on the resource in the 

Configuration Editor, click on the configure button  on the toolbar, or 

select Tools → Edit from the main menu.
Note: Double-clicking on the resource in the Configuration Editor is only 
applicable for timers, counters, constants, and LIFO/FIFO registers.

4 Make selections in the resource configuration dialog box. Save changes 
when complete.

Step Action

1 When changes are complete, either select Accept Changes from the Tools menu, or 

click on the accept button  in the tool bar. An Exit Warning dialog box is displayed.
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Saving Changes 
when Closing the 
Configuration 
Editor

To save changes to a configuration when closing the Configuration Editor:

Display example 
for AS-Interface 
expansion 
modules

Click "Expansion modules" from the toolbar to display the configuration of all 
modules in the expansion bus.
Example: 

For an AS-Interface master module, the configuration editor displays a list of the 
slaves planned for the project with their addresses, symbols, names and limit 
values.

2 Press OK to accept changes and close the Configuration Editor.

3 Click on Cancel to cancel acceptance of the changes and return to the 
Configuration Editor.

Step Action

Step Action

1 Close the Configuration Editor by clicking on the Close button. An Exit Warning 
dialog box is displayed.

2 Press Yes to accept changes and close the Configuration Editor.

3 Press No to discard changes and close the Configuration Editor.

%IA1   . 1A . 0
%IA1   . 1A . 1
%QA1 . 1A . 0
%QA1 . 1A . 1

%IWA1   . 7A . 0
%IWA1   . 7A . 1
%QWA1 . 7A . 0
%QWA1 . 7A . 1

1
2

3
1 2

3771 2
3 ??1

0
1
0

Configuration   of   ASI   master   module     -     TWDALXXXX    [Position 1]

Expansion Modules

2   :    TWDDDI8DT    -    8   inputs,   24V DC,   removable   terminal   block,   1   common   line, 

XVBC21A
XVBC21A
XVBC21A
XVBC21A

WXA36
WXA36
WXA36
WXA36

0
0
0
0

0
0
0
0

1
1
1
1

32767
32767
32767
32767

Channel Symbol Name Minimum Maximum
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Event report Click the  icon to display the following event report:  

Over its five columns, the event report shows: the source of the events, the 
triggering option (on rising/falling edge), the executed subroutine number, the 
priority and the updated outputs.
The report is updated when an event is added, deleted or modified. The line 
corresponding to the highest-priority event is printed in capital letters and preceded 
by an asterisk.

Configuration Editor

  %IO.2
 *%VFCO.THO
  Periodic

1 2
3

1 2
3771 2

3 ??1
0

1
0

Source decl. Option decl.

ED F

Falling edge
BOTH EDGES
255ms

SR

SR8
SR9
SR3

Priority

Low
HIGH

Low

Reflex Outputs

%QO.1, %QO.4
%QO.2

PID
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Validating a Configuration

Introduction TwidoSoft automatically validates configurations by checking for differences 
between the application configuration data and the hardware selected. As you select 
configuration options, TwidoSoft adjusts options available for configuration 
selections and displays alerts to warn of incorrect or invalid configuration entries.
Configurations do not require a separate validating command since validation is an 
automatic, built-in TwidoSoft feature. 

Validating 
Examples

Examples of TwidoSoft validating a configuration:
� When changing the base controller, any hardware not supported by the new 

choice is deleted from the Application.
� Alerts you to incorrect or invalid configuration entries. For example, only available 

options are displayed when adding an option to a configuration.
� Won’t allow you to configure more than one communications port as Remote 

Link.
� Checks for sufficient memory for the application.
� Displays errors for use of function blocks or I/O points that do not exist.
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4.2 Configuring Hardware

At a Glance

Overview This section contains detailed procedures for using TwidoSoft to configure Twido 
hardware in an application.

What's in this 
Section?

This section contains the following topics:

Topic Page

Device Properties 126

Change Base Controller 127

Input Configuration 128

Output Configuration 132

Add Module 133

Delete Module 134

Configure Module - Choosing a Module 135

Configure Module - Parameters 136

Add Option 138

Delete Option 139

Controller Communications Setup 140

Add and configure a modem 143

About Remote Links 151

Setting Up a Remote Links Network 153

Add Remote Controller 155

Delete Remote Controller 156

About Modbus Links 157

About ASCII Links 158
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Device Properties

Introduction The Device Properties dialog box displays information about Twido hardware. 
Information is available for the following Twido hardware:
� Controllers
� Expansion I/O modules
� Hardware options (such as RTC, communications, operator display, and backup 

memory cartridges) 

Displaying the 
Properties 
Information

To view the Device Properties dialog box, right-click on one of the following 
hardware items in the Application Browser, p. 24 and select the Properties menu:
� Controller Model
� Expansion I/O module
� Hardware option
The Device Properties dialog box is displayed with the Twido part number and a 
brief description of the hardware item.
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Change Base Controller

Introduction Use the Change Base Controller dialog box to select another base controller 
model for an application.The base controller can be changed but not deleted from 
the application structure.

Changing Base 
Controller

To select another base controller model:

Step Action

1 Select Hardware → Change Base Controller from the main menu, or right-
click on the base controller model in the Application Browser and select 
Change Base Controller from the shortcut menu.

2 Select a different model in the list window of the Change Base Controller 
dialog box, and press Change (or double-click on the item in the list window) 
to change the base controller to the new model.

3 Press Done to close the dialog box without changing the base controller. 

4 If the new base controller model does not support the hardware configuration 
of the previous model, a dialog box is displayed allowing you to cancel the 
change. Press Yes to change the base controller. Those hardware 
configuration settings not supported by the new base model will be removed 
from the hardware configuration in the Application Browser.

5 Press No to cancel the change and return to the dialog box and make another 
selection or keep the current model.
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Input Configuration

Introduction Use the Input Configuration dialog box to configure base controller digital inputs.

Input 
Configuration 
Dialog Box

The dialog box is organized similar to a table or spreadsheet and consists of the 
following columns which are described starting at the left-most column.

Column Description Function

Inputs (no 
heading)

Address of each input 
digital input.

For display only. Number of inputs determined by 
the type of base controller.

Used By Lists any function 
blocks using this 
input, or indicates 
whether the input is 
used to trigger an 
event.

For display only. If more than one function block is 
using an input, text is displayed in red. Displays: 
� where input is used, function blocks or program 

logic, if any.
� Event indicates whether the input is used to 

trigger an event

Symbol Displays any symbols 
assigned for inputs.

For display only. Symbols are created by using the 
Symbol Editor, p. 44.

Filtering Configuring Input 
Filtering

Input filters reduce the effect of noise on a 
controller input.

Retained? Input latching setting. Latching allows incoming pulses with durations of 
less than one scan of the controller to be captured 
and recorded.

Run/Stop? Run/Stop input 
setting.

The Run/Stop input can be used to run or stop a 
program in the controller.

Deactivation Configuration of an 
event’s trigger.

Only used to configure whether or not an event is 
triggered on an input.

High Priority Configuration of an 
event’s priority.

The High Priority input can be used to make an 
event high priority (triggered).

SR Number Configuration of the 
section number.

The SR number is used to assign a subroutine 
number to an event (triggered).
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Configuration 
Guidelines

Guidelines for configuring inputs:
� The Filtering, Retained, Run/Stop, Deactivation, High Priority and SR Number 

inputs are the only elements from this dialog box that can be configured.
� For latching inputs, %I0.2, %I0.3, %I0.4 and %I0.5 are the only configurable 

inputs.
� Only inputs %I0.2, %I0.3, %I0.4 and %I0.5 can be associated with an event.
� Only one input from %I0.2, %I0.3, %I0.4 and %I0.5 can be defined with High 

Priority.
� All inputs can be defined for filtering or as Run/Stop.
� Only one input can be configured as Run/Stop. This Run/Stop bit can be used in 

your application logic.
� Inputs configured as filtered can not be used as latched inputs.
� Inputs associated with an event cannot be latched and must be filtered (the "No 

filtering" option is not available for an input associated with an event).

Configuring 
Input Filtering

To configure filtering for an input:

Configuring 
Input Latching

To configure latching for an input:

Step Action

1 Click on the Filtering edit box of an input.

2 Click on the pull-down menu and select an option: No Filtering, 3 ms, or 12 
ms.

3 If there are no other changes, click on OK to close the dialog box and apply 
the new configuration.

Step Action

1 Click on a check box in the Latch?column for an input.

2 Setting a check mark indicates that the input is a latched.

3 If there are no other changes, click on OK to close the dialog box and apply the 
new configuration.
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Configuring a 
RUN/STOP Input

To configure an input to be used for the Run/Stop function:

Configuration of 
an event’s 
trigger.

To configure whether or not an event is triggered on an input:

Configuration of 
an event’s 
priority.

The priority of an event can be configured for an input only where its Deactivation 
option is other than Not used. To configure an event as high priority: 

Step Action

1 Click on a check box in the Run/Stop?column for an input.

2 Setting a check mark indicates that the input is used as the Run/Stop input.

3 If there are no other changes, press OK to close the dialog box. 

4 If there are no other changes, click on OK to close the dialog box and apply 
the new configuration.

Step Action

1 Click on a Deactivation zone for an input.

2 Open the drop-down menu and select an option: 
� Not used for there to be no event attached to this input,
� Rising edge for an event to be triggered when the value of the input 

switches to 1,
� Falling edge for an event to be triggered when the value of the input 

switches to 0,
� Both edges for an event to be triggered when the value of the input varies.

3 Configure the SR Number to be associated with the input if a trigger is used 
(see Configuration of the section number).

4 If there are no other changes, click on OK to close the dialog box and apply 
the new configuration.

Step Action

1 Click on a check box in the High Priority column for an input.

2 Setting a check mark indicates that the input triggers a high-priority event.
Note: If another input’s box is checked, this will be automatically unchecked 
(as only one event can be high priority).

3 If there are no other changes, click on OK to close the dialog box and apply 
the new configuration.
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Configuration of 
the section 
number.

The section number can be configured for an input only where its Deactivation 
option is other than Not used. To configure an input’s section number:

Step Action

1 Click on an SR Number zone for an input.

2 Open the drop-down menu, and select the number of the subroutine to be 
executed when an event is triggered on this input: 
� 0 to 15 (maximum 16 subroutines) for the Twido 16 controller,
� 0 to 63 (maximum 64 subroutines) for Twido 20, 24 and 40 series 

controllers.
 
Note:
If the selected section number does not correspond to any implemented 
subroutine, or if the section number is already used by another event, the 
numbers are nevertheless available from the drop-down menu. Warning 
messages alert the user to these situations.

3 If there are no other changes, click on OK to close the dialog box and apply 
the new configuration.
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Output Configuration

Introduction Use the Output Configuration dialog box to configure base controller digital 
outputs.

Output 
Configuration 
Dialog Box

The dialog box is organized similarly to a table or spreadsheet and consists of the 
following columns which are described starting with the left-most column.

Configuration 
Guidelines

Guidelines for configuring outputs:
� Controller Status is the only configurable item in this dialog box.
� The only configurable outputs are %Q0.1, %Q0.2, and %Q0.3.
� Only one output can be configured as Controller Status.

Configuring 
Controller Status

To configure an output to be used as Controller Status:

Column Description Function

Outputs (no 
heading)

Address of each 
digital output.

For display only. Number of outputs determined by 
the type of base controller.

Symbol Displays any symbols 
assigned for outputs.

For display only. Symbols are created by using the 
Symbol Editor, p. 44.

Controller 
Status?

Controller Status 
output.

Indicates controller state. If the controller is in RUN, 
output is set to one. If the controller is in STOP or in 
an error, output set to zero. Can be used for safety 
circuits external to the controller for power supplies.

Used By Lists any function 
blocks using this 
output.

For display only. If more than one function block is 
using an output, text is displayed in red. Displays 
where output is used, function blocks or program 
logic, if any.

Step Action

1 Click on a check box in the Controller Status column.

2 A check mark indicates that the output will be used for the Controller Status 
output.

3 Click on OK to close the dialog box and apply the new configuration.
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Add Module

Introduction Use the Add Module dialog box to add an Expansion I/O Module (including one AS-
Interface interface module) to the configuration of the open application. Up to seven 
expansion modules can be added to a base controller (depending on the controller 
model, maximum 2 AS-Interface expansion modules).

Expansion 
Address

Each expansion I/O module is assigned an Expansion Address when added to the 
application configuration. The addresses are numbered in the order the modules are 
added, starting with 1 and ending with the highest number of allowable expansion 
modules. 
In the Add Module dialog box, the Expansion Address list contains:
� All configured module addresses.
� The next available address (selected by default).

Renumbering of 
Addresses

If you insert a module at an already configured address, the module at that address 
and all other modules with higher addresses are moved up one address. The 
selected module is then added at the selected address. For example, adding a 
module at address 1 with modules already at addresses 1 and 2 results in a 
renumbering of the addresses:
� New module is address 1
� Module 1 is now address 2
� Module 2 is now address 3

Adding a Module To add an Expansion I/O Module:

Step Action

1 Select and highlight a module in the Module window. A brief description is 
displayed in the Description box.

2 Click on Add to add the selected module to the application. The selection is 
immediately displayed in the Application Browser.

3 To add more than one option without closing the dialog box, continue 
selecting modules and clicking on Add.

4 When selections are completed, click on Done to close the dialog box. 
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Delete Module

Introduction Use the Delete Module dialog box to remove an Expansion I/O Module from the 
configuration of an open application. There are two slightly different procedures for 
using this dialog box depending on if it is opened from the Application Browser or 
the Hardware menu.

Deleting a 
Module using the 
Application 
Browser

Using this procedure, the dialog box opens with a default selection. To delete an 
Expansion I/O Module from the Application Browser, p. 24:

Deleting a 
Module using the 
Hardware Menu

Using this procedure, the dialog box does not open with a default selection. To 
delete an Expansion I/O Module from the Hardware menu:

Renumbering of 
Expansion 
Addresses

When an module is deleted, the higher addresses are renumbered so that there is 
no gap in the numbering sequence. For example, if the module at expansion 
address #4 is deleted, then the module at address #5 is renumbered to #4. If there 
are other modules with higher addresses, they will also be renumbered in the same 
way. 

Step Action

1 Right-click on the module under the Expansion Bus. If the module is not 
displayed, double-click on the Expansion Bus to display the list of installed 
Expansion I/O modules.

2 Select Delete from the shortcut menu.

3 The Delete Module dialog box is displayed with the selected module 
highlighted by default in the Module list. Only one module can be selected at 
a time.

4 Select OK to delete the selected module and close the dialog box. Select 
Cancel to close the dialog box without changes.

Step Action

1 Select Hardware → Delete Module from the main menu.

2 The Delete Module dialog box is displayed without any modules highlighted 
in the Module list window. Click on a module in the list window to select it. 
Only one module can be selected at a time.

3 Select OK to delete the selected module and close the dialog box. Select 
Cancel to close the dialog box without changes.
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Configure Module - Choosing a Module

Introduction Use the Configure Module dialog box to manage the parameters for configurable 
modules. The dialog box lists configurable modules that have been previously 
installed on the expansion bus.
This dialog box is only available when the PC is not connected to the controller and 
there are configurable expansion modules on the expansion bus.

Two Dialogs 
Required to 
Configure a 
Module

There are two dialog boxes required to configure modules: 
� Configure Module - Choose Module

Use this first dialog to select a module from a list of configurable modules installed 
on the expansion bus. 

� Configure Module - Parameter Screen
Use this second dialog to adjust configurable parameters for the module selected 
in the first dialog box.

Choosing a 
Module

To choose a configurable module on the expansion bus:

Step Action

1 Select Configure Module from the Hardware menu. The Configure Module - 
Choose Module dialog box is displayed. 

2 Select a module from the list of configurable modules. The Description box at the 
bottom of the dialog box lists details about the module. 

3 Select OK to select the highlighted module and close the dialog box. 

4 The second Configure Module dialog box opens. See Configure Module - 
Parameter Screen.
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Configure Module - Parameters

Introduction Use this dialog to configure parameters for the module selected in the Configure 
Module - Choose Module dialog box. 
The following analog modules must be configured before they can be used by an 
application program:
� TWDALM3LT
� TWDAMM3HT
� TWDAMI12HT
� TEDAM01HT
The AS-Interface master module TWDNOI10M3 must be configured where there 
are slaves on the AS-Interface bus. The configuration screen of the AS-Interface 
master is different from the one described below (see Description of the AS-
Interface bus configuration screen in the manual "Twido programmable 
controllers: Software setup guide" – reference number TWD USE 10AF).

Title Bar and 
Description

The Title bar displays the module type and its position on the expansion bus. The 
Description zone displays a short summary of the module.

Addresses Each row of the spreadsheet represents either an input or output channel of the 
module.
The addresses of each of these are identified in the following table, where "i" is the 
location of the module on the expansion bus.

Symbol This is a read-only display of a symbol, if assigned, for the address.

Type This identifies the mode of a channel. The choices depend on the channel and type 
of module. All channels, except for the TWDALM3LT input, support the following 
types:
� Not used
� 0 - 10 V
� 4 - 20 mA

Module Name Address

TWDALM3LT 2 Inputs (%IWi.0, %IWi.1), 1 Output (%QWi.0)

TWDAMM3HT 2 Inputs (%IWi.0, %IWi.1), 1 Output (%QWi.0)

TWDAMI12HT 2 Inputs (%IWi.0, %IWi.1)

TWDAMI01HT 1 Output (%QWi.0)
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The TWDALM3LT input channel supports the following types:
� Not used
� Thermocouple K
� Thermocouple J
� Thermocouple T
� PT 100

Range This identifies the range of values for a channel. The choices depend on the specific 
type of channel and module. All channels, except for the TWDALM3LT input, 
support the following types:
� Normal

Fixed range from 0 to 4095
� Custom

User defined with a minimum and maximum between -32768 and 32767
The TWDALM3LT input channel supports the following additional range settings:
� Celsius

International thermometric scale
� Fahrenheit

Thermometric scale where the boiling point of water is 212 and the freezing point 
is 32

Minimum and 
Maximum

Use these two fields to create a user defined, or custom, range. These fields are only 
enabled when the Custom range choice has been selected. 

Units This read-only field identifies the units associated with the range selected. For 
Normal or Custom ranges, None is selected. Appropriate units are displayed for the 
temperature measure ranges of Celsius and Fahrenheit.

CAUTION

Unexpected Equipment Damage

If you have wired your input for a voltage measurement, and you 
configure TwidoSoft for a current type of configuration, you may 
permanently damage the analog module. Ensure that the wiring 
complies with the TwidoSoft configuration. 

Failure to follow this precaution can result in injury or equipment 
damage.
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Add Option

Introduction Use the Add Option dialog box to add a Twido hardware option to the configuration 
of the open application. Available selections are determined by installed hardware 
and the base controller model. TwidoSoft automatically displays available options 
for each controller.

Adding an 
Option

To add an option:

Step Action

1 Select and highlight an option in the Hardware Option window. A brief 
description of the option is displayed in the Description box.

2 Click on Add to add the selected option to the application. The selection is 
immediately displayed in the Application Browser.

3 To add more than one selection without closing the dialog box, continue 
selecting options and clicking on Add.

4 When selections are completed, click on Done to close the dialog box. 
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Delete Option

Introduction Use the Delete Option dialog box to remove an installed Twido hardware option 
from the configuration of an open application. There are two slightly different 
procedures for using this dialog box depending on if it is opened from the Application 
Browser or the Hardware menu.

Deleting an 
Option using the 
Application 
Browser

Using this procedure, the dialog box opens with a default selection. To delete a 
hardware option from the Application Browser, p. 24:

Deleting an 
Option using the 
Hardware Menu

Using this procedure, the dialog box does not open with a default selection. To 
delete a hardware option from the Hardware menu:

Step Action

1 Right-click on the option in the Application Browser.

2 Select Delete from the shortcut menu.

3 The Delete Option dialog box is displayed with the selected option 
highlighted by default in the Hardware Option list. Only one option can be 
selected at a time.

4 To delete the selected option, click on OK to close the box. Select Cancel to 
close the dialog box without changes.

Step Action

1 Select Hardware → Delete Option from the main menu.

2 The Delete Option dialog box is displayed without any options highlighted in 
the Hardware Option list window. Click on an option in the list window to 
select it. Only one option can be selected at a time.

3 To delete the selected option, click on OK to close the box. Select Cancel to 
close the dialog box without changes.
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Controller Communications Setup

Introduction Use the Controller Communications Setup dialog box to configure serial ports. 
One or two serial ports may be installed:
� Port 1 (standard)
� Port 2 (optional)

Protocols Each port can be configured for one of the following protocols:
� Remote Link (see About Remote Links, p. 151)
� Modbus (see About Modbus Links, p. 157)
� ASCII (see About ASCII Links, p. 158) 
Only one port at a time can be configured as a Remote Link. 

Using the 
Communications 
Cable

Port 1 of the controller can be configured for any protocol, but it will automatically be 
set to the TwidoSoft connection protocol when the PC to controller communications 
cable is detected. Once the cable is removed, Port 1 will revert back to the 
configured protocol.
See Connecting a PC to a Twido controller, p. 14.

Configuring a 
Serial Port as a 
Remote Link

To configure a serial port as a Remote Link (default settings are in bold):

Step Action

1 Note: To setup a remote link network, connect the PC to Serial Port 1 of each 
controller to configure as a remote link, unless already configured.

2 Select the Port 1 or Port 2 (if installed) tab in the dialog box.

3 Select Remote Link in the Protocol Type box.

4 Select an address number in the Address box. Select 0 to set the base controller 
as the master of the network of remote links. Select another number between 1 and 
7 for a slave remote link. Each remote link must have a unique address.

5 Select OK to close the dialog box. The selected serial port in the Application 
Browser is updated with the Protocol Type and Address. Select Cancel to close the 
dialog box without making changes to the current settings.
140    



Configuration
Configuring a 
Serial Port for 
Modbus

To configure a serial port to use Modbus protocol (default settings are in bold):

Step Action

1 Select the Port 1 or Port 2 (if installed) tab in the dialog box.

2 Select Modbus in the Protocol Type box.

3 Select an Address: 1 - 247.

4 Select a Baud Rate: 1200, 2400, 4800, 9600, 19200, 38400.

5 Select Data Bits: 7, 8.
Note: A setting of 8 indicates that the Modbus RTU protocol will be used; a setting 
of 7 indicates that Modbus ASCII protocol will be used. 

6 Select Parity: None, Even, Odd.

7 Select a Stop Bits: 1, 2 bits.

8 Enter a value for End of Frame from 1 to 255. Default is 10. End Of Frame identifies 
the character used to indicate the end of data reception while using either ASCII or 
Modbus ASCII. A line feed or carriage return character is typically used to indicate 
the End Of Frame. The default value is 0x0A (line feed) and is used if the value 
entered is zero (0). 

9 Enter a value for Response Timeout from 0 to 255. Default is 10, which indicates 
1 second. Response Timeout defines the time (in 100 milliseconds) to wait for a 
completed response when using either ASCII or Modbus. 

10 Enter a value for Frame Timeout from 1 to 255. Default value is 10. Frame Timeout 
defines the time (in milliseconds) to accept data when receiving Modbus RTU. The 
default is 60 milliseconds for 19200 baud.

11 Select OK to close the dialog box. The selected serial port in the Application 
Browser is updated with the Protocol Type and Address. Select Cancel to close the 
dialog box without making changes to the current settings.
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Configuring a 
Serial Port for 
ASCII

To configure a serial port to use ASCII protocol (default settings are in bold):

Step Action

1 Select the Port 1 or Port 2 (if installed) tab in the dialog box.

2 Select ASCII in the Protocol Type box.

3 Select a Baud Rate: 1200, 2400, 4800, 9600, 19200, 38400.

4 Select Data Bits: 7, 8.
Note: A setting of 8 indicates that the Modbus RTU protocol will be used; a setting 
of 7 indicates that Modbus ASCII protocol will be used. 

5 Select Parity: None, Even, Odd.

6 Select a Stop Bits: 1, 2 bits.

7 Enter a value for End of Frame from 0 to 255. Default is 10. End Of Frame identifies 
the character used to indicate the end of data reception while using either ASCII or 
Modbus ASCII. A line feed or carriage return character is typically used to indicate 
the End Of Frame. The default value is 0x0A (line feed) and is used if the value 
entered is zero (0). 

8 Enter a value for Response Timeout from 1 to 255. Default is 10, which indicates 
1 second. Response Timeout defines the time (in 100 milliseconds) to wait for a 
completed response when using either ASCII or Modbus. 

9 Select OK to close the dialog box. The selected serial port in the Application 
Browser is updated with the Protocol Type and Address. Select Cancel to close the 
dialog box without changes to the current settings.
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Add and configure a modem

Introduction Use the Add Option dialog box to add a modem to the configuration of the open 
application. TwidoSoft automatically displays available options for each controller.

Adding a Modem To add a modem:

Deleting the 
Modem

The procedure for deleting a modem is the same as for any other option (See Delete 
Option, p. 139).
Here, during the connection procedure, TwidoSoft sends an empty Hayes 1 
command to the controller.

Step Action

1 Select and highlight "MODEM" in the Hardware Option window. A brief 
description of the modem is displayed in the Description area: "Connection 
modem using TwidoSoft".

2 Click on Add to add the modem to the application. The selection is 
immediately displayed in the application browser.

3 When selections are completed, click on Done to close the dialog box. 
Result: A new "Modem" hardware device appears in the application browser.
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Configuring the 
Modem

To configure the modem:

Step Action

1 In the application browser, right-click on "Modem". 

2 Select Properties... from the right-click menu.
Result: a "Properties of the Modem" dialog box appears.
Illustration of the dialog box:  

The selected configuration corresponds to the one read in the controller: the 
Hayes initialization command, then read, is displayed in Hayes standard 
format.

3 From the dialog box, select the modem you wish to configure from the list 
(modems known to TwidoSoft, or previously-configured user modems). If no 
modem is selected, the modem selected by default is the first modem in the 
list of modems known to TwidoSoft. 
Note: If TwidoSoft does not manage to convert the Hayes initialization 
command read by the controller, a new user modem to be configured is 
created automatically.

Properties of the Modem

OK Cancel

 Modem

ATEOQ1&B1&DO&HO&IO&R1&SOSO

...My Modem

 Hayes initialization command
144    



Configuration
4 To modify the configuration (Hayes command), click "... ". 
Result: A new dialog box appears.
Illustration of the dialog box:  

Known modem names are automatically replaced by "My modem i" (where i 
is ≥ 1). For created user modems, the name is kept.

5 Click OK to confirm the configuration.
Result: the newly configured modem appears in the list of user modems.

6 Transfer the application to the controller using the serial cable for it to be 
configured for the use of a modem.

Note: If the modem added is already configured and the controller already has a 
configured Hayes 2 command, the Hayes 1 initialization command is ignored. In 
this case the modem icon is replaced in the browser by a warning icon. 

Step Action

Add/Modify Modem

OK Cancel

 Modem

ATEOQ1&B1&DO&HO&IO&R1&SOSO

My Modem

Hayes initialization command
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Configuring 
TwidoSoft

In order to be able to dialog with the controller via the modem connection, the user 
must have configured the modem in the configuration of the controller (see previous 
section) and have connected the modem to port 1 of the controller.
After this phase, TwidoSoft must be configured to use a modem connection instead 
of a serial cable.
The following table describes the procedure for selecting a modem connection: 

Step Action

1 Select File->Preferences... from the main menu.
Result: 
The following dialog box appears:  

2 Select the type of modem connection required for controller dialog from the list of 
existing connections already configured (serial, USB, modem or IP).
Note:
If the required connection does not appear in the list of proposed connections, 
follow the procedure given in the following section on creating or modifying a 
modem connection.

3 Click OK to close the "Preferences" dialog box and acknowledge the selected 
connection type.

Note: The user can now connect TwidoSoft to the controller using the type of 
connection selected in the "Preferences" dialog box.

Preferences

OK

CancelList

1 line

Help

Default Program Editor

Ladder

Ladder Information

3 lines (symbols AND addresses)

3 lines (symbols OR addresses)

Close Ladder viewer on Edit Rung

Display Toolbars

Auto Line Validate

Hex

List/Ladder Animation

Decimal

Symbols

Display Attributes

Addresses

Connection management

COM2
Bourguebus plant
Ales plant

COM1

COM1

Connection:
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There is another way of selecting the type of connection, which is shown in the 
following table: 

Adding or 
Modifying a 
Modem 
Connection in 
TwidoSoft 
Configuration

The following table describes the procedure for adding or modifying a modem 
connection in TwidoSoft configuration: 

Step Action

1 Select Controller->Select a connection from the main menu.
Result: a choice of connections appears in the contextual menu.

2 Select the type of modem connection required for controller dialog from the 
list of connections proposed.
Note:
If the required connection does not appear in the list of proposed connections, 
follow the procedure given in the following section on creating or modifying a 
modem connection.

Step Action

1 Select File->Preferences... from the main menu.
Result: 
The Preferences dialog box appears. 

2 In this dialog box, click Connection management.
The following dialog box is then displayed: 

3 In this new dialog box, the user has three options:
� Delete the connection selected in the dialog box by clicking Delete. It is 

impossible to delete connections via COM ports, as these always exist.
� Modify the connection selected in the dialog box by clicking Modify or by 

double-clicking the selection. 
� Add a new modem type connection by clicking Add. A new line is added.

4 Where modem connections are modified or added: 
� Change or enter the required name.

5 Where modem connections are modified or added: 
� Select the connection type from the list containing all the modems configured on 

the PC.

Connection management

COM1 Port

Name

COM2 Port

Serial

Connection type

Serial

COM 1

Configuration

COM 2

3000

Timeout

3000

45

Break timeout

45

ALES plant ETHERNET 192.0.0.1

ModifyAdd Delete OK

Bourguebus plant MODEM: Lucent Win Modem 0231850000 5000 65
   147



Configuration
6 Where modem connections are modified or added: 
� From the "Configuration" column, enter the telephone number to be called for 

this modem connection.

7 Where modem connections are modified or added: 
� Enter or modify the desired timeouts (values in ms):

� The Timeout corresponds to the maximum time interval between two 
frames.

� The Break timeout corresponds to the maximum time interval between two 
characters. When the time interval between two characters is greater than 
the Break timeout, the system considers this to be the beginning of the next 
frame.

8 Click OK to close the "Connection management" dialog box.
Result: the list of connections in the "Preferences" dialog box is updated with the 
new connection type.

Note: If the user connects TwidoSoft to the controller without having configured the 
modem in the application, an empty Hayes 1 command is sent to the controller to 
deconfigure it.

Step Action
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Configuring a 
Hayes 2 
Command

If the user has to manage several controllers using the same modem for each of 
them, a Hayes 2 command can be sent to dialog with a specific controller without 
having to modify or duplicate the program.
To configure a Hayes 2 command, follow the procedure below:

Step Action

1 Select Controller->Modify modem configuration... from the main menu.
Result: a dialog box appears.
Illustration of the dialog box:  

The selected configuration corresponds to the one read in the controller: the 
Hayes 2 command, then read, is displayed in a command format known to 
TwidoSoft.
Note: If TwidoSoft does not manage to convert the Hayes 2 initialization 
command read by the controller, a new user modem is created automatically.

2 In the dialog box, select the modem connected to the controller. 
Note: The modem called "None" is used to delete the Hayes 2 command in 
the controller. Configuration of the None modem has an empty Hayes 2 
command.

3 To modify the configuration (Hayes 2 command), click "...". 
Result: a new dialog box appears.
Illustration of the dialog box:  

Configure modem controller

OK Cancel

 Modem

ATEOQ1&B1&DO&HO&IO&R1&SOSO

...My Modem

Hayes initialization command
None

3COM  US  Robotics  56K  (653

Microlink  ELSA  56K  (Fun FR)

My Modem

Add/Modify Modem

OK Cancel

 Modem

ATEOQ1&B1&DO&HO&IO&R1&SOSO

My Modem

Hayes initialization command
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4 Click OK to confirm the configuration.
Result: The newly configured modem appears in the list of user modems.

5 Click OK in the dialog box "Configure modem controller" to send the Hayes 2 
command to the PLC (even if there is not yet any application or connection).

Step Action
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About Remote Links

Introduction A Remote Link is a Twido controller configured to communicate with other Twido 
base controllers over a high-speed network. The network uses a proprietary but 
simple serial protocol to communicate small amounts of data between two or more 
Twido controllers. One controller is configured as the master and can communicate 
with up to seven slaves or Remote Controllers. A Remote Link can be any type of 
base controller model. 
Only one type of data for each Remote Controller can be accessed by the Master 
Controller, either I/O or application data. A mixture of Remote Controller types is 
possible, where some can be Remote I/O and some can be Peer Controllers.
See Setting Up a Remote Links Network, p. 153.

Types of Remote 
Links

A Remote Link has two possible configurations:
� Remote I/O

The Remote I/O controller is not running an application program, and the Master 
Controller can only access I/O data. Access to remote data uses variables %I and 
%Q. The synchronization of remote data occurs at the end of every scan.

� Peer
The Peer controller is running its own application program, and the Master 
Controller can only access application data. Access to Peer application data uses 
network variables %INW and %QNW. The synchronization of remote data can 
occur over multiple scans depending on the number of Peer controllers and the 
application program.
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Remote Links 
Network

The following diagram is a simplified view of a Remote Link network. 

Designating a 
Remote Network 
Master

There can only be one controller configured as the master on a Remote Link 
network. To designate a controller as the network master, select a Remote Link 
address of 0 by using the Controller Communication Setup. To designate a 
controller as a Remote Link slave, select a Remote Address of 1 to 7.

Guidelines for 
Configuring 
Remote Links

The following conditions must be met to configure a Remote Link:
� TwidoSoft must be alternately connected to Port 1 of each controller to configure 

a serial port for Protocol Type and Address.
� Configure the slave Remote Links first so that the master controller will detect the 

remote links after configuration.
� TwidoSoft must be offline.
� The application on the master controller must be programmed to exchange data 

with the remote links.
� EIA-485 is required for the port used for connecting the remote link: Port 1 or 

optional Port 2.
� Only one port can at a time can be configured as a Remote Link.

Remote I/O

Master controller

Link

Peer

Remote controllers
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Setting Up a Remote Links Network

Introduction The following three steps are required to setup a Remote Link network:
� Wiring the controllers in a network

See the Twido User Reference Manual for details on wiring a Remote Link 
network.

� Configuring Remote Controllers
Remote Controllers can be configured as either Remote I/O or Peer type, and you 
can mix types up to a maximum of seven Remote Controllers. 

� Configuring the Master Controller
Only one controller can be configured as the master.

See About Remote Links, p. 151. 

Configuring 
Remote I/O Type

To configure a controller as a Remote I/O type of Remote Controller:

Configuring Peer 
Type

To configure a controller as a Peer type of Remote Controller:

Step Action

1 Create a new application with TwidoSoft offline. 

2 Configure the application’s hardware and software, and select Remote Link protocol 
and an address of 1 - 7. See Controller Communications Setup, p. 140.

3 Do not enter any programming logic since this controller will be used only for I/O 
data. 

4 Transfer the application to the controller.

Step Action

1 Create a new application with TwidoSoft offline. 

2 Configure the application’s hardware and software. Select Remote Link protocol 
and an address of 1 - 7. See Controller Communications Setup, p. 140.

3 Enter programming logic since this controller will be used only for application data. 

4 Transfer the application to the controller.
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Configuring a 
Master 
Controller

To configure a controller as a Master Controller:

Step Action

1 Create a new application with TwidoSoft offline. 

2 Configure the application’s hardware and software. Select Remote Link protocol 
and an address of 0. See Controller Communications Setup, p. 140.

3 Configure Remote Controllers on Remote Link. See Add Remote Controller, p. 155.

4 Enter programming logic since this controller will be used only for application data. 

5 Transfer the application to the controller.
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Add Remote Controller

Introduction Use the Add Remote Controller dialog box to add up to seven Remote Link 
controllers to the hardware configuration of an open application. 
See About Remote Links, p. 151.

Opening the 
Dialog Box

To open the Add Remote Controller dialog box:
� Right-click on a configured serial port under Hardware in the Application Browser.
� Select Add Remote Controller from the Hardware menu.

Controller Usage The base controller in the hardware configuration must be configured as the network 
master to enable adding Remote Links. A mixture of the Remote link types is 
possible: 
� Remote I/O
� Peer Controller

Remote Address The address of each Remote I/O or Peer Controller is from 1 to 7. When all 
addresses have been used, the selection is left blank.

Adding a Remote 
Controller

To add an a Remote controller:

Step Action

1 Select either Remote I/O or Peer controller for Controller Usage.

2 Select a Remote Address from the list of available addresses. Click on Add 
to add the selected option to the application.

3 To add more than one Remote controller without closing the dialog box, 
continue selecting options and clicking on Add.

4 When selections are completed, click on Done to close the dialog box. 
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Delete Remote Controller

Introduction Use the Delete Remote Controller dialog box to remove a remote controller, 
Remote I/O or Peer, from the hardware configuration of an open application. This 
dialog box can be opened from the Application Browser, p. 24 or the Hardware 
menu and the procedure is slightly different for each method.
See About Remote Links, p. 151.

Deleting a 
Remote 
Controller Using 
the Application 
Browser

Using this procedure, the dialog box opens with a default selection. To delete a 
remote controller from the Application Browser, p. 24:

Deleting a 
Remote 
Controller Using 
the Hardware 
Menu

Using this procedure, the dialog box does not open with a default selection. To 
delete an remote controller from the Hardware menu:

Numbering of 
Remote 
Addresses

When a remote controller is deleted, the Remote Link addresses do not 
automatically renumber since the numbers for the remaining remote controllers 
were assigned during configuration. If you change an address number for a 
remaining remote controller, you will have to reconnect the controller to TwidoSoft 
and reconfigure the controller.

Step Action

1 Right-click on the Remote Link controller under the Remote Link, 0.

2 Select Delete from the shortcut menu.

3 The Delete Remote Controller dialog box is displayed with the selected 
controller highlighted by default. Only one controller can be selected at a time.

4 Select OK to delete the selected controller and close the box. Select Cancel 
to close the dialog box without changes.

Step Action

1 Select Hardware → Delete Remote Controller from the main menu.

2 The Delete Remote Controller dialog box is displayed without any remote 
controllers highlighted. Click on a controller to select it. Only one controller 
can be selected at a time.

3 Select OK to delete the selected controller and close the box. Select Cancel 
to close the dialog box without changes.
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About Modbus Links

Introduction Modbus defines a master-slave communications protocol that allows one single 
master to request responses from slaves. The master can address individual slaves, 
or can initiate a broadcast message to all slaves. Slaves return a message 
(response) to requests from the master that are addressed to them individually. 
Response are not made to broadcasts from the master.

Types of Modbus 
Links

There are two types of Modbus devices supported by TwidoSoft:
� Master

Initiates the transmission of a Modbus query and solicit responses from slave 
devices. Supported using the EXCH instruction. Both Modbus ASCII and Modbus 
RTU are supported in Modbus Master mode.

� Slave
Responds to Modbus queries from a Modbus master. Supports both Modbus 
ASCII and Modbus RTU in Modbus Master mode.

Using Modbus Twido controllers support the use of both Modbus ASCII and Modbus RTU modes 
of operation. The number of Data Bits selected in the Controller Communications 
Setup dialog box determines which mode is active.
Setting the number of Data Bits to 8 indicates that the Modbus RTU protocol will be 
used, while setting Data Bits equal to 7 indicates that the Modbus ASCII protocol will 
be used.
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About ASCII Links

Introduction  ASCII protocol is a simple, half-duplex character mode protocol used to exchange 
a character string with a simple device. The protocol is supported using the EXCH 
instruction.

Types of 
Exchange

There are three types of communication possible using ASCII protocol:
� Transmission only
� Transmission/Reception
� Reception only

Frames and 
Baud Rate

The maximum size of the transmitted or received frames is 128 bytes. The maximum 
baud rate supported is 38,400.
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4.3 Configuring Software

At a Glance

Overview This section contains detailed procedures for using TwidoSoft to configure software 
resources for an application.

What's in this 
Section?

This section contains the following topics:

Topic Page

Maximum Software Configuration 160

Configuring Timers 161

Configuring Counters 162

LIFO/FIFO Registers Dialog Box 163

Drum Controllers 164

Constants 165

%PLS/%PWM 166

Fast Counters 168

Very Fast Counters 169

Schedule Blocks 173

Step Counter 174

Shift Bit Register 175
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Maximum Software Configuration

Introduction  The following table lists maximum software variables for each base controller model 
for Twido. Use this table as a guide for configuring applications. Configuration 
options are determined by the model.

Base Controller 
Models

Maximum number of configurable variables for each base controller model:

Part Compact Base Controllers Modular Base Controllers

10DRF 16DRF 24DRF 20DUK 20DTK 20DRT 40DUK 40DTK

Timers 64 64 128 128 128 128 128 128

Constants 256 256 256 256 256 256 256 256

Counters 128 128 128 128 128 128 128 128

Fast counters 3 3 3 2 2 2 2 2

Very fast counter: 1 1 1 2 2 2 2 2

LIFO/FIFO registers 4 4 4 4 4 4 4 4

Schedule blocks 16 16 16 16 16 16 16 16

Drum controllers 4 4 8 8 8 8 8 8

PLS/PWM 0 0 0 2 2 2 2 2

Step counter 8 8 8 8 8 8 8 8

Shift bit register 8 8 8 8 8 8 8 8
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Configuring Timers

Introduction Use the Timers dialog box to configure timers.

Configuring 
Timers

To configure a timer using the Timers dialog box:
1. Enter the Timer number in the %TM box.
2. The Symbol box displays the alphanumeric name, if assigned, for this variable 

(see Defining Symbols, p. 74 for more details.)
3. Select the Timer Type. Options: TON (Timer On Delay), TOF (Timer Off Delay), 

and TP (Timer Pulse). Default: TON.
4. Select the Time Base which sets the unit of time for the timer. Options: 1 ms 

(%TM0 to %TM5 only), 10 ms, 100 ms, 1 sec, and 1 min. Default: 1 min.
5. Select a Preset value. Range: 0 to 9999. Default: 9999.
6. Select the Adjustable option to allow the Preset value to be changed using the 

Animation Tables editor.
7. Use Previous and Next to scroll through the list of timers (only available when 

dialog box is opened from the Configuration Editor).
8. Select OK to close the dialog box and accept changes.
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Configuring Counters

Introduction Use the Counters dialog box to configure up/down counting.

Configuring 
Counters

To configure a up/down counter using the Counters dialog box:
1. Enter the Counter number in the %C box.
2. The Symbol box displays the alphanumeric name, if assigned, for this variable 

(see Defining Symbols, p. 74 for more details.)
3. Select a Preset value. Range: 0 to 9999. Default: 9999.
4. Select the Adjustable option to allow the Preset value to be changed using the 

Animation Tables editor.
5. Use Previous and Next to scroll through the list of counters (only available when 

dialog box is opened from the Configuration Editor).
6. Select OK to close the dialog box and accept changes.
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LIFO/FIFO Registers Dialog Box

Function Use this dialog box to configure the LIFO and FIFO registers.

Access Use one of the following methods to access the Registers dialog box:
� Clicking on the LIFO/FIFO Registers in the Application Browser
� Clicking on the LIFO/FIFO Registers selection from the Software menu
� Selecting a specific LIFO/FIFO Register in the Configuration Editor window

Example The following is an example of the LIFO/FIFO Register dialog box: 

Dialog Box 
Options

The following tablle briefly identifies each selection option, describes the function of 
the selection, and defines selection conditions or values:

Entry conditions Identify any setting conditions required in order to use this dialog box:
� Operation mode?

LIFO/FIFO REGISTER

OK

Cancel

Previous

Next

Help

Register: %R

Symbol:

0

LIFO FIFO

 Type

Selection Description Value/Action

Register %R Enter the number of the 
register

Enter the number between 0 and 3

Type Select type of register LIFO - Last In, First Out, or FIFO - First 
In First Out

OK Select to accept changes Closes dialog box

Cancel Select to lose changes Closes dialog box

Previous Selects previous timer Only available when accessed from the 
Configuration EditorNext Selects next timer
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Drum Controllers

Introduction Use the Drum Controllers dialog box to configure drum controllers function blocks.

Configuring 
Drum Controllers

To configure drum controllers:

Step Action

1 Enter a Drum number in the %DR box.
Range: see Maximum Software Configuration, p. 160.

2 Symbol is the alphanumeric name, if assigned, for this variable. See Symbol Editor, 
p. 44.

3 Enter Number of Steps.
Range: 1 to 8. The check boxes for steps that are not used will appear dimmed.

4 In Outputs, assign either a physical bit or a memory bit to each of the 16 (0 to 15) 
logical control bits that will be used for each defined step.
All outputs %Q must be valid I/O for the hardware configuration, and cannot be 
expansion I/O on Remote controllers. Internal memory bit %M range is determined 
by the base controller model.

5 Select check boxes in each step to activate bits that have been assigned a value in 
Outputs.
For example: When a step is run, the logical bits defined in Output will be activated 
if the corresponding check box in the step is selected

6 Select Previous or Next to scroll to the previous or next item without closing the 
dialog box. (Only displayed when the Configuration Editor window is open.)

7 Select OK to accept the selected values, or select Cancel to close the dialog box 
without changing the configuration.
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Constants

Introduction Use the Constants dialog box to configure program constants. Constants are 
memory words that contain values or alphanumeric messages entered during 
configuration.

Configuring 
Constants

To configure constants:

Step Action

1 Enter the Constant %KW number to configure.
Range: see Maximum Software Configuration, p. 160.

2 Symbol is the alphanumeric name, if assigned, for this variable. See Symbol Editor, 
p. 44.

3 Enter a Value for the constant.
Range: Decimal: -32768 to 32767. Hexadecimal: 0000 to FFFF. Binary: 
000000000000000 to1111111111111111 (maximum of sixteen bits). For ASCII: Any 
two ASCII characters.

4 Select the Value Format.
Options:Hexadecimal, Decimal, Binary, or ASCII

5 Select Previous or Next to scroll to the previous or next item without closing the 
dialog box. (Only displayed when the Configuration Editor window is open.)

6 Select OK to accept the selected values, or select Cancel to close the dialog box 
without changing the configuration.
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%PLS/%PWM

Introduction Use the %PLS/%PWM dialog box to configure the Pulse Generator function blocks.

Pulse Generation The %PLS/%PWM pulse generator serves as a square wave generator with the 
following characteristics.
� %PLS: 50% duty cycle (on time equals the off time).
� %PWM: duty cycle can be varied by the program.

Note: Outputs %Q0.0 and %Q0.1 are dedicated to either the %PLS or the %PWM 
function block. Configuring %PLS0/%PWM0 requires the dedicated output %Q0.0. 
If %Q0.0 is already in use, then %PLS0/%PWM0 cannot be configured. 
Conversely, if %PLS0/%PWM0 is configured, then %Q0.0 cannot be used 
elsewhere. The same is true for %PLS1/%PWM1 which requires dedicated output 
%Q0.1. In the %PLS/%PWM dialog box, the output used by each counter is 
displayed in the Dedicated Output box.

Note: You will not be able to view the value of the dedicated output bit for %PLS 
and %PWM on the optional Operator Display or the Animation Tables Editor. The 
operator display is updated at a specific interval of the controller scan cycle. This 
can cause confusion in interpreting the display of dedicated outputs for %PLS and 
%PWM pulses. At the time these outputs are sampled, their value will always be 
zero, and this value will be displayed. Ensure that the actual dedicated output is 
manipulated by the configuration of the controlling function block. 

Note: The %PLS/%PWM function blocks are not available for some base 
controllers (see Maximum Software Configuration, p. 160). 
166    



Configuration
Configuring 
%PLS or %PWM

To configure the %PLS or %PWM pulse generators using the %PLS/%PWM dialog 
box:

Step Action

1 Enter the %PLS/%PWM number.
Range: see Maximum Software Configuration, p. 160.

2 Select %PLS or %PWM in the PLS/PWM Type box.

3 Symbol is the alphanumeric name, if assigned, for this variable. See Symbol Editor, 
p. 44.

4 Select a Time Base. 
Options: 0.142 ms, 0.57 ms, 10 ms and 1 s. By default: 1 s. 

5 Enter a Preset. 
Range (depends on selected Time Base)
� .142 ms: 0 - 255
� 0.57 ms: 0 - 255 
� 10 ms: 0 - 32767 
� 1 s: 0 - 32767 

6 Select an Adjustable option. 
Yes: You can change the Preset value using the Animation Tables Editor, p. 51.
No: You cannot change the Preset value. 

7 Select Previous or Next to scroll to the previous or next item without closing the 
dialog box. (Only displayed when the Configuration Editor window is open.)

8 Select OK to accept the selected values, or select Cancel to close the dialog box 
without changing the configuration.
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Fast Counters

Introduction Use the Fast Counters dialog box to configure fast Up/Down Counters function 
blocks.

Configuration 
Options

The Fast Counters function block is a single software resource that can be 
configured as one of two types of counters:
� Up Counter
� Down Counter
Compact controllers allow a maximum of three fast counters, while Modular 
controllers allow only two fast counters.

Configuring Fast 
Up and Down 
Counters

To configure a fast Up or Down Counter:

Note: Inputs %I0.2, %I0.3, and %I0.4 are dedicated inputs for use by Fast 
Counters function blocks. Configuring %FC0 requires dedicated input %I0.2. If 
%I0.2 is already in use, then %FC0 cannot be configured. Conversely, if %FC0 is 
configured, then %I0.2 cannot be used elsewhere. The same is true for %FC1 
which requires dedicated input %I0.3. In the Fast Counters dialog box, the input 
used by each counter is displayed in the Dedicated Input box. 

Step Action

1 Enter the Fast Counter %FC number.
Range: see Maximum Software Configuration, p. 160.

2 Select Up Counter or Down Counter for the Fast Counter Type.

3 Symbol is the alphanumeric name, if assigned, for this variable. See Symbol Editor, 
p. 44.

4 In Preset, enter the number of events to be counted.
Range: 1 to 65535

5 Select an Adjustable option.
Yes: You can change the Preset value using the Animation Tables Editor, p. 51.
No: You cannot change the Preset value. 

6 Select Previous or Next to scroll to the previous or next item without closing the 
dialog box. (Only displayed when the Configuration Editor window is open.)

7 Select OK to accept the selected values, or select Cancel to close the dialog box 
without changing the configuration.
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Very Fast Counters

Introduction Use the Very Fast Counters dialog box to configure the Very Fast Timer (%VFC) 
function blocks.

Illustration of the 
dialog box

The Very Fast Counters dialog box is displayed below:   

Note: Inputs %I0.0 through %I0.7 are dedicated inputs for use by Very Fast 
Counters function blocks. Configuring %VFC0 requires dedicated input %I0.0 to 
%I0.3. If one of these inputs is already in use, it is impossible to configure %VFC0. 
Conversely, if %VFC0 is configured, then %I0.0 through %I0.3 cannot be used 
elsewhere. The same is true for %VFC1 which requires dedicated inputs %I0.1 to 
%I0.7. In the Very Fast Counters dialog box, the inputs used by each counter is 
displayed in the Dedicated Inputs box.

Note: The %VFC1 function block is not available for some base controllers (see 
Maximum Software Configuration, p. 160). 

Very Fast Counter (VFC)

 Reflex Outputs

%Q0.2

 Event Trigger

SR
Number 2

Up/Down 2-Phase Counter

0Preset:

65535Threshold S0:

65535Threshold S1:

0Very Fast Counter: %VFC

Symbol:

OK

Cancel

Previous

Next

Help

Very Fast Counter Type:

Adjustable

High
Priority

Falling edgeTH0

SR
Number 0

High
Priority

TH1

%Q0.3

%VFC.V <S0 >S0 >S1

 Dedicated Inputs

%I0.2 = Normal Input

%I0.3 = Normal Input

%I0.0 = Pulse Phase B

%I0.1 = Pulse Phase A
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Counter Options The Very Fast Counter function block is a software resource that can be configured 
as Not Used or as one of the following types of counters:
� Up/Down Counter
� Up/Down 2-Phase Counter
� Single Up Counter
� Single Down Counter
� Frequency Meter

Not used Setting the Very Fast Counter to Not Used releases its resources for use by other 
functions such as timers or schedule blocks.

Preset Set the Preset value to the total number of events to be counted. Enter a decimal 
value between 0 and 65,535.
The Preset value is loaded into the present value of the very fast counter (%VFC.V) 
on the rising edge of %I0.2 for %VFC0 and %I0.5 for %VFC1.

Thresholds, 
reflex outputs 
and outputs TH0 
and TH1

Set Threshold values S0 and S1 to decimal values between 0 and 65,535. 
Threshold values are used: 
� in conjunction with the dedicated Reflex outputs %Q0.2 and %Q0.3 for VFC0, 

and %Q0.4 and %Q0.5 for VFC1. The counter is constantly compared to these 
values to set the Reflex outputs according to configuration settings. Reflex 
outputs are values that are available immediately.

� For potentially triggering each event according to the configuration of the TH0 
and TH1 outputs. The counter is constantly compared to these threshold values 
to set the TH0 and TH1 outputs. In turn, the outputs switch to 1 when the value 
of the counter is greater than the S0 and S1 thresholds. They switch to 0 when 
the value of the counter is smaller than the S0 and S1 thresholds. Events can 
then be triggered according to the status of the outputs (see Configuration 
of an event's trigger).

Catch Input The current counting value does not update automatically. Use the Catch (or 
capture) input to force the update of %VFCi.V and copy it into %VFCi.C. %VFC0 
uses the dedicated input %I0.3, and %VFC1 uses the dedicated input %I0.4. These 
dedicated inputs are shared with Fast Counter function blocks, the Catch Input 
feature can not be used if these inputs are already used.

Adjustable Select Adjustable to allow an application to modify the Preset (%VFC.P) and 
Thresholds (%VFC.S0 and %VFC.S1). If Adjustable is selected, the Animation 
Tables Editor and the optional HMI can modify these values.
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Frequency meter When Frequency Meter is selected, only the Pulse input is needed. A frequency is 
measured by counting the rising edges of the input signal. In Time Window, select 
an interval of 100 ms or 1s.

Configuring Very 
Fast Counters

To configure a Very Fast Counter:

Step Action

1 Enter the Very Fast Counter %FVC number.
Range: see Maximum Software Configuration, p. 160.

2 Symbol is the alphanumeric name, if assigned, for this variable.  See Symbol Editor, 
p. 44.

3 Select the Fast Counter Type.
Options: Up/Down Counter, Up/Down 2-Phase Counter, Single Up Counter, Single 
Down Counter, or Frequency Meter.

4 In Preset, enter the number of events to be counted.
Range: 0 à 65 535.

5 Enter values for Threshold S0 and Threshold S1.
Range: 0 à 65 535.

6 Select an Adjustable option.
Yes: You can change the Preset value using the Animation Tables Editor, p. 51.
No: You cannot change the Preset value. 

7 Select an Adjustable option.
Yes: You can change the Preset value using the Animation Tables Editor, p. 51.
No: You cannot change the Preset value. 

8 Select Previous or Next to scroll to the previous or next item without closing the 
dialog box. (Only displayed when the Configuration Editor window is open.)

9 Select OK to accept the selected values, or select Cancel to close the dialog box 
without changing the configuration.
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Configuration of 
an event’s 
Deactivation edit 
box.

This area is divided into 2 parts: one depends on the value of the S0 threshold and 
the other depends on the value of the S1 threshold. Each time the counter reaches 
one of these 2 values , a rising or falling edge is generated on the TH0 and TH1 
outputs.
The 2 parts of the event trigger zone are configured in the following independent and 
identical way: 

Step Action

1 Open the drop-down menu associated with the TH0 or TH1 output then select 
an option: 
� Not used for there to be no event attached to this output,
� Rising edge for an event to be triggered when the value of the output 

switches to 1,
� Falling edge for an event to be triggered when the value of the output 

switches to 0, 
� Both edges for an event to be triggered when the value of the output varies.

2 Open the drop-down menu SR Number only if the output option is other than 
Not Used, then select the number of the subroutine to be executed when an 
event is triggered on this output: 
� 0 (maximum 1 subroutine) for Twido10 series controllers,
� 0 to 15 (maximum 16 subroutines) for the Twido16 controller.
� 0 to 63 (maximum 64 subroutines) for the other series of Twido controllers.
 
Note:
If the selected section number does not correspond to any implemented 
subroutine, or if the section number is already used by another event, the 
numbers are nevertheless available from the drop-down menu. Warning 
messages alert the user to these situations.

3 If the output option is other than Not Used, check the associated High Priority 
box to set the output to be used with a high-priority event trigger.
Notes: 
� If an output’s box is checked, the other output’s box can no longer be used.
� If one of the inputs from %I0.2 to %I0.5 of the controller base is already used 

on activation of a High Priority event, a dialog box alerts the user that the 
input in question is in high priority, and suggests interchanging the priority.

4 Select OK to accept the selected values, or select Cancel to close the dialog 
box without changing the configuration.
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Schedule Blocks

Introduction Use the Schedule Blocks dialog box to control Date/Clock functions, which are 
actions scheduled at predefined times. This function requires the Real-Time Clock 
option.

Configuring 
Schedule Blocks

To configure schedule blocks:

Step Action

1 Enter the Schedule Block number to configure.
Range: see Maximum Software Configuration, p. 160.

2 Click in the Configured check box to activate the dialog box boxes.

3 Enter an Output Bit address. For example, when configuring a sprinkler to turn on, 
enter the address of the output terminal connected to the sprinkler system.
All outputs %Q must be valid I/O for the hardware configuration, and cannot be 
expansion I/O on Remote controllers. Internal memory bit %M range is determined 
by the base controller model

4 Select Start Month and End Month for starting and ending the Schedule Block. 
Range: January to December.

5 Select Start Date and End Date for the day of the month for starting and ending the 
Schedule Block. Range: 1 to 31 (depending on month selection).

6 Select the Start Time and End Time for setting the time of day for starting and 
ending the Schedule Block. Range: 00:00 to 23:59.

7 Select the Days of the Week to activate the schedule block output. Checked boxes 
indicate the days that the output device is activated.

8 Select Previous or Next to scroll to the previous or next item without closing the 
dialog box. (Only displayed when the Configuration Editor window is open.)

9 Select OK to accept the selected values, or select Cancel to close the dialog box 
without changing the configuration.
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Step Counter

Introduction Use the Step Counter dialog box to assign a number from 0 to 7 for a specific Step 
Counter function block (%SC).

Opening the 
Dialog Box

This dialog box is opened by double-clicking on a Step Counter function block in a 
ladder rung.

Configuring a 
Step Counter

To configure a Step Counter:

Step Action

1 Enter a number 0 to 7 in the Step Counter box.

2 Select OK to accept the changes and close the dialog box. Select Cancel to 
close the dialog box without changes to the current settings.
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Shift Bit Register

Introduction Use the Shift Bit Register dialog box to select the a number from 0 to 7 for a specific 
Shift Bit Register function block (%SBR).

Opening the 
Dialog Box

This dialog box is opened by double-clicking on a Shift Bit Register function block in 
a ladder rung.

Configuring a 
Shift Bit Register

To configure a Shift Bit register:

Step Action

1 Enter a number 0 to 7 in the Step Counter box.

2 Select OK to accept the changes and close the dialog box. Select Cancel to 
close the dialog box without changes to the current settings.
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4.4 Configuring Program Parameters 

At a Glance

Overview This section contains detailed procedures for using TwidoSoft to configure program 
or application-wide settings.

What's in this 
Section?

This section contains the following topics:

Topic Page

Scan Mode 177

Application Name 179
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Scan Mode

Introduction Use the Scan Mode dialog box to select how the controller will scan when running 
a program. Scan time is monitored by the controller’s Watchdog Timer. If scan time 
exceeds 150 ms, a fault is generated, and the controller stops immediately. 
This dialog box can also be used to configure a periodic event.

Scan mode Scan mode can be set to normal or periodic:
� Normal (Cyclic)

Continuous, cyclic scanning; a scan starts immediately after the current scan is 
completed.

� Periodic
Controller waits until the minimum scan time has been reached before starting 
another scan.

Period The duration of a periodic scan has a selectable range of 2 ms to 150 ms. 

Watchdog The execution of the application is monitored by an application watchdog timer 
which has a default value of 250 ms. The watchdog timer has a range of selectable 
values from 10 ms to a maximum of 500 ms.

Operating mode Selecting the Automatic Start in Run function places the controller in automatic 
execution mode on start-up. 

WARNING

Unexpected Equipment Operation

When using Automatic start in Run, it is essential to know in advance 
how automatic reactivation of the outputs will effect the process or 
machine being controlled.

Failure to follow this precaution can result in death, serious injury, 
or equipment damage.
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Periodic Event An event can be periodically triggered, with a period that can be defined between 5 
and 255 ms (this is the trigger period). Every time an event is triggered, the task 
(subroutine) is executed, the number of which can also be defined.

Configuring 
Scan Mode

To configure Scan Mode:

Configuring the 
Periodic Event

To configure the periodic event:

Note: Restrictions: 
� The periodic event cannot be high-priority,
� Only one periodic event can be configured.

Step Action

1 Select Program → Edit scan mode... from the main menu.

2 Select the type of Scan Mode. 
Options: Periodic or Normal

3 If the type of Scan Mode selected is Periodic (this is the scan period), enter 
the scan time in the Period: (2 - 150 ms) zone.

4 Select OK to accept the changes and close the dialog box. Select Cancel to 
close the dialog box without changes to the current settings.

Step Action

1 Select Program → Edit scan mode... from the main menu.

2 Uncheck the box Not used from the Periodic event zone. 

3 Increment the period in the Period (5 - 255 ms) field.

4 Select the subroutine number to be periodically executed by incrementing the 
Subroutine number field.
Possible selections: 
� 0 (maximum 1 subroutine) for Twido10 series controllers,
� 0 to 15 (maximum 16 subroutines) for the Twido16 controller.
� 0 to 63 (maximum 64 subroutines) for the other series of Twido 

controllers.

5 Select OK to accept the changes and close the dialog box. Select Cancel to 
close the dialog box without changes to the current settings.
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Application Name

Introduction Use the Application Name dialog box to define a name for an application that is not 
restricted to the Windows operating system limits for file names and provides more 
flexibility for identifying applications.
The application name is not the same as the Windows file name and is only internal 
to the application (see Naming an Application, p. 70).

Naming an 
Application

To name an application:

Step Action

1 Select Program → Rename from the main menu, or right-click on the current name 
of the application in the Application Browser.

2 Enter a new name in the Application Name box. An application name can be from 
1 to 32 characters and consist of any characters including spaces, periods, and front 
and back slashes.

3 Select OK to accept the changes and close the dialog box. Select Cancel to close 
the dialog box without changes to the current settings.
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Programming in Ladder Language 
At a Glance

Overview This chapter provides detailed instructions for using TwidoSoft to create Ladder 
programs.

What's in this 
Chapter?

This chapter contains the following sections:

Section Topic Page

5.1 Creating Ladder Programs 182

5.2 Using the Ladder Viewer 187

5.3 Using the Ladder Editor 196

5.4 Using Edit Functions in the Ladder Viewer 204

5.5 Inserting Graphic Instructions 214
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5.1 Creating Ladder Programs

At a Glance

Overview This section provides an overview of using TwidoSoft to create Ladder programs.

What's in this 
Section?

This section contains the following topics:

Topic Page

Overview of Ladder Programs 183

Creating a Ladder Program 185
182    



Programming in Ladder Language 
Overview of Ladder Programs

Introduction A program written in Ladder language consists of networks of linked graphical 
elements organized into rungs that are executed sequentially by the controller. A 
ladder diagram is a graphical representation of a ladder program similar to a relay 
logic diagram.
Each rung consists of one network of linked graphical elements organized in a 
programming grid starting with a potential bar on the left and ending with a potential 
bar on the right.

Graphical 
Elements

The graphical elements represent:
� Controller inputs and outputs such as sensors, push buttons, and relays.
� Arithmetic, logical, comparison, and numerical operations.
� Predefined system functions such as timers and counters.
� Controller internal variables such as bits and words.

Rungs Each rung consists of: 
� A Rung Header which documents the purpose of the rung. See Rung Header, 

p. 37.
� A programming grid of cells with a maximum of seven rows and eleven columns. 

Each cell is one row high by one column wide. Graphical elements are inserted 
into the grid and are linked with horizontal and vertical connector lines.
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Programming 
Grid

The following is an illustration of a programming grid. 

Grid Zones The ladder diagram programming grid is divided into two zones:
� Test Zone

Contains the conditions that are tested in order to perform actions. Consists of 
columns 1 - 10, and contains contacts, function blocks, and comparison blocks.

� Action Zone
Contains the output or operation that will be performed according to the results of 
the tests of the conditions in the Test Zone. Consists of columns 9 - 11, and 
contains coils and operation blocks.

Test Zone

Action Zone

2

3

4

6

7

2 43 5 6 7 109 11

5

1

1 8

Rows

Columns

Grid
Cells

Potential 
Bars
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Creating a Ladder Program

Introduction A Ladder program can be created at any time while developing an application. Once 
the Ladder program is completed, you can configure hardware, define symbols, and 
print documentation.
See Developing an Application, p. 67.

Basic Steps The following are the basics steps for creating a Ladder program from an open 
application:

Step Action

1 Open the Ladder Viewer, p. 32. See Preferences, p. 28 to configure the view 
of ladder programs.

2 Insert the first rung. Select Tools → Insert Rung to open the Ladder Editor, 
p. 34 and create the first rung in the ladder program.

3 Enter optional information in the Rung Header (see Using Rung Headers, 
p. 195). Double-click on the Rung Header to enter the following:
� Rung title and comments
� Declare Label (%Li)
� Declare a Subroutine (SRi)
� Declare a Grafcet step

4 Select graphic instructions from the Ladder Palette Toolbar, p. 198 and the 
Extended Ladder Palette, p. 36 and insert into the rung:
� Contacts (See Inserting a Contact, p. 218)
� Standard Function Blocks (See Inserting a Timer or Counter Function 

Block, p. 219 and Using the Extended Ladder Palette, p. 199)
� Comparison Blocks (See Inserting a Comparison Block, p. 224)
� Operation Blocks (See Inserting an Operate Block, p. 225) 
� Connectors (See Inserting and Removing Connectors, p. 221)
� Jump or Subroutine Call (See Inserting a Coil or Jump/Subroutine Call, 

p. 220)
� Coils (See Inserting a Coil or Jump/Subroutine Call, p. 220) 

5 Select Accept Changes from the Tools menu to keep your changes, or select 
Cancel Changes from the Tools menu to close the rung without changes.
Note: You can analyze your program at any time by selecting Analyze 
Program from the Program menu, but changes made with the Ladder Editor 
are not analyzed until they are "Accepted." 

6 Add other rungs necessary to complete your program by repeating Step #2 
though Step #5.

7 Analyze your program for errors. If there are any errors, open the Program 
Errors Viewer for a detailed description of errors and program reversibility 
problems. See Analyzing a Program, p. 72.
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8 Save your program. Select Save from the Edit menu. See Saving an 
Application, p. 71.

9 Configure your program. See Hardware and Software Configuration , p. 117.

10 Run your program. See Running Applications, p. 87.

11 Animate your program. See Animating a Table, p. 266.

12 Print your program. See Printing Applications, p. 105.

Step Action
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5.2 Using the Ladder Viewer

At a Glance

Overview This section describes using the Ladder Viewer to view Ladder programs, insert and 
delete ladder rungs, and open the Ladder Editor.

What's in this 
Section?

This section contains the following topics:

Topic Page

Using the Ladder Viewer 188

Inserting, Editing, and Deleting Rungs 189

Displaying Symbols and Addresses 191

Toggling Ladder Views 193

Using Rung Headers 195
   187



Programming in Ladder Language 
Using the Ladder Viewer

Introduction Use the Ladder Viewer to view and edit a Ladder program. See Using the Ladder 
Editor, p. 197 to insert and edit elements within an individual rung.
With the Ladder Viewer open, the following options are available:
� Opening the Ladder Editor
� Inserting, editing, and deleting rungs
� Displaying symbols and addresses
� Toggling ladder views
� Using Edit menu commands

Opening the 
Ladder Editor

Use one of the following commands to open the Ladder Editor from the Ladder 
Viewer to edit the instructions in an individual rung:
� Insert Rung Edit
� Edit Current Rung
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Inserting, Editing, and Deleting Rungs

Introduction With the Ladder Viewer open, the following commands are available from the Tools 
menu of the main menu:
� Insert Rung
� Insert List
� Edit Current Rung
� Delete Current Rung

Insert Rung To insert a new rung before the currently selected rung:

Insert List To insert a new rung before the currently selected rung and use the List Rung Editor 
to enter instructions:

Step Action

1 Select the location where the new rung is to be inserted. The current rung, or a 
selected element within the current rung, is highlighted with a red rectangle.

2 Select Insert Rung from the Tools menu, or click on Insert on the toolbar.

3 The Ladder Editor opens in Insert Rung mode so that you can create a new rung.

Step Action

1 Select the location where the new rung is inserted. The current rung is 
highlighted with a red rectangle.

2 Select Insert List from the Tools menu. The List Rung Editor opens.

3 Enter instructions in the List Rung Editor window. 

4 When you are finished entering instructions, select Validate to check the 
instructions for errors and reversibility warnings.

5 Select OK to return to the Ladder Viewer. Press Cancel to return to the Ladder 
Viewer without adding the changes.

6 If the rung is not reversible, the new rung is displayed as List instructions.
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Edit Current 
Rung

To open the Ladder Editor from the Ladder Viewer to edit the current rung (see 
Using the Ladder Editor, p. 197):

Delete Current 
Rung

To delete the current rung (removes the rung, rung header, and any labels or 
subroutine declarations):

Step Action

1 Select a rung to edit. The current rung is highlighted with a red rectangle.

2 Select Edit Rung from the Tools menu or Edit from the toolbar. The Ladder 
Editor opens in Edit Rung mode.

3 A rung can also be opened for editing by double-clicking on a unused portion of 
the programming grid. 

4 If the rung is not reversible, the new rung is displayed as List instructions. 

Step Action

1 Select a rung to delete by using the shift and arrow keys. The current rung must 
be highlighted with a blue background.

2 Select Delete Rung from the Tools men or Delete from the toolbar.

3 The rung is removed and the Ladder Viewer window is updated.
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Displaying Symbols and Addresses

Introduction With the Ladder Viewer open, you can select to view instructions in a Ladder 
program as symbols, address, or a combination. There are two main choices:
� View instructions as addresses or symbols.
� View the instructions in one-line or three-line format as an address, symbol, or 

both.

Show Symbols To display the symbols for instructions:

Show Addresses To display the addresses for instructions:

1 Line Address 
or Symbol

To display one line of either symbol or address for instructions:

3 Lines Address 
or Symbol

To display three lines of either symbol or address for instructions:

Step Action

1 Select Show Symbols from the Tools menu or from the toolbar.

2 Symbols are displayed above the instructions in either one-line or three-line 
format (see below).

Step Action

1 Select Show Addresses from the Tools menu or from the toolbar.

2 Addresses are displayed above the instructions in either one-line or three-line 
format (see below).

Step Action

1 Select 3 Lines Address or Symbol from the Tools menu or from the toolbar.

2 Address or symbols are displayed above the instructions in a one-line format.

Step Action

1 Select 3 Lines Address or Symbol from the Tools menu or from the toolbar. 
Only coils and contacts are displayed in three lines.

2 Address or symbols are displayed above the instructions in a three-line format.
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3 Lines Address 
and Symbol

To display three lines of symbol and address or instructions:

Zoom function To select a zoom scale:

Step Action

1 Select 3 Lines Address or Symbol from the Tools menu or from the toolbar. 
Only coils and contacts are displayed in three lines.

2 The address and symbol are displayed above the instructions in a three-line 
format.

Step Action

1 Select zoom scale from the View menu.
100% correspond to the previous version.
66% or 33% enable to see the most important part of the Ladder rung.
Fit enables to adjust the display area to the window size. 
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Toggling Ladder Views 

Introduction With the Ladder Viewer open, you can change the view of Ladder programs by 
selecting the following:
� Toggle Rung Header
� Toggle Grid
� Toggle Ladder/List
� Show All As Ladder
� Grafcet Step Table

Toggle Rung 
Header

To switch the display of rung headers on or off:

Toggle Grid To switch the display of the programming grid on or off:

Step Action

1 Select Toggle Rung Header from the Tools menu or Toggle Headers from the 
toolbar.

2 The Ladder Viewer switches the view of rung headers: if they were previously 
on, they are now off.

3 Select Toggle Rung Header from the Tools menu or Toggle Headers from the 
toolbar again to switch the rung headers to the opposite view.

Step Action

1 Select Toggle Grid from the Tools menu or from the toolbar.

2 The Ladder Viewer switches the view of the grid: if the grid was previously on, it 
is now off.

3 Select Toggle Grid from the Tools menu or from the toolbar again to switch the 
grid to the opposite view.
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Toggle Ladder/
List

To toggle an entire program between the List and Ladder formats, select Ladder 
Editor or List Editor from the Program menu. To switch between the Ladder and List 
formats for a selected rung:

Grafcet Step 
Table

Viewing Grafcet steps is simplified by using the Grafcet Step Table which can be 
displayed by selecting Tools → Grafcet Step Table from the main menu while 
viewing either the List Editor or the Ladder Viewer. 
The table displays the list of Grafcet steps defined in the program in ascending 
order. The initial step is represented by a square with two borders while all other 
steps have a single border. In the online state, the table is animated and the active 
step or steps are highlighted.
To select a step from the Grafcet Step Table, do one of the following: 
� Single click with the mouse on a step and press the ENTER key.
� Double-click on a step.
Once selected from the table, the step will be highlighted in red for both ladder rungs 
and list instructions.

Step Action

1 Select Toggle Ladder/List from the Tools menu or from the toolbar.

2 The Ladder Viewer switches the view of the selected rung. If the rung was 
displayed in List format, the view changes to the Ladder format.
Note: If a rung is toggled from the List to the Ladder format, and it does not meet 
reversibility rules, then the rung will stay in the List format.

3 Select Toggle Ladder/List from the Tools menu or Toggle Headers from the 
toolbar again to switch the view back to the other format.
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Using Rung Headers

Introduction A Rung Header appears directly above a rung and documents the purpose of the 
rung in a ladder diagram. 
See Rung Header, p. 37.

Displaying Rung 
Headers

 If Rung Headers are not visible when using the Ladder Viewer, select Tools → 
Toggle Rung Headers from the main menu. Rung Headers are always visible when 
using the Ladder Editor.

Opening the 
Rung Header

To open the Rung Header in the Ladder Viewer or Ladder Editor, do one of the 
following:
� Double-click on the rung header.
� Use the arrow keys on the keyboard to select a rung header, press ENTER to 

open the highlighted rung header.
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5.3 Using the Ladder Editor

At a Glance

Overview This section describes how to use the Ladder Editor to create and edit rungs in a 
Ladder program.

What's in this 
Section?

This section contains the following topics:

Topic Page

Using the Ladder Editor 197

Ladder Palette Toolbar 198

Using the Extended Ladder Palette 199

Ladder Editor Commands 200
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Using the Ladder Editor

Introduction To create a ladder program, simply select graphic elements from the Ladder Editor 
and insert into a ladder rung  (graphic elements are the same as graphic 
instructions). Graphic elements are available from the following parts of the Ladder 
Editor:
� Ladder Palette Toolbar (See Ladder Palette Toolbar, p. 198)
� Extended Ladder Palette (See Using the Extended Ladder Palette, p. 199)

Example The following is an example of editing a rung using the Ladder Editor.  

RUNG 0      EXAMPLE OF A LADDER PROGRAM

%I0.1

%Q0.4

Ladder Editor  - Insert Rung

75% ??

RUNG

F2 F3 F5
P

F6
N

F7 F8 F9 F11 F12 F2 F3 F5
R

F6
S

F7 F8 F9
%TM

F11
%C

F12
+... ??

N

%I0.2

%C8

R E

ADJ     Y
%C8.P 777

S D

CU F

CD

%M1

%M0

ESC
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Ladder Palette Toolbar

Introduction Use the Ladder Palette Toolbar to select graphic instructions to insert into a Ladder 
program. The Ladder Palette is part of the Ladder Editor. 
Some special instructions are located on the Extended Ladder Palette which can be 
opened from the toolbar.

Ladder Palette 
Toolbar

The following is the Ladder Palette toolbar.  

For easy reference, the Ladder Palette toolbar consists of three sections:
1. Left section: contains buttons for test elements such as inputs and the 

comparison block.
2. Middle section: contains buttons for action elements such as outputs, operate 

block, jump/subroutine instruction, timer and counter function blocks, and the 
shortcut button for the Extended Ladder Palette. 

3. Right section: displays the name of the currently selected graphic element from 
the Ladder Palette or the Extended Ladder Palette.

Select Extended Ladder Palette (SHIFT+F12)

Right sectionLeft section Middle section

F2 F3 F5
P

F6
N

F7 F8 F9 F11 F12 F2 F3 F5
R

F6
S

F7 F8 F9
%TM

F11
%C

F12
+... ?? Normally Open ContactESC
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Using the Extended Ladder Palette

Introduction The Extended Ladder Palette contains special instructions that are not available 
from the Ladder Palette toolbar:
� Special contacts
� Special function blocks
� Special coils

Inserting a 
Special 
Instruction

To insert a special instruction from the Extended Ladder Palette, with the Ladder 
Editor open:

Step Action

1 Select the Extended Ladder Palette by pointing and left-clicking the mouse on the 
last button in the Middle section of the Ladder Palette or by pressing the SHIFT + 
F12 function key.

2 The Extended Ladder Palette dialog box opens.

3 Select an instruction from the Extended Ladder Palette by pressing the TAB key 
repeatedly or clicking with the mouse until the instruction you want is highlighted. 
Press ENTER to select the highlighted instruction. The Extended Ladder Palette 
dialog box closes.

4 Left-click or press the space bar to insert the contact. When positioning the contact 
using the mouse, it is placed in the cell in which you click. When positioning the 
contact using the space bar, it is placed in the cell which was previously selected. 
To select an cell you must call up the selection tools (arrow icon) then left-click or 
move to the desired cell using the arrow keys. 

5 To complete programming, see Inserting an Operand or Symbol, p. 226.

Note: To position several objects (or blocks) hold down the CTRL key.
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Ladder Editor Commands

Introduction With the Ladder Editor open, the following commands are available from the Tools 
menu:
� Accept Changes
� Cancel Changes
� New Rung
� Clear Rung
� Previous Rung
� Next Rung
� Toggle Grid
� Zoom function
� Cut function
� Copy function
� Paste function
� Cancel function
� Repeat function

Accept Changes To accept changes made to a rung:

Cancel Changes To cancel changes made to a rung:

Step Action

1 Select Accept Changes from the Tools menu to close an open rung with all 
changes when you have completed editing or creating a rung.

2 The Ladder Editor closes and the Ladder Viewer opens. (The Ladder Viewer can 
remain open while using the Ladder Editor, see Preferences, p. 28.)

Step Action

1 Select Cancel Changes from the Tools menu when you want to discard 
changes made to a rung.

2 The Ladder Editor closes and the Ladder Viewer opens. (The Ladder Viewer can 
remain open while using the Ladder Editor, see Preferences, p. 28.)
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New Rung To insert a new rung while editing another rung:

Clear Rung To clear all instructions from the current rung:

Previous Rung To open the previous rung in a Ladder program:

Next Rung To open the next rung in a Ladder program:

Step Action

1 Select New Rung from the Tools menu to open a new rung while editing the 
current rung.
Note: Any changes to the current rung are saved before opening a new rung.

2 The current rung is closed and a new rung opens in the Ladder Editor.

Step Action

1 Select Clear Rung from the Tools menu to remove all elements from the current 
rung.

2 The rung remains open in the Ladder Editor.

Step Action

1 Click on Previous Rung from the Tools menu. 

2 The preceding rung in the Ladder program opens in the Ladder Editor.

3 Continue clicking on Previous Rung to open all rungs sequentially that precede 
the current rung.
Note: If a rung is encountered that is not reversible, it can not be viewed in the 
Ladder Editor, and it will stop the sequence of opening preceding rungs. 

Step Action

1 Click on Next Rung from the Tools menu. 

2 The next rung in the Ladder program opens in the Ladder Editor.

3 Continue clicking on Next Rung to open all rungs sequentially that follow the 
current rung in the Ladder program.
Note: If a rung is encountered that is not reversible, it can not be viewed in the 
Ladder Editor, and it will stop the sequence of opening following rungs. 
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Toggle Grid To switch the display of the programming grid on or off:

Zoom Function To select a zoom scale:

Cut Function Use Cut to remove one or more rungs and insert into another location in the same 
program, or in another program. To remove one or more rungs in offline or online 
stopped states:

Step Action

1 Select Toggle Grid from the Tools menu or from the toolbar.

2 The Ladder Editor switches the view of the grid: if the grid was previously on, it 
is now off.

3 Select Toggle Grid from the Tools menu or from the toolbar again to switch the 
grid to the opposite view.

Step Action

1 Select zoom scale from the View menu.
100 % corresponds to the previous version
66 % or 33% enable you to view most of the Ladder rung
Fit enables to adjust the display area to the window size 

Step Action

1 See Marking a Ladder Block, p. 208 to select a block of rungs to cut. Selections 
are highlighted in blue.

2 Select Cut from the Edit menu.
Note: Press the DELETE key to remove the marked block without copying it to 
the Clipboard. 

3 The marked block is removed from the program and the remaining rungs are 
renumbered.

4 Use the Paste command from the Edit menu to insert the removed marked block 
into another location in the same program, or insert into another program.
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Copy Function Use Copy to duplicate a marked block from a program and place it in the Clipboard. 
Copy does remove the marked block. Use Copy and Paste to duplicate rungs in a 
program for use in another location in the same program, or for use with another 
program. To copy a marked block in offline or online stopped states:

Paste Function Use Paste to insert rungs that are in the Clipboard after a Cut or Copy command. 
Insert rungs in another location in the same program, or in a different program. To 
Paste a marked block in offline or online stopped states:

Cancel Function Use Undo to reverse the last Cut, Paste, or Delete operation.
To use Undo:

Repeat Function Use the Repeat command to reverse the Undo command.
To use Repeat:

Step Action

1 See Marking a Ladder Block, p. 208 to select a block of rungs to copy. Selections 
are highlighted in blue.

2 Select Copy from the Edit menu.

3 A copy of the marked block is placed in the Windows Clipboard.

4 Use the Paste command from the Edit menu to insert a copy of the marked block 
into another location in the same program, or into another program.

Step Action

1 Use Cut or Copy to place a marked block in the Clipboard.

2 Select the rung where you want to insert the marked block. The rung can be in the 
current program, or close the current program and open another program.

3 Select Paste from the Edit menu.

4 A copy of the marked block is inserted before the selected rung.

Step Action

1 Select Undo from the Edit menu.

2 The previous editing operation is reversed.

Step Action

1 Select Undo from the Edit menu.

2 The last Undo operation is reversed.
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5.4 Using Edit Functions in the Ladder Viewer

At a Glance

Overview This section provides procedures for using commands from the Edit menu to edit 
Ladder programs in the Ladder Viewer,

What's in this 
Section?

This section contains the following topics:

Topic Page

Edit Menu Commands 205

Cut, Copy, and Paste 206

Marking a Ladder Block 208

Find and Replace 209

Find 211

Replace 212

Undo 213
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Edit Menu Commands

Introduction With the Ladder Viewer open, use the following commands from the Edit menu to 
edit a single rung, or a group of rungs:
� Cut, Copy, and Paste, p. 206
� Find and Replace, p. 209
� Undo, p. 213
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Cut, Copy, and Paste

Introduction Select the following commands from the Edit menu to edit a Ladder program:
� Cut, p. 206
� Copy, p. 206
� Paste, p. 207
� Cancel, p. 207
� Repeat, p. 207
See Marking a Ladder Block, p. 208.

Cut Use Cut to remove one or more rungs and insert into another location in the same 
program, or in another program. To remove one or more rungs in offline or online 
stopped states:

Copy Use Copy to duplicate a marked block from a program and place it in the Clipboard. 
Copy does remove the marked block. Use Copy and Paste to duplicate rungs in a 
program for use in another location in the same program, or for use with another 
program. To copy a marked block in offline or online stopped states:

Step Action

1 See Marking a Ladder Block, p. 208 to select a block of rungs to cut. Selections 
are highlighted in blue.

2 Select Cut from the Edit menu.
Note: Press the DELETE key to remove the marked block without copying it to 
the Clipboard. 

3 The marked block is removed from the program and the remaining rungs are 
renumbered.

4 Use the Paste command from the Edit menu to insert the removed marked block 
into another location in the same program, or insert into another program.

Step Action

1 See Marking a Ladder Block, p. 208 to select a block of rungs to copy. Selections 
are highlighted in blue.

2 Select Copy from the Edit menu.

3 A copy of the marked block is placed in the Windows Clipboard.

4 Use the Paste command from the Edit menu to insert a copy of the marked block 
into another location in the same program, or into another program.
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Paste Use Paste to insert rungs that are in the Clipboard after a Cut or Copy command. 
Insert rungs in another location in the same program, or in a different program. To 
Paste a marked block in offline or online stopped states:

Cancel Use Undo to reverse the last Cut, Paste, or Delete operation.
To use Undo:

Repeat Use the Repeat command to reverse the Undo command.
To use Repeat:

Step Action

1 Use Cut or Copy to place a marked block in the Clipboard.

2 Select the rung where you want to insert the marked block. The rung can be in the 
current program, or close the current program and open another program.

3 Select Paste from the Edit menu.

4 A copy of the marked block is inserted before the selected rung.

Step Action

1 Select Undo from the Edit menu.

2 The previous editing operation is reversed.

Step Action

1 Select Undo from the Edit menu.

2 The last Undo operation is reversed.
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Marking a Ladder Block

Introduction Marking a block of ladder rungs for cut, copy, paste, delete, search, and other 
commands.

Marking a Block 
in a Ladder 
Program

To mark a rung or a number of rungs in a Ladder program:

Step Action

1 Position the cursor in the beginning of the first rung in the block. A red rectangle 
highlights the selected cell.

2 Press and hold the SHIFT key. Use the up or down arrow on the keyboard to 
select rungs.
Note: The first click with an arrow will select the contents of the current rung. 
Additional clicks select other rungs. All selected rungs are highlighted in blue.

3 Release the SHIFT key when selections are completed.
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Find and Replace

Introduction You can search for and replace each occurrence of an operand or comment string 
in Ladder programs. You can also search for rung numbers, but these cannot be 
replaced.
Find and Replace can be used in the offline state.

Types of 
Searches

You can search for the following items in a program. 
� Operands

Address or Symbol: Does not matter if addresses or symbols are displayed. For 
example, if Show Addresses is selected from the Tools menu, you can still 
search for symbols.

� Rung
The rung number of a specified rung when viewing a Ladder program. If the rung 
number specified is greater than the highest available rung number, then the last 
rung is highlighted.

� Comment String 
A specific text string in the rung headers of a Ladder program.
Searching for comment and text strings is not case sensitive.

Search Options Three options are available to select a search area in a program:
� Search All: Search the entire program.
� Search From Cursor: Start searching at cursor and continue to end of program.
� Search Selected Region: Search only within a marked block in the program.

See Marking a Ladder Block, p. 208.

Search 
Guidelines

Some general guidelines for searching a program:
� Exact matches only for operands. For example, when searching for %TM0, 

%TM0.V or AND %TM0.Q will not be found. 
� Selecting Comment or Text strings searches for strings in comments, operands, 

operators, labels, and subroutines.
� Subroutines (SRn) and Labels (%Li) are treated as operands.
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General 
Guidelines for 
Using Replace

Some general guidelines for using Replace:
� When replacing operands, only function blocks are replaced. For example, when 

replacing %TM0 with %TM2, %TM0.Q is not replaced with %TM2.Q.
� Source and target operands cannot be unresolved symbols. See Defining 

Symbols, p. 74.
� Replacing a label or subroutine will not change the declaration of the label or 

subroutine. A label or subroutine declaration may be replaced with another label 
or subroutine declaration.

� Subroutines (SRn) and Labels (%Li) are treated as operands.
� For Comment or Text strings, any strings that can be located using Find can be 

replaced.

Replacing 
Operands

For operands, you can replace: 
� Bits with bits (For example, %I0.0 with %M2)
� Words with words (For example, %MW100 with %SW12)
� Function blocks with like function blocks (For example, %TM0 with %TM2 is 

allowed, %TM0 with %C3 is not allowed)
� Immediate values with immediate values (For example, 7 with 8)
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Find

Introduction Use the Find dialog box to search for each occurrence of an operand, rung/line 
numbers, or comment/text strings in Ladder and List programs. Once the first 
instance of an item is found, the dialog box changes to display only command 
buttons to simplify searching and replacing (see Step #7 below). This dialog box is 
displayed by selecting Edit → Find from the main menu while viewing a program in 
the Ladder Viewer or List Editor. 
See Find and Replace, p. 209 for Ladder programs, or Find and Replace, p. 246 for 
List programs.

Searching a 
Program

With a program displayed in the Ladder Viewer or the List Editor:

Step Action

1 Select Edit → Replace from the main menu to open the Replace dialog box.

2 With the Find dialog box open, click on the Find drop-down list and select the type 
of item for the search.

3 In the text box below Find, enter a specific item that you want to locate.

4 Select one of the search Options. For selecting a region, see Marking a Ladder 
Block, p. 208 or Marking a List Block, p. 245. )

5 Click on OK to close the dialog box and start the search.

6 If the item is not found, an information box is displayed confirming "Item not found." 
Select OK to close the information box and return to the Find dialog box.

7 If the item is found, it is highlighted in red. The dialog box changes to display the 
following buttons:
� Find Next - select to search for another instance.
� Cancel - select to close the dialog box.

8 To continue searching, press the Find Next button. (Go to Step #7.)

9 To stop searching, press the Cancel button to close the dialog box.

10 After the last instance of the value or text is found, or if the search does not find any 
instance of the specified value or text, an information dialog box is displayed stating 
"Item not found." Press OK to close the box.
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Replace

Introduction Use the Replace dialog box to search for and replace an operand or comment/text 
strings in Ladder and List programs. Once the first instance of an item is found, the 
dialog box changes to display just command buttons to simplify searching and 
replacing (see Step #8). This dialog box is displayed by selecting Edit → Find from 
the main menu while viewing a program in the Ladder Viewer or List Editor.
See Find and Replace, p. 209 for Ladder programs, or Find and Replace, p. 246 for 
List programs.

Using Replace To search for and replace an operand or text string:

Step Action

1 Select Edit → Replace from the main menu to open the Replace dialog box.

2 Click on the Find box and select the type of item to be replaced. 

3 In the box below the Find box, enter the specific item that will be replaced.

4 In the Replace with box, enter the specific item that will be the replacement.

5 Select one of the search Options.

6 Click on OK to close the dialog box and start the search.
You can also select Replace All to replace all instances of the item. Found instances 
will not be displayed, but an information box is displayed confirming the number of 
occurrences (items replaced). Select OK to close the information box and the 
Replace dialog box.

7 If an item is not found, an information box is displayed confirming "Item not found." 
Select OK to close the box and return to the Replace dialog box.

8 If an item is found, it is highlighted in red. The dialog box changes to display four 
buttons:
� Find Next - select to leave highlighted instance unchanged and search for 

another instance.
� Replace - select to replace the highlighted instance.
� Replace All - select to replace all instances of the item.
� Cancel - select to close the dialog box without any further changes (previous 

changes are retained).

9 After the last instance of the value or text is found, or if the search does not find any 
instance of the specified value or text, an information dialog box is displayed stating 
"Item not found." Press OK to close the box.

10 When the Replace dialog box is closed, an information box is displayed confirming 
the number of occurrences (items replaced).
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Undo

Introduction Use Undo to reverse the last Cut, Paste, or Delete operation.

Using Undo To use Undo:

Step Action

1 Select Undo from the Edit menu.

2 The previous editing operation is reversed.
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5.5 Inserting Graphic Instructions

At a Glance

Overview This section provides a procedure and rules for inserting graphic instructions in 
ladder rungs by using either the mouse or the keyboard.

What's in this 
Section?

This section contains the following topics:

Topic Page

Inserting Graphical Elements 215

Rules for Inserting Graphical Elements 217

Inserting a Contact 218

Inserting a Timer or Counter Function Block 219

Inserting a Coil or Jump/Subroutine Call 220

Inserting and Removing Connectors 221

Inserting a Comparison Block 224

Inserting an Operate Block 225

Inserting an Operand or Symbol 226
214    



Programming in Ladder Language 
Inserting Graphical Elements

Introduction General procedure for inserting graphical elements in a ladder program.
See Ladder Palette Toolbar, p. 198.

Inserting 
Instructions

To insert graphic instructions, starting at the Ladder Viewer:

Using the Mouse 
to Insert Graphic 
Instructions

To insert a graphic instruction into a ladder rung by using the mouse:

Step Action

1 Select Tools → Insert Rung to open the Ladder Editor, p. 34.

2 To view the programming grid, select Tools → Toggle Grid. See Preferences, 
p. 28 to configure viewing ladder diagrams.

3 You can select and insert graphic instructions in a ladder rung using the mouse 
or the keyboard:
� Using the Mouse to Insert Graphic Instructions, p. 215.
� Using the Keyboard to Insert Graphic Instructions, p. 216.

Step Action

1 Select an instruction from the Ladder Palette Toolbar, p. 198 by pointing at an 
instruction button and left-clicking the mouse.

2 For instructions that are not on the Ladder Palette, click on the last button in the 
Action section of the Ladder Palette to open the Extended Ladder Palette.

3 Select an instruction from the Extended Ladder Palette by pointing at the 
associated button and left-clicking the mouse. Once you make a selection, the 
Extended Ladder Palette closes.

4 The Element Name section of the Ladder Palette toolbar displays the name of 
the selected instruction.

5 Left-click or press the space bar to insert the instruction. When positioning the 
instruction using the mouse, it is placed in the cell in which you click. When 
positioning the instruction using the space bar, it is placed in the cell which was 
previously selected. To select an cell you must call up the selection tools (arrow 
icon) then left-click or move to the desired cell using the arrow keys. 
The inserted instruction remains active until another instruction is selected.

6 If you insert an instruction in a cell that already has an instruction, the new 
instruction overwrites the previous instruction.

7 Press delete to remove an instruction from a selected cell.
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Using the 
Keyboard to 
Insert Graphic 
Instructions

To insert a graphic instruction into a ladder rung by using the keyboard:

Step Action

1 Select an instruction from the Ladder Palette Toolbar, p. 198 by pressing the 
keyboard shortcut identified on the instruction button: a function key or a 
combination of the SHIFT key and a function key.

2 For instructions that are not on the Ladder Palette, press SHIFT+F12 (press and 
hold the SHIFT key, and then press the F12 function key) to open the Extended 
Ladder Palette,

3 Select an instruction from the Extended Ladder Palette by pressing the TAB key 
repeatedly until the instruction button you want is highlighted. Press ENTER to 
select the highlighted instruction. The Extended Ladder Palette closes.

4 The Element Name section of the Ladder Palette toolbar displays the name of 
the selected instruction.

5 Left-click or press the space bar to insert the instruction. When positioning the 
instruction using the mouse, it is placed in the cell in which you click. When 
positioning the instruction using the space bar, it is placed in the cell which was 
previously selected. To select an cell you must call up the selection tools (arrow 
icon) then left-click or move to the desired cell using the arrow keys. 
Note: If you insert an instruction in a cell that already has an instruction, the new 
instruction overwrites the previous instruction.

8 Press the DELETE key to remove an instruction from a currently selected cell. to 
remove an instruction from a selected cell.

Note: To keep the instruction active, press Ctrl + Enter.
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Rules for Inserting Graphical Elements

Introduction Use the following list of rules as guidelines for inserting graphic instructions into a 
ladder rung.
See Ladder Palette Toolbar, p. 198 and Using the Extended Ladder Palette, p. 199.

Rules Rules for inserting graphical elements: 
1. You can not insert the graphic instructions located on the Test section of the 

Ladder Palette toolbar into the last column of the grid. The Compare Block 
instruction, the last selection in this section, requires two cells and can not be 
inserted into the last two columns.

2. The coil, inverse coil, reset coil, set coil, and jump/routine call instructions can 
only be inserted in the last column of the grid.
If you try to insert these instructions anywhere else, a horizontal connector line is 
automatically inserted from that point to the last column where the instruction is 
inserted.

3. You can only insert an Operate Block, which requires four cells, into the last four 
columns of the grid. 
If you try to insert this instruction anywhere else, a horizontal connector line is 
automatically inserted from that point to the last four columns where the 
instruction is inserted.

4. The timer and counter blocks, which require two columns by four rows each, can 
not be inserted in the first column or the last two columns.

5. The Special Contacts located on the Extended Ladder Palette can not be 
inserted in the first or last columns. 
The OPEN and SHORT special contacts are the exceptions to this rule and can 
be inserted in the first column.

6. The Function Blocks located on the Extended Ladder Palette occupy two 
columns by four rows, and can not be inserted in the first or last columns.The 
Very Fast Counter function block occupies two columns by five rows. Only one 
function block is allowed in a rung.

7. The Special Coils, located on the Extended Ladder Palette, can only be inserted 
in the last column. 
If you try to insert these instructions anywhere else, a horizontal connector line is 
automatically inserted from that point to the last four columns where the 
instruction is inserted.
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Inserting a Contact

Introduction Insert contacts in any column of the programming grid except he last column. This 
procedure is for inserting the following in a ladder rung:
� Normally open contact
� Normally closed contact
� Rising edge contact
� Falling edge contact

Inserting a 
Contact

With the Ladder Editor open:

Step Action

1 Select a contact from the Test section of the Ladder Palette by pointing and left-
clicking the mouse, or by using the assigned function key.

2 The Element Name section of the Ladder Palette Toolbar, p. 198 displays the name 
of the selected contact.

3 Left-click or press the space bar to insert the contact. When positioning the contact 
using the mouse, it is placed in the cell in which you click. When positioning the 
contact using the space bar, it is placed in the cell which was previously selected. 
To select an cell you must call up the selection tools (arrow icon) then left-click or 
move to the desired cell using the arrow keys. 

4 To complete programming, see Inserting an Operand or Symbol, p. 226.
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Inserting a Timer or Counter Function Block

Introduction Insert a timer or counter in any column of the programming grid except for the first 
column and the last two columns.

Inserting a Timer 
or Counter 
Function Block

With the Ladder Editor open:

Step Action

1 Select a timer or counter function from the Action section of the Ladder Palette 
Toolbar, p. 198 by pointing and left-clicking the mouse, or by pressing SHIFT and 
the assigned function key.

2 The Element Name section of the Ladder Palette toolbar displays the selected type 
of function block.

3 Left-click or press the space bar to insert the block. When positioning the block 
using the mouse, it is placed in the cell in which you click. When positioning the 
block using the space bar, it is placed in the cell which was previously selected. To 
select an cell you must call up the selection tools (arrow icon) then left-click or move 
to the desired cell using the arrow keys. 

4 To complete programming timers, see Configuring Timers, p. 161. To complete 
programming counters, see Configuring Counters, p. 162.
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Inserting a Coil or Jump/Subroutine Call

Introduction Insert a coil or jump/subroutine call only in the last column of the programming grid. 
Use this procedure to insert the following into a ladder rung:
� Coil
� Inverse coil
� Reset coil
� Set coil
� Jump/Subroutine call

Inserting a Coil 
or Jump/
Subroutine Call

With the Ladder Editor open:

Step Action

1 Select a contact or a jump/subroutine call from the middle section of the Ladder 
Palette Toolbar, p. 198 by pointing and left-clicking the mouse, or by pressing 
SHIFT and the assigned function key.

2 The Element Name section of the Ladder Palette toolbar displays the name of the 
selected coil or jump/subroutine.

3 Left-click or press the space bar to insert the contact. When positioning the contact 
using the mouse, it is placed in the cell in which you click. When positioning the 
contact using the space bar, it is placed in the cell which was previously selected. 
To select an cell you must call up the selection tools (arrow icon) then left-click or 
move to the desired cell using the arrow keys. 

4 To complete programming, see Inserting an Operand or Symbol, p. 226.
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Inserting and Removing Connectors

Introduction Use horizontal and vertical connector lines to link elements in a ladder rung.
� Horizontal Connector - a horizontal line that connects elements on the same row.
� Down Connector - a vertical line in one column that connects two rows.
� Erase Down Connector - deletes a down connector.
� Horizontal Connector Fill - inserts a unbroken horizontal connector line from the 

selected cell to an Action block such as an operation or output. 

Inserting a 
Horizontal 
Connector

With the Ladder Editor open:

Deleting a Down 
Connector

With the Ladder Editor open:

Step Action

1 Select the Horizontal Connector from the left section of the Ladder Palette Toolbar, 
p. 198 by pointing and left-clicking the mouse, or by pressing SHIFT and the 
assigned function key.

2 The Element Name section of the Ladder Palette toolbar displays Horizontal 
Connector.

3 Left-click or press the space bar to insert the connector. When positioning the 
connector using the mouse, it is placed in the cell in which you click. When 
positioning the connector using the space bar, it is placed in the cell which was 
previously selected. To select an cell you must call up the selection tools (arrow 
icon) then left-click or move to the desired cell using the arrow keys. 

4 The horizontal connector line appears near the bottom of the cell. To insert a 
horizontal connector line in another location, point to a cell and left-click, or press 
the spacebar.

Step Action

1 Select a cell containing a horizontal connector line by left-clicking the mouse or 
using the arrow keys. A red rectangle highlights the selected cell.

2 Delete the horizontal connector by pressing the DELETE key.
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Inserting a Down 
Connector

With the Ladder Editor open:

Deleting a Down 
Connector

With the Ladder Editor open:

Step Action

1 Select the Down Connector from the left section of the Ladder Palette by pointing 
and left-clicking the mouse, or by pressing SHIFT and the assigned function key.

2 The Element Name section of the Ladder Palette toolbar displays Down Connector.

3 Left-click or press the space bar to insert the connector. When positioning the 
connector using the mouse, it is placed in the cell in which you click. When 
positioning the connector using the space bar, it is placed in the cell which was 
previously selected. To select an cell you must call up the selection tools (arrow 
icon) then left-click or move to the desired cell using the arrow keys. 

4 The down connector line appears and extends down to the right side of the cell 
immediately below and in the same column.

Step Action

1 Select a cell containing a down connector line by left-clicking the mouse or using the 
arrow keys. You will need to select the cell above the cell containing the down 
connector. A red rectangle highlights the selected cell which is located immediately 
above the cell containing the down connector line. 

2 Select the Erase Down Connector from the left section of the Ladder Palette by 
pointing and left-clicking the mouse, or by pressing SHIFT and the assigned function 
key.

3 The Element Name section of the Ladder Palette toolbar displays Erase Down 
Connector.

4 Left-click, or press the spacebar to delete the down connector for the cell.
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Using Horizontal 
Fill

With the Ladder Editor open:

Deleting a 
Horizontal 
Connector Fill

Use the same procedure as Deleting a Down Connector, p. 221.

Step Action

1 Select a cell in a row that you want to insert a horizontal line from a the selected cell 
to the last cell while still leaving the last cell open for an output element. A red 
rectangle highlights the selected cell.

2 Select the Horizontal Connector Fill from the left section of the Ladder Palette by 
pointing and left-clicking the mouse, or by pressing SHIFT and the assigned function 
key.

3 The Element Name section of the Ladder Palette toolbar displays Horizontal 
Connector Fill.

4 Left-click, or press the spacebar to insert a horizontal connector line starting in the 
selected cell and ending in a block or output. 
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Programming in Ladder Language 
Inserting a Comparison Block

Introduction Use a Comparison Block to compare two operands. A comparison block cannot be 
inserted in the last two columns of the programming grid.

Inserting a 
Comparison 
Block

With the Ladder Editor open:

Step Action

1 Select the Comparison Block from the left section of the Ladder Palette Toolbar, 
p. 198 by pointing and left-clicking the mouse, or by pressing the F10 function key.

2 The Element Name section of the Ladder Palette toolbar displays Compare.

3 Left-click or press the space bar to insert the block. When positioning the block 
using the mouse, it is placed in the cell in which you click. When positioning the 
block using the space bar, it is placed in the cell which was previously selected. To 
select an cell you must call up the selection tools (arrow icon) then left-click or move 
to the desired cell using the arrow keys. 

4 To complete programming, see Inserting an Operand or Symbol, p. 226.
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Inserting an Operate Block

Introduction Use an Operate Block to perform numerical instructions. An operate block can only 
be inserted in the last four columns of the programming grid in a ladder rung. If you 
try to insert this instruction anywhere else, a horizontal connector line is 
automatically inserted from that point to the last four columns where the block is 
inserted.

Inserting an 
Operate Block

With the Ladder Editor open:

Step Action

1 Select the Operate Block from the middle section of the Ladder Palette Toolbar, 
p. 198 by pointing and left-clicking the mouse, or by pressing the SHIFT+F8 function 
key.

2 The Element Name section of the Ladder Palette toolbar displays operate.

3 Left-click or press the space bar to insert the block. When positioning the block 
using the mouse, it is placed in the cell in which you click. When positioning the 
block using the space bar, it is placed in the cell which was previously selected. To 
select an cell you must call up the selection tools (arrow icon) then left-click or move 
to the desired cell using the arrow keys. 

4 To complete programming, see Inserting an Operand or Symbol, p. 226.
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Inserting an Operand or Symbol

Introduction Simple Ladder instructions, such as contacts or coils, use a single operand (for 
example, %I0.1). Other instructions, such as compare and operate blocks, require 
operation strings - multiple operands with operators or option calls.
Example of operation strings:
� %MW50:=%MW3 + %KW5 in an operate block
� %MW15<0 in a comparison
Enter operation strings directly from the keyboard, just as you would to specify a 
single operand.

Inserting an 
Operand or 
Symbol above a 
Contact or Coil

With the Ladder Editor open:

Inserting an 
Operation String 
in a Comparison 
or Operate Block

With the Ladder Editor open:

Step Action

1 Select a cell containing a contact or coil by left-clicking the mouse or using the arrow 
keys. A red rectangle highlights the selected cell. 

2 Double-click the mouse or press ENTER to open a small rectangular, text box above 
the instruction.

3 Enter the operand or symbol name in the text box. 

4 Press ENTER to accept the entry and close the box. Press ESC to close the box 
without changes.

Step Action

1 Select the comparison from the left section, or the operate block from the middle 
section of the Ladder Palette Toolbar, p. 198 by pointing and left-clicking the mouse.

2 The Element Name section of the Ladder Palette toolbar displays Compare or 
Operate.

3 Left-click or press the space bar to insert the instruction. When positioning the 
instruction using the mouse, it is placed in the cell in which you click. When 
positioning the instruction using the space bar, it is placed in the cell which was 
previously selected. To select an cell you must call up the selection tools (arrow 
icon) then left-click or move to the desired cell using the arrow keys. 

4 Double-click the mouse or press ENTER to open a text box above the instruction.

5 Enter an operation string into the text box. Press ENTER when complete. The 
operand appears inside the box. 

6 Press ENTER to accept the entry and close the box. Press ESC to close the box 
without changes.
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Programming in List Language 
At a Glance

Overview This chapter provides detailed instructions for using TwidoSoft to program in 
Instruction List language.

What's in this 
Chapter?

This chapter contains the following sections:

Section Topic Page

6.1 Creating List Programs 228

6.2 Using the List Editor 232

6.3 Inserting List Instructions 235

6.4 Using Edit Functions in the List Editor 241
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Programming in List Language
6.1 Creating List Programs

At a Glance

Overview This section provides an overview of using TwidoSoft to create List programs.

What's in this 
Section?

This section contains the following topics:

Topic Page

Overview of List Programs 229

Creating a List Program 231
228    



Programming in List Language
Overview of List Programs

Introduction A program written in List language consists of a series of instructions executed 
sequentially by the controller. Each List instruction is represented by a single 
program line and consists of three components:
� Line number
� Instruction code
� Operand(s)

Example of a List 
Program

The following is an example of a List program. 

Line Number Line numbers are generated automatically when you enter an instruction. Blank 
lines and Comment lines do not have line numbers.

Instruction Code The instruction code is a symbol for an operator that identifies the operation to be 
performed using the operand(s). Typical operators specify Boolean and numerical 
operations.
For example, in the sample program above, LD is the abbreviation for the instruction 
code for a LOAD instruction. The LOAD instruction places (loads) the value of the 
operand %I0.1 into an internal register called the accumulator.
There are basically two types of instructions:
� Test instructions

These setup or test for the necessary conditions to perform an action. For 
example, LOAD (LD) and AND.

� Action instructions
These perform actions as a result of setup conditions. For example, assignment 
instructions such as STORE (ST) and RESET (R).

 
1 ST %Q0.3
2 LDN %M0
3 ST %Q0.2
4 LDR %I0.2
5 ST %Q0.4
6 LDF %I0.3
7 ST %Q0.5

%I0.1LD

Operand(s)

Line Number

Instruction Code

0

0 LD %I0.1
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Operand An operand is a number, address, or symbol representing a value that a program 
can manipulate in an instruction. For example, in the sample program above, the 
operand %I0.1 is an address assigned the value of an input to the controller. An 
instruction can have from zero to three operands depending on the type of 
instruction code.
Operands can represent the following:
� Controller inputs and outputs such as sensors, push buttons, and relays.
� Predefined system functions such as timers and counters. 
� Arithmetic, logical, comparison, and numerical operations.
� Controller internal variables such as bits and words.
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Creating a List Program

Introduction A List program can be created at any time while developing an application. Once the 
program is completed, you can configure hardware, define symbols, and print 
documentation.
See Developing an Application, p. 67.

Basic Steps The following are the basics steps for creating a List program from an open 
application:

Step Action

1 Open the List Editor, p. 40. Select Program → List Editor from the main 
menu.

2 Configure the List Editor. See Preferences, p. 28 to configure the view of List 
programs. 

3 Enter instruction codes and operands by using one of the following methods 
(see Entering List Instructions, p. 236):
� Select from the List Instruction Bar
� Enter directly from the keyboard

4 Enter comments, See Guidelines for Inserting List Instructions, p. 240.

5 Analyze your program for errors. If there are any errors, open the Program 
Errors Viewer for a detailed description of errors and program reversibility 
problems. See Analyzing a Program, p. 72.

6 Save your program. See Saving an Application, p. 71.

7 Configure your program. See Hardware and Software Configuration , p. 117.

8 Run your program. See Running Applications, p. 87.

9 Animate your program. See Animating a Program, p. 252.

10 Print your program. See Printing Applications, p. 105.
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Programming in List Language
6.2 Using the List Editor

At a Glance

Overview This section describes using the List Editor to view and create List programs.

What's in this 
Section?

This section contains the following topics:

Topic Page

Using the List Editor 233

List Editor Commands 234
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Programming in List Language
Using the List Editor

Introduction Use the List Editor, p. 40 to view and edit a List program. With the List Editor open, 
the following options are available:
� Inserting, modifying, and deleting instruction lines
� Entering comments
� Displaying symbols and addresses
� Using Edit menu commands

Opening the List 
Editor

To open the List Editor, select Program → List Editor from the main menu.

When You Can 
Use the List 
Editor

You can use the List Editor in the Online or Offline state, but not in the Monitor state. 
Typically, use the List Editor in the Offline state to develop a List program, and in the 
Online state to debug a program.
Some instructions require balancing or complementary instructions. For example, a 
BLK instruction requires an END_BLK instruction. An instruction modified by a 
parenthesis requires a closing parenthesis - all in the same scan.
To maintain an effective scan rate, the controller accepts a single instruction line at 
a time. Consequently, there is no way to write these complex instructions without 
severely diminishing the performance of the controller while in the Online state.
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List Editor Commands

Introduction With the List Editor open, the following commands are available from the Tools 
menu:
� Show Symbols
� Show Addresses
� Grafcet Step Table

Viewing 
Operands

You can view operands in a List program as symbols or as addresses. Additionally, 
you can quickly locate Grafcet instructions in a program by using the Grafcet Step 
Table.

Show Symbols To display the symbols for operands:

Show Addresses To display the addresses for operands:

Grafcet Step 
Table

Viewing Grafcet steps is simplified by using the Grafcet Step Table which can be 
displayed by selecting Tools → Grafcet Step Table from the main menu while 
viewing either the List Editor or the Ladder Viewer. 
The table displays the list of Grafcet steps defined in the program in ascending 
order. The initial step is represented by a square with two borders while all other 
steps have a single border. In the online state, the table is animated and the active 
step or steps are highlighted.
To select a step from the Grafcet Step Table, do one of the following: 
� Single click with the mouse on a step and press the ENTER key.
� Double-click on a step.
Once selected from the table, the step will be highlighted in red for both Ladder 
rungs and List instructions.

Step Action

1 Select Show Symbols from the Tools menu or from the toolbar.

2 Operands are displayed as symbols in List instructions if symbols were defined 
for the operands using the Symbol Editor. 

Step Action

1 Select Show Addresses from the Tools menu or from the toolbar.

2 Operands are displayed as addresses in List instructions.
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6.3 Inserting List Instructions

At a Glance

Overview This section provides procedures and guidelines for inserting List instructions in a 
program by using either the mouse or the keyboard.

What's in this 
Section?

This section contains the following topics:

Topic Page

Entering List Instructions 236

Guidelines for Inserting List Instructions 240
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Entering List Instructions

Introduction With the List Editor open, type List instructions directly from the keyboard or select 
operators and operands from the List Instruction Toolbar by using the keyboard 
or the mouse. The List Instruction Toolbar displays the most commonly used 
operators and operands, and this convenience enhances the speed and accuracy 
of creating a List program. Operators and operands that are not available from the 
toolbar have to be entered using the keyboard. 

List Instruction 
Bar

The following is the List Instruction Toolbar, which is located on the List Editor. 

Inserting 
Instructions

To insert List instructions in an existing or new List program, with an open 
application:

F2 F3 F5
LD

F6 F7 F8 F9 F11 F12 F2 F3 F5 F6 F7 F8 F9 F11 F12
ST AND OR XOR IN MPS BLK SR JMP %I %Q %M %S %TM MRD OUT RETBLK

AF2 AF3 AF5
%L %IW %QW

AF6 AF7
%MW %SW

AF8 AF9
%C %MPP ??AF11 AF12

END ENDBLK

Use function key alone Use SHIFT
+function key

Use ALT
+function key

List Instruction Toolbar

Step Action

1 Select Program → List Editor from the main menu to open the List Editor. See 
Preferences, p. 28 to configure the view of List programs. 

2 The cursor is positioned at the beginning of the first program line in the editing 
area of the List Editor, p. 40. 

3 You can enter List Instructions by using the mouse or the keyboard:
� Using the Mouse to Insert List Instructions, p. 237.
� Using the Keyboard to Insert List Instructions, p. 238.
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Using the Mouse 
to Insert List 
Instructions

To insert a List instruction by using the mouse:

Step Action

1 Left-click in the program where you want to enter an instruction.
The text cursor is placed on the selected line. If you click on the last line, the text 
cursor is placed on the last line which is then highlighted in red.

2 Press ENTER anywhere in the program line to create a new program line that 
appears immediately after the current line, or press the INSERT key to insert a new 
blank line immediately before the current line. 

3 Select an instruction from the List Instruction Toolbar by left-clicking on the toolbar 
button. Use the keyboard to enter instructions not available from the toolbar.

4 The selected instruction is inserted at the cursor location. If the instruction was 
selected from the toolbar, a space is automatically included after the instruction to 
allow for separation from the operand, otherwise, enter a space using the 
keyboard.

5 Select an operand from the List Instruction Toolbar by left-clicking on the toolbar 
button. Use the keyboard to enter operands not available from the toolbar.

6 The selected operand is inserted at the cursor location.

7 Enter a numerical value for the specific Instance of the operand by using the 
keyboard.
For example: Click on %TM on the List Instruction Toolbar to insert a Timer 
function block into a program line. The text cursor is positioned immediately after 
the %TM. Enter a valid number for the instance using the keyboard. (Valid 
numbers for instances depend on the controller model (see Maximum Software 
Configuration, p. 160). 

8 Enter optional Comments to document the program. See Line Comments.

9 To complete insertion of the List instruction: press ENTER to complete the line and 
begin a new, blank line; or, use the up and down arrows on the keyboard to move 
the text cursor off the current line; or, click on another line.
Note: The program line is validated for errors, and the List Editor displays errors 
according to the Auto Line Validate setting in Preferences. (See Program Errors 
When Inserting List Instructions, p. 239.)

10 If there are no program errors for the program line, continue entering instructions 
or validate the entire program (see Analyzing a Program, p. 72).
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Using the 
Keyboard to 
Insert List 
Instructions

To insert a List instruction by using the keyboard:

Step Action

1 Use the Up and Down arrows to position the cursor where you want to enter an 
instruction.

2 Press ENTER anywhere in the program line to create a new program line that 
appears immediately after the current line, or press the INSERT key to insert a new 
blank line immediately before the current line.

3 Select an instruction from the List Instruction Toolbar by pressing the keyboard 
shortcut identified on the instruction button, or type in the instruction directly from 
the keyboard. Some operands are not available on the toolbar and must be entered 
using the keyboard. 

4 The selected instruction is inserted at the cursor location. If the instruction was 
selected from the toolbar, a space is automatically included after the instruction to 
allow for separation from the operand, otherwise, enter a space using the 
keyboard.

5 Select an operand from the List Instruction Toolbar by pressing the keyboard 
shortcut identified on the instruction button, or type in the instruction directly from 
the keyboard. Some operands are not available on the toolbar and must be entered 
using the keyboard.

6 The selected operand is inserted at the cursor location.

7 Enter a numerical value for the specific instance of the operand by using the 
keyboard.
For example: Click on %TM on the List Instruction Toolbar to insert a Timer 
function block into a program line. The text cursor is positioned immediately after 
the %TM. Enter a valid number for the instance using the keyboard. (Valid numbers 
for instances depend on the controller model (see Maximum Software 
Configuration, p. 160).

8 Enter optional Comments to document the program. See Line Comments.

9 To complete insertion of the List instruction: press ENTER to complete the line and 
begin a new, blank line; or, use the up and down arrows on the keyboard to move 
the text cursor off the current line.
Note: The program line is validated for errors, and the List Editor displays errors 
according to the Auto Line Validate setting in Preferences. (See Program Errors 
While Entering Instructions.)

10 If there are no program errors for the program line, continue entering instructions 
or validate the entire program (see Analyzing a Program, p. 72).
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Program Errors 
When Inserting 
List Instructions

When you have completed entering a List Instruction in the List Editor, the 
instruction is validated for program errors. The List Editor handles errors according 
to the state of the Auto Line Validate option (see Preferences, p. 28).
� If Auto Line Validate is selected

The List Editor displays the errors in the message section of the Status bar, and 
you can not move the cursor to another line. You have to correct errors to the 
current line before the List Editor permits movement to another instruction line.

� If Auto Line Validate is not selected
The List Editor displays the errors in the message section of the Status bar, and 
you can move the cursor to another line. A question mark (?) is displayed at the 
beginning of the line to mark the line as containing an error, and you may continue 
entering instructions. You can return to this line later to correct the error.

Line Comments Enter optional comments to describe the purpose of a program, individual 
instructions, operands, and so on. Comments consist of text that must be entered 
within parenthesis and enclosed by asterisks as in the following example:
(*THIS IS A COMMENT.*)
Valid text entries are standard keyboard alphanumeric characters: A - Z, 0 - 9, 
"‘~!@#$%^&*()-_+=", and spaces. Letters that are entered in lower case are 
automatically converted to upper case when the line is validated.
There are two methods for inserting comments in a program:
� At the end of a program line

1 LD START_WATER (*STARTS THE PUMP*)
� On a separate Comment Line

1 LD START_WATER 
 (*STARTS THE PUMP*)

Comment Lines do not have line numbers.
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Guidelines for Inserting List Instructions

Introduction Use the following list of guidelines for inserting List instructions.
See Entering List Instructions, p. 236.

Guidelines Guidelines for inserting List instructions: 
1. There are two cursors that can be used for inserting and modifying List 

instructions . The mouse cursor and the text cursor. The text cursor is a short, 
flashing vertical line that can be moved either by using the mouse or the up/down 
arrows on the keyboard. 

2. When inserting an instruction, a space is required between an operator and an 
operand, and between an operand and any comments as in the following 
example:
LD START_SWITCH (*START THE CONVEYOR*)

3. When entering operands using the toolbar, only the type of operand is inserted in 
the program, you will have to add the specific Instance for the operand.
For example, if you inserted a timer function block %TM as an operand in an 
instruction, only %TM appears in the instruction. You must use the keyboard to 
enter a number for the specific instance of the timer to complete address for the 
operand (for example, %TM1).

4. You can enter a symbol such as START_SWITCH for an operand instead of the 
associated address such as %I0.7. 
See Defining Symbols, p. 74.
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6.4 Using Edit Functions in the List Editor

At a Glance

Overview This section provides procedures for using commands from the Edit menu to edit 
List programs in the List Editor.

What's in this 
Section?

This section contains the following topics:

Topic Page

Edit Menu Commands 242

Cut, Copy, and Paste 243

Marking a List Block 245

Find and Replace 246

Find 248

Replace 249

Undo 250
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Edit Menu Commands

Introduction With the List Editor open, use the following commands from the Edit menu to edit a 
single instruction, or a group of instructions:
� Cut, Copy, and Paste, p. 243
� Find and Replace, p. 246
� Undo, p. 250
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Cut, Copy, and Paste

Introduction With the List Editor open, select the following commands from the Edit menu to edit 
a List program:
� Cut, p. 243
� Copy, p. 243
� Paste, p. 244
See Marking a List Block, p. 245.

Cut Use Cut to remove one or more program lines and insert into another location in the 
same program, or in another program. To remove one or program lines in offline or 
online stopped states:

Copy Use Copy to duplicate a marked block from a program and place it in the Clipboard. 
Use Copy and Paste to duplicate lines in a program for use in another location in 
the same program. To copy a marked block in offline or online stopped states:

Step Action

1 See Marking a List Block, p. 245 to select a block of program lines to cut. 
Selections are highlighted in red.

2 Select Cut from the Edit menu.
Note: Press the DELETE key to remove the marked block without copying it to 
the Clipboard. 

3 The marked block is removed from the program and the remaining lines are 
renumbered.

4 Use the Paste command from the Edit menu to insert the removed marked block 
into another location in the same program, or insert into another program.

Step Action

1 See Marking a List Block, p. 245 to select a block of program lines to copy. 
Selections are highlighted in red.

2 Select Copy from the Edit menu.

3 A copy of the marked block is placed in the Windows Clipboard.

4 Use the Paste command from the Edit menu to insert a copy of the marked block 
into another location in the same program, or into another program.
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Paste Use Paste to insert program lines that have been copied into the Clipboard after a 
Cut or Copy command. Insert lines in another location in the same program. To 
Paste a marked block in offline or online stopped states:

Step Action

1 Use Cut or Copy to place a marked block in the Clipboard.

2 Select the line where you want to insert the marked block. The line can be in the 
current program, or close the current program and open another program.

3 Select Paste from the Edit menu.

4 A copy of the marked block is inserted before the selected line.
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Marking a List Block

Introduction Marking a block or region of a List program for cut, copy, paste, delete, search, and 
other commands.

Marking a List 
Block

To mark a block of List instructions:

Step Action

1 Select the first instruction in the block by clicking the mouse anywhere within the 
instruction line, or by using the arrow keys on the keyboard to move the text cursor 
to the instruction line.

2 Select additional lines by clicking and dragging the mouse cursor up or down, or by 
pressing the SHIFT and the up/down arrows on the keyboard.

3 The marked block is the highlighted text in red.
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Find and Replace

Introduction You can search for and replace each occurrence of an operand or text string in List 
programs. You can also search for rung or line numbers, but these cannot be 
replaced.

Types of 
Searches

You can search for the following items in a program. 
� Operands

Address or Symbol: Does not matter if addresses or symbols are displayed. For 
example, if Show Addresses is selected from the Tools menu, you can still 
search for symbols.

� Line
The line number of an instruction when viewing a List program. If the line number 
specified is greater than the highest available line number, then the cursor is 
positioned after the last instruction and at the beginning of a blank instruction line.

� Text String 
A specific text string in the instructions of a List program
Searching for comment and text strings is not case sensitive.

Search Options Three options are available to select a search area in a program:
� Search All: Search the entire program.
� Search From Cursor: Start searching at cursor and continue to end of program.
� Search Selected Region: Search only within a marked block in the program.

See Marking a List Block, p. 245.

Search 
Guidelines

Some general guidelines for searching a program:
� Exact matches only for operands. For example, when searching for %TM0, 

%TM0.V or AND %TM0.Q will not be found. 
� Selecting Text Strings searches for strings in comments, operands, operators, 

labels, and subroutines.
� Subroutines (SRn) and Labels (%Li) are treated as operands.
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General 
Guidelines for 
Using Replace

Some general guidelines for using Replace:
� When replacing operands, only function blocks are replaced. For example, when 

replacing %TM0 with %TM2, %TM0.Q is not replaced with %TM2.Q.
� Source and target operands cannot be unresolved symbols. See Defining 

Symbols, p. 74.
� Replacing a label or subroutine will not change the declaration of the label or 

subroutine. A label or subroutine declaration may be replaced with another label 
or subroutine declaration.

� Subroutines (SRn) and Labels (%Li) are treated as operands.
� For Comment or Text strings, any strings that can be located using Find can be 

replaced.

Replacing 
Operands

For operands, you can replace: 
� Bits with bits (For example, replace %I0.0 with %M2)
� Words with words (For example, replace %MW100 with %SW12)
� Function blocks with like function blocks (For example, replace %TM0 with %TM2 

is allowed, %TM0 with %C3 is not allowed)
� Immediate values with immediate values (For example, replace 7 with 8)
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Find

Introduction Use the Find dialog box to search for each occurrence of an operand, rung/line 
numbers, or comment/text strings in Ladder and List programs. Once the first 
instance of an item is found, the dialog box changes to display only command 
buttons to simplify searching and replacing (see Step #7 below). This dialog box is 
displayed by selecting Edit → Find from the main menu while viewing a program in 
the Ladder Viewer or List Editor. 
See Find and Replace, p. 209 for Ladder programs, or Find and Replace, p. 246 for 
List programs.

Searching a 
Program

With a program displayed in the Ladder Viewer or the List Editor:

Step Action

1 Select Edit → Replace from the main menu to open the Replace dialog box.

2 With the Find dialog box open, click on the Find drop-down list and select the type 
of item for the search.

3 In the text box below Find, enter a specific item that you want to locate.

4 Select one of the search Options. For selecting a region, see Marking a Ladder 
Block, p. 208 or Marking a List Block, p. 245. )

5 Click on OK to close the dialog box and start the search.

6 If the item is not found, an information box is displayed confirming "Item not found." 
Select OK to close the information box and return to the Find dialog box.

7 If the item is found, it is highlighted in red. The dialog box changes to display the 
following buttons:
� Find Next - select to search for another instance.
� Cancel - select to close the dialog box.

8 To continue searching, press the Find Next button. (Go to Step #7.)

9 To stop searching, press the Cancel button to close the dialog box.

10 After the last instance of the value or text is found, or if the search does not find any 
instance of the specified value or text, an information dialog box is displayed stating 
"Item not found." Press OK to close the box.
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Replace

Introduction Use the Replace dialog box to search for and replace an operand or comment/text 
strings in Ladder and List programs. Once the first instance of an item is found, the 
dialog box changes to display just command buttons to simplify searching and 
replacing (see Step #8). This dialog box is displayed by selecting Edit → Replace 
from the main menu while viewing a program in the Ladder Viewer or List Editor. 
See Find and Replace, p. 209 for Ladder programs, or Find and Replace, p. 246 for 
List programs.

Using Replace To search for and replace an operand or text string:

Step Action

1 Select Edit → Replace from the main menu to open the Replace dialog box.

2 Click on the Find box and select the type of item to be replaced. 

3 In the box below the Find box, enter the specific item that will be replaced.

4 In the Replace with box, enter the specific item that will be the replacement.

5 Select one of the search Options.

6 Click on OK to close the dialog box and start the search.
You can also select Replace All to replace all instances of the item. Found instances 
will not be displayed, but an information box is displayed confirming the number of 
occurrences (items replaced). Select OK to close the information box and the 
Replace dialog box.

7 If an item is not found, an information box is displayed confirming "Item not found." 
Select OK to close the box and return to the Replace dialog box.

8 If an item is found, it is highlighted in red. The dialog box changes to display four 
buttons:
� Find Next - select to leave highlighted instance unchanged and search for 

another instance.
� Replace - select to replace the highlighted instance.
� Replace All - select to replace all instances of the item.
� Cancel - select to close the dialog box without any further changes (previous 

changes are retained).

9 After the last instance of the value or text is found, or if the search does not find any 
instance of the specified value or text, an information dialog box is displayed stating 
"Item not found." Press OK to close the box.

10 When the Replace dialog box is closed, an information box is displayed confirming 
the number of occurrences (items replaced).
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Undo

Introduction Use Undo to reverse the last Cut, Paste, or Delete operation.

Using Undo To use Undo:

Step Action

1 Select Undo from the Edit menu.

2 The previous editing operation is reversed.
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Debugging and Adjusting an 
Application 
At a Glance

Overview This chapter provides details on debugging and adjusting an application. 

What's in this 
Chapter?

This chapter contains the following topics:

Topic Page

Animating a Program 252

Using the Animation Tables Editor 254

Animation Tables Editor Commands 256

Inserting, Editing, and Deleting Variables 257

Reading and Writing Values 259

Add Next and Previous Instances 261

Forcing Input/Output Values 262

Opening and Saving Animation Tables 264

Animating a Table 266

Modifying a Program in RUN mode 267

Modifying a Program in Stop Mode 269

Memory editor 271

Memory editor: Display Tab 272

Memory editor: Edit Tab 274
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Animating a Program

Introduction Animating a program provides a view of actual values of variables when a program 
is online, either running or stopped. This is useful for debugging because changes 
in values can be viewed as the program runs to compare the actual values against 
expected values.

Values Animated 
for Ladder 
Programs 

When animating a Ladder program, the following data is displayed in the Ladder 
Viewer:
� Contacts, coils, and special objects with logical results of 1 are highlighted.
� The data variables of function blocks, compare blocks, and operate blocks are 

displayed including the current and preset values.
Binary operands are displayed as 0 or 1, while all other values are displayed in 
hexadecimal or decimal, depending on the format selected in the Preferences, 
p. 28 dialog box.

Animating a 
Ladder Program

To animate a Ladder Program, with the Ladder Viewer open, and a program online 
(running or stopped):

Values Animated 
for List Programs 

When animating a List program, the following values are animated in the List Editor:
� A column is added to the right of the Line Number column. This column contains 

the value of the operand for that program line.
If an instruction contains more than one operand, the value of each operand is 
displayed and separated by a slash character (/).

� Binary operands are displayed as 0 or 1, while all other values are displayed in 
hexadecimal or decimal, depending on the format selected in the Preferences, 
p. 28 dialog box.

Step Action

1 Select Controller → Toggle Animation from the main menu.
The Ladder Viewer displays the following:
� Animating is displayed in the title bar of the Ladder Viewer.
� Animated data (see Values Animated for Ladder Programs , p. 252).

2 Select Controller → Toggle Animation from the main menu to turn off animation.
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Values Not 
Animated for List 
Programs 

When animating a List program, the following values are not animated in the List 
Editor, but are represented by an asterisk (*):
� Labels (%Li)
� Subroutines (SRn)
� Instructions that have no operands (NOT, NOP, END)
� Immediate values
� Indexed words
� Bits extracted from words
� Tables of words
� String of bits (for example, %M0:5)

Display of 
Forced Bits

Forced bits are displayed with an F paired with the forced state, either a 0 or a 1:
� A bit operand that is forced On, is displayed as "F  1".
� A bit operand that is forced Off, is displayed as "F  0".
See Forcing Input/Output Values, p. 262.

Animating a List 
Program

To animate a List program, with the List Editor open and a program online (running 
or stopped):

Step Action

1 Select Controller → Toggle Animation from the main menu.
Animating is displayed in the title bar of the List Editor.
The List Editor displays animated values (see Values Animated for List Programs , 
p. 252).

2 Select Controller → Toggle Animation from the main menu to turn off animation.
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Using the Animation Tables Editor

Introduction  The Animation Tables Editor, p. 51 is used to view and modify program variables to 
assist in debugging a program. The Animation Tables Editor can also be used to 
force the values of input or output bits.
The list of data variables that the Animation Tables Editor displays is known as an 
Animation Table.

Animation 
Tables

An Animation Table displays a list of controller variables that you want to monitor 
and save. Data in the table is organized similar to a spreadsheet with six columns: 
� Address
� Current
� Retained
� Format
� Symbol
� Valid

Address An Address is a specific location in controller memory, always preceded by a 
percent sign (%). An address does not require an assigned symbol, but a symbol 
must have an assigned address.

Current The Current value is the actual value of a variable in the controller. In the online 
state, this value changes as the program runs. This changing value can be 
monitored by animating the program. 
An asterisk (*) appears in this column prior to the first time the data is animated. 
When the data is animated and subsequently turned off, the Current column 
displays the last updated value.

Retained The Retained value is the initial value for variables in the controller. When the Write 
Retained Values command is performed, these values are written to the controller.

Format The Format column identifies the number format of the data variable. Options are 
Decimal, Hexadecimal, Binary, Floating Point or ASCII.

Symbol A Symbol is a name you assigned to the address in the Symbol Editor, p. 44 to 
identify the purpose of the variable. A symbol must have an assigned address.
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Valid The Valid column indicates if the variable or object has been validated. A variable 
is Valid only when it has been configured in the currently opened application 
program. A green check mark indicates a valid variable or object, while a red X 
identifies a variable or object that is invalid or not configured in the currently 
configured opened application program.
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Animation Tables Editor Commands

Introduction The Animation Tables Tools menu is used to construct, edit, and save an animation 
table. Additionally, you can modify and force values for selected variables in a 
program.
With the Animation Tables Editor open, the following commands are available from 
the Tools Menu:
� Add Next Instance (See Add Next and Previous Instances, p. 261)
� Add Previous Instance (See Add Next and Previous Instances, p. 261)
� Force 1 (See Forcing Input/Output Values, p. 262)
� Force 0 (See Forcing Input/Output Values, p. 262)
� Clear Force (See Forcing Input/Output Values, p. 262)
� Clear All Force (See Forcing Input/Output Values, p. 262)
� Read Retained Values (See Reading and Writing Values, p. 259)
� Write Retained Values (See Reading and Writing Values, p. 259)
� Write Data Value (See Reading and Writing Values, p. 259)
� Open Animation Table (See Opening and Saving Animation Tables, p. 264)
� Save Animation Table (See Opening and Saving Animation Tables, p. 264)
� Save Animation Table As (See Opening and Saving Animation Tables, p. 264)
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Inserting, Editing, and Deleting Variables

Introduction Use the Animation Tables Editor to insert, edit, and delete variables in an animation 
table. The following conditions are required:
� An application must be open.
� A PC must be connected to the controller.
� The controller can be running or stopped.

Inserting a 
Variable

To insert a single variable in an animation table:

Editing a 
Variable

To edit a single variable in an animation table:

Step Action

1 Left-click on an Address cell and enter a variable or object. Entry must be preceded 
by a percent symbol (%). 

2 Press ENTER to complete the entry.
The following default values are displayed automatically for the entry:
� Current value defaults to an asterisk (*).
� Retained value defaults to 0.
� Format defaults to Decimal.
� The Symbol for the variable, if previously defined in currently opened 

application. See Defining Symbols, p. 74.

Step Action

1 Left-click on an Address cell to edit the address for the variable or object.
You can also highlight text using the mouse to edit a specific portion of the entry, or 
double-click in the cell to highlight the entire entry.
The Current column is read-only. It updates only when TwidoSoft is connected to 
the controller (online state).

2 To modify the Retained value, left-click in the cell and enter a value. Only valid 
entries will be accepted.

3 To update the Display Format, left-click in the column and select an option from a 
list of valid formats. Only valid options for the given data type will be available.
Options:Decimal, Hexadecimal, Binary, Floating Point or ASCII.

4 Press ENTER to accept the display format change.
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Deleting a 
Variable

To delete a single variable from an animation table:

5 The symbol for the variable can not be edited directly from the Animation Tables 

Editor. Click on the Symbol Mode button  in the toolbar to display the Symbol 

Editor to create a new symbol or edit an existing symbol. See Defining Symbols, 
p. 74.
Note: If a symbol has not been previously defined, it will not be displayed in the 
Animation Tables Editor. An animation table can be saved as a separate file from 
the application.

6 Click on the Animation Editor button  in the toolbar to return to the Animation 

Tables Editor.

Step Action

Step Action

1 Select a variable to delete by left-clicking on any entry in a variable row in the 
animation table, or clicking on the row number.

2 Select Tools → Delete Row, or click on the Delete Row button  on the toolbar, 

or click on the DELETE key.
The variable row is deleted.
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Reading and Writing Values

Introduction Use read and write values commands to transfer values between an animation table 
and the controller. The following commands are available from the Tools menu 
when the Animation Tables Editor is open:
� Read Retained Values

Transfer Current values on the controller to Retained values in an animation 
table.

� Write Retained Values
Transfer Retained values in the animation table to the Current values in the 
controller.

� Write Data Value
Momentarily send a single data value to the controller. An animation table does 
not need to be open.

For these commands, the program must be online, either stopped or running. An 
animation table must be open and animated.

Read Retained 
Values

To transfer Current values on the controller to Retained values in an animation table:

Write Retained 
Values

To transfer Retained values in an animation table to the Current values in the 
controller:

Step Action

1 Select Tools → Read Retained Values from the main menu or from the Animation 
Tables Editor toolbar.

2 The Retained values column is updated with the values from the Current values 
column.

Step Action

1 Select Tools → Write Retained Values from the main menu or from the Animation 
Tables Editor toolbar.

2 The Current values column is updated with the values from the Retained values 
column.
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Write Data Value To transfer a single data value to the controller:

Step Action

1 Select Tools → Write Data Value from the main menu or from the Animation Tables 
Editor toolbar. An animation table does not need to be open.
The Write Data Value dialog box is displayed.

2 Enter a variable in the Data Object box.
The Current Value box displays the current value for the selected variable.

3 Select the format for the value from the format list. 
Options: Decimal, Hexadecimal, Binary, Floating Point or ASCII.
Default: Decimal.

4 In the Write Data Value box, enter a value to write to the controller for the variable.

5 Select OK to write the value to the controller. Select Cancel to return to the Animation 
Tables Editor without writing the value to the controller.
Note: Depending on the frequency of changes for the variable, the change in values 
may not be detectable.
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Add Next and Previous Instances

Introduction The Add Next Instance and the Add Previous Instance commands add sequential 
instances of a variable to the animation table. For example, if the variable %I0.3 is 
currently highlighted in an animation table, selecting Add Next Instance inserts the 
new variable %I0.4 immediately after %I0.3 in the animation table. The following two 
commands are available from the Tools menu with the Animation Tables Editor 
open:
� Add Next Instance

Adds the next sequential instance of a variable highlighted in the table. For 
example, if %I0.3 is highlighted, variable %I0.4 is added to the table.

� Add Previous Instance
Adds the previous sequential instance of a variable highlighted in the table. For 
example, if %I0.3 is highlighted, variable %I0.2 is added to the table.

Add Next 
Instance

To add the next sequential instance of a variable highlighted in the table:

Add Previous 
Instance

To add the previous sequential instance of a variable highlighted in the table:

Step Action

1 Select a variable in the animation table.

2 Select Add Next Instance from the Tools menu, or from the Animation Tables 
Editor toolbar, or press CTL+DOWN. 
A new variable of the same type is added to the animation table with a sequential 
number decremented by one from the highlighted variable.

Step Action

1 Select a variable in the animation table.

2 Select Add Previous Instance from the Tools menu, or from the Animation 
Tables Editor toolbar, or press CTL+UP.
A new variable of the same type is added to the animation table with a sequential 
number decremented by one from the highlighted variable.
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Forcing Input/Output Values

Introduction The Animation Tables Editor can be used to force inputs and outputs bits to 0 or 1 
values even if the actual values are different. The Current value column of the 
animation table displays an F next to the value if it is a forced value and the table is 
animated. The value remains forced even when the PC is disconnected from the 
controller and TwidoSoft is closed.

Force 
Commands

The following force commands are available in animation tables: 
� Force 1 - sets a value to 1.
� Force 0 - sets a value to 0.
� Clear force - removes a forced value from a selected variable.
� Clear All Force - removes all forced values from variables.
The force commands are available from the Tools menu and the Animation Tables 
Editor toolbar when the Animation Tables Editor is open and the controller is online, 
either running or stopped. An animation table must be open and animated.

Force 1 To force the value of a variable to 1 in an animation table:

Force 0 To force the value of a variable to 0 in an animation table:

Clear Force To remove a forced value from a variable in an animation table:

Step Action

1 Highlight a variable in the animation table.

2 Select Tools → Force 1 from the main menu.
The animation table displays an F next to the current value of 1.

Step Action

1 Highlight a variable in the animation table.

2 Select Tools → Force 0 from the main menu.
The animation table displays an F next to the current value of 0.

Step Action

1 Highlight a variable in the animation table.

2 Select Tools → Clear Force from the main menu.
The forced value is removed from the highlighted variable in the animated table.
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Clear All Force To remove all forced value in an animation table:

Step Action

1 Highlight a variable in the animation table.

2 Select Tools → Clear All Force from the main menu.
All forced values are removed from the animation table.
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Opening and Saving Animation Tables

Introduction Animation tables can be saved for later use. Although animation tables are usually 
associated with an open application, it is possible to open and use an existing 
animation table created by another application.

Commands The following commands are available from the Tools menu with the Animation 
Tables Editor open: 
� Open Animation Table

Open a previously saved animation table file.
� Save Animation Table

Save current animation table with a file extension of .tat (default). Once saved, 
the title of the animation table appears on the title bar of the Animation Tables 
Editor.

� Save Animation Table As
Save an animation table for the first time or rename an animation table file.

Opening an 
Animation Table

To open a previously saved animation table:

Initial Save of an 
Animation Table 

To save an animation table for the first time:

Step Action

1 Select Tools → Open Animation Table from the main menu. The Open dialog box 
is displayed.

2 Select a file with a .tat extension from the list, or browse to find a file.

3 Double-click to open the selected file, or left-click and press the Open button in the 
dialog box. 

4 The Animation Tables Editor displays the selected animation table.

Step Action

1 Select Tools → Save Animation Table As from the main menu. The Save As dialog 
box is displayed.

2 Enter a file name for the animation table. File names can be up to 255 characters.
Note: Do not use any of the following characters: \:*?<>|".

3 Click the Save button.The animation table is saved with the extension of .tat (default). 
The file name and path are displayed in the title bar of the Animation Tables Editor.
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Saving Changes 
to an Animation 
Table 

To save changes to a previously saved animation table:

Step Action

1 Select Tools → Save Animation Table from the main menu.

2 Changes are saved to the open animation table.
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Animating a Table

Introduction Animating a table of data variables displays and updates the Current Value column 
of the animation table as the controller runs.
To animate a table:
� An application must be open.
� A PC must be connected to the controller.
� The controller can be running or stopped.

Animating a 
Table

To animate a table:

Step Action

1 Select Program → Animation Tables Editor from the main menu to open the 
Animation Tables Editor.
Before the table is animated for the first time, the Current column contains asterisks 
(*). If the application is not connected to the controller already, see Connecting a PC 
to the Controller, p. 89.

2 When the PC is connected to the controller, select Controller → Toggle Animation 
from the main menu to animate the table.
The Current Values in the Current column are updated and "Animating" appears in 
the title bar of the editor.

3 Select Controller → Toggle Animation from the main menu to turn off animation.
The Current Values will retain the last updated value.
266    



Debugging and Adjusting an Application
Modifying a Program in RUN mode

Introduction The List Editor allows a List program to be modified when the controller is in RUN 
Mode.

Modifying a 
Program in RUN 
Mode

To modify a program in RUN mode, TwidoSoft requires that all modifications be 
validated before being transferred to the controller. This requires moving the cursor 
off of the line being modified to force the validation. This works in the same manner 
as selecting the setting Auto Line Validate in Preferences, p. 28. The valid 
modifications take effect as soon as the current entry is confirmed.

WARNING

Unpredictable Equipment Operation

For safety reasons, it is advisable to program a controller in STOP 
mode. Programming a controller in RUN mode can present hazards to 
both equipment and personnel.
It is possible to program a controller in RUN mode if a modification to a 
program does not require the controller to be stopped. However, 
ensuring safe operating conditions remains the responsibility of the 
user.
Before any modifications are performed, it is essential to identify the 
consequences of modifications made to an application while the 
controller is running. Perform all necessary preventative actions to 
ensure safe conditions while making modifications.

Failure to follow this precaution can result in death, serious injury, 
or equipment damage.
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Restrictions in 
RUN Mode

The following table lists the restrictions to modifications when the controller is in 
RUN mode.

Function Limits

Configuration Access to display only

Programming All modifications, insertions, and deletion of instructions are permitted, 
except for the following instructions that modify the structure of the 
program:
� Parenthesis
� Grafcet Instructions
� Labels
� Jump or subroutine calls (JMP and SR)
� Block instructions (BLK, OUT_BLK, and END_BLK)
� Coil routing instructions (MPS, MRD, and MPP)
The following instructions are not available:
� Find and replace
� Backing up an application to internal EEPROM
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Modifying a Program in Stop Mode

Introduction The List Editor allows a List program to be modified when the controller is in Stop 
Mode.

Modifying a 
Program in Stop 
mode

To modify a program in Stop mode, TwidoSoft requires that all modifications be 
validated before being transferred to the controller. This requires moving the cursor 
off of the line being modified to force the validation. This works in the same manner 
as selecting the setting Auto Line Validate in Preferences, p. 28. The valid 
modifications take effect as soon as the current entry is confirmed.

Restrictions in 
Stop Mode

You can create changes to an application that can prevent the controller from 
running the application.  This creates the state "Stop/Not Exec" that is displayed in 
the status bar. The controller will not go back into the "Stop/Exec" state until all 
causes for the non-executable state have been resolved. These changes can be 
grouped into six categories, which are described in the following table.

WARNING

Unpredictable Equipment Operation

Before any modifications are performed, it is essential to identify the 
consequences of modifications made to an application while the 
controller is running. Perform all necessary preventative actions to 
ensure safe conditions while making modifications.

Failure to follow this precaution can result in death, serious injury, 
or equipment damage.

Function Restrictions to Running an Application

Parentheses � An opening parenthesis with no closing parenthesis.
� A closing parenthesis with no opening parenthesis (unbalanced 

parentheses).
� More than eight nested parentheses.

Function Blocks � Block that has a beginning with no end (BLK is not followed by an 
END_BLK).

� A block that has an end/output with no start (END_BLK or 
OUT_BLK not preceded by BLK).

� An invalid block (block that contains invalid logic).
� BLK not followed by a LD instruction.
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Subroutines � Call to a non-existent subroutine. Two possible cases:
- Referencing a non-existent subroutine.
- Deleting a label that is referenced elsewhere in the application.

� A subroutine without a return.
� A return without a start for the subroutine.
� A subroutine with multiple definitions. 
� A subroutine definition not followed by a LD instruction.
� Definition of subroutine or End of Subroutine (RET) in parentheses.

Labels � A jump to a non-existent label. Two possible cases:
- Referencing a non-existent label.
- Deleting a label that is referenced elsewhere in the application.

� A label with multiple definitions.
� A label definition not followed by a LD instruction.
� A label definition in parentheses.

Grafcet instructions � A transition to a non-existent step. Two possible cases:
- Referencing a non-existent step.
- Deleting a step that is referenced elsewhere in the application.

� A step with multiple definitions.
� A step definition not followed by a LD instruction.
� Use of Grafcet instructions in Pre or Post processing.

Stack operations 
(Push/Pop)

� The number of Pops is more than the number of Pushes.
� More than eight levels of nesting.

Note: Special care must be taken when inserting or deleting stack instructions 
(MPP, MPS, MRD) in the stop state. Analyze the program to be sure of restrictions 
before re-starting the controller.

Function Restrictions to Running an Application
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Memory editor

Introduction The memory editor enables you to view and optimize the memory resources of the 
PLC.
It is composed of two tabs:
� The View (See Memory editor: Display Tab, p. 272) tab, which indicates memory 

usage concerning:
� the PLC's memory usage (data, program, configuration and system),
� the memory distribution of the application.

� an Edit (See Memory editor: Edit Tab, p. 274) tab, which enables you to modify 
the assignment of the PLC objects (function blocks, registers, memory objects).

Access to the 
memory editor

The table below describes the procedure for accessing the memory editor.

Step Action

1 Open the required application.

2 Double-click the Memory indicator zone located in the status bar.
or
select the Controller → Memory usage command.
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Memory editor: Display Tab

Introduction The View tab includes all information relating to the PLC's memory usage.
The information is updated on opening the editor.

Illustration The illustration below shows the View tab of the memory editor.  

Note: When the application or data are using too large for the memory available a 
single red block is displayed ≥ 100%.
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Description The following table describes the various components of the Display tab.

Field Item Description

User data Memory bits Number of internal %Mi bits used by the application.

Memory words Number of internal %MWi words used by the 
application.

Backup Size of backup application.
Note: the sign ???appears if an application backup 
has not been performed.

RAM = EEPROM Indicates if the RAM memory content is identical to 
the EEPROM memory.
Note: the sign ???appears if an application backup 
has not been performed.

Constants Number of %KWi configuration constants used by the 
application.

Configuration Number of words used by the application (other than 
those indicated above).

Available memory 
data

Size of available memory (excluding program).

User 
program

Executable code Size of user program.

Program data Number of words used by the application data. 

Online Mod. Size of memory allocated for modifying the 
application program in online mode.
On switching to online mode, or when the application 
is transferred in the PLC, this field is reset to 0.
On switching to offline mode, the current value is 
saved to the memory.

Available memory 
code

Size of available program memory.

Others Executable data Size of memory reserved for execution of the program 
in the PLC.

Mem. 1 - Graphic representation of the memory usage rate for 
the internal RAM (available on all Twido controllers).

Mem. 2 - Graphic representation of the memory usage rate for 
the external RAM (not available on TWDLCAA10DRF 
controllers).
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Memory editor: Edit Tab

Introduction The Edit tab presents the list of data objects that are used and usable by the 
application.
All data objects configured or used occupy memory space. It is therefore possible to 
optimize the PLC's memory requirements by only configuring the number of data 
objects actually needed by the application. 

Illustration The illustration below shows the Edit tab of the memory editor.  

Note: Optimization of memory space can only be performed in offline mode.

Number of preallocated objects

HelpCancelOK

View Edit

Memory usage

Constants %KW 19 9

Counters %C 53 3

Drums %DR 6 4

Fast counters %FC 8 5

LIFO/FIFO Registers %R 27 20

Memory Words %MW 30 12

PLS/PWM %PLS/%PWM 25 5

Shift Registers %SBR 56 6

Schedule blocks 91 1

Step counters %SC 9 5

Timers %TM 45 5

Very Fast Counters %VFC 2 1

Type Maximum Allocated Configured

4

Auto

Auto

Auto

9

Auto

25

46

Auto

Auto

Auto

Auto
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Description The following table describes the various components of the Edit tab. 

Column Description

"Data Object" List of data objects predefined by the application.

Type Address associated with the corresponding data object type.

Maximum Maximum number of data objects authorized for the controller.

Allocated Number of data objects used by the application (1).

Configured Number of data objects configured.
The possible values are Auto, then 1 and the maximum value of the data 
object in question. 
By default, the value displayed is Auto. This means that the number of data 
objects configured is equal to the number of data objects used (1).

To modify a value, enter the value directly or use the drop-down menu. Carry 
out the same procedure for each data object type and then confirm by clicking 
Ok.

(1) It is better first to use data objects with the lowest index, then continue 
in ascending order (e.g.: %TM0, %TM1). In fact, an application that uses 
for example the data object %TM3 automatically configures the timers 
%TM0 to %TM3 and so needlessly takes up memory space.

Note: In the event that the value entered is less than the number of data objects 
actually used, an error appears during the application transfer. However, we 
recommend you carry out a program analysis after the optimization operation. The 
error objects appear in the error window of the program.
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Glossary
% Prefix that identifies internal memory addresses in the controller that are used to 
store the value of program variables, constants, I/O, and so on.

Addresses Internal registers in the controller used to store values for program variables, 
constants, I/O, and so on. Addresses are identified with a percentage symbol (%) 
prefix. For example, %I0.1 specifies an address within the controller RAM memory 
containing the value for input channel 1.

Analog 
potentiometer

An applied voltage that can be adjusted and converted into a digital value for use by 
an application.

Analyze program A command that compiles a program and checks for program errors: syntax and 
structure errors, symbols without corresponding addresses, resources used by the 
program that are not available, and if the program does not fit in available controller 
memory. Errors are displayed in the Program Errors Viewer. 

Animation table Table created within a language editor or an operating screen. When a PC is 
connected to the controller, provides a view of controller variables and allows values 
to be forced when debugging. Can be saved as a separate file with an extension of 
.tat.

!

A
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Animation 
Tables Editor

A specialized window in the TwidoSoft application for viewing and creating 
Animation Tables.

Application A TwidoSoft application consists of a program, configuration data, symbols, and 
documentation.

Application 
browser

A specialized window in the TwidoSoft that displays a graphical tree-like view of an 
application. Provides for convenient configuration and viewing of an application.

Application file Twido applications are stored as file type .twd. 

ASCII (American Standard Code for Information Interchange) Communication protocol for 
representing alphanumeric characters, notably letters, figures and certain graphic 
and control characters.

Auto line validate When inserting or modifying List instructions, this optional setting allows for program 
lines to be validated as each is entered for errors and unresolved symbols. Each 
element must be corrected before you can exit the line. Selected using the 
Preferences dialog box. 

Auto load A feature that is always enabled and provides for the automatic transfer of an 
application from a backup cartridge to the controller RAM in case of a lost or 
corrupted application. At power up, the controller compares the application that is 
presently in the controller RAM to the application in the optional backup memory 
cartridge (if installed). If there is a difference, then the copy in the backup cartridge 
is copied to the controller and the internal EEPROM. If the backup cartridge is not 
installed, then the application in the internal EEPROM is copied to the controller.

Backup A command that copies the application in controller RAM into both the controller 
internal EEPROM and the optional backup memory cartridge (if installed).

Coil A ladder diagram element representing an output from the controller.

B
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Cold start or 
restart

A start up by the controller with all data initialized to default values, and the program 
started from the beginning with all variables cleared. All software and hardware 
settings are initialized. A cold restart can be caused by loading a new application into 
controller RAM. Any controller without battery backup always powers up in Cold 
Start.

Comment lines In List programs, comments can be entered on separate lines from instructions. 
Comments lines do not have line numbers, and must be inserted within parenthesis 
and asterisks such as: (*COMMENTS GO HERE*). 

Comments Comments are texts you enter to document the purpose of a program. For Ladder 
programs, enter up to three lines of text in the Rung Header to describe the purpose 
of the rung. Each line can consist of 1 to 64 characters. For List programs, enter text 
on n unnumbered program line. Comments must be inserted within parenthesis and 
asterisks such as: (*COMMENTS GO HERE*). 

Compact 
controller

Type of Twido controller that provides a simple, all-in-one configuration with limited 
expansion. Modular is the other type of Twido controller. 

Configuration 
editor

Specialized TwidoSoft window used to manage hardware and software 
configuration.

Constants A configured value that cannot be modified by the program being executed.

Contact A ladder diagram element representing an input to the controller. 

Counter A function block used to count events (up or down counting).

Cross references Generation of a list of operands, symbols, line/rung numbers, and operators used in 
an application to simplify creating and managing applications.

Cross 
References 
Viewer

A specialized window in the TwidoSoft application for viewing cross references.

Data variable See Variable.

Date/Clock 
functions

Allow control of events by month, day of month, and time of day. See Schedule 
Blocks.
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Drum controller A function block that operates similar to an electromechanical drum controller with 
step changes associated with external events.

EEPROM Electrically Erasable Programmable Read-Only Memory. Twido has an internal 
EEPROM and an optional external EEPROM memory cartridge. 

Erase This command deletes the application in the controller, and has two options:
� To delete the contents of the controller RAM, the controller internal EEPROM, 

and the installed optional backup cartridge.
� To delete the contents of the installed optional backup cartridge only.

Executive loader A 32-Bit Windows application used for downloading a new Firmware Executive 
program to a Twido controller. 

Expansion bus Expansion I/O Modules connect to the base controller using this bus.

Expansion I/O 
modules

Optional Expansion I/O Modules are available to add I/O points to a Twido controller. 
(Not all controller models allow expansion).

Fast counters A function block that provides for faster up/down counting than available with the 
Counters function block. A Fast Counter can count up to a rate of 5 KHz. 

FIFO First In, First Out. A function block used for queue operations.

Firmware 
executive

The Firmware Executive is the operating system that executes your applications and 
manages controller operation.

Forcing Intentionally setting controller inputs and outputs to 0 or 1 values even if the actual 
values are different. Used for debugging while animating a program. 

Function block A program unit of inputs and variables organized to calculate values for outputs 
based on a defined function such as a timer or a counter.
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Grafcet Grafcet is used to represent the functioning of a sequential operation in a structured 
and graphic form.
This is an analytical method that divides any sequential control system into a series 
of steps, with which actions, transitions, and conditions are associated.

Init state The operating state of TwidoSoft that is displayed on the Status Bar when TwidoSoft 
is started or does not have an open application.

Initialize A command that sets all data values to initial states. The controller must be in Stop 
or Error mode.

Instance A unique object in a program that belongs to a specific type of function block. For 
example, in the timer format %TMi, i is a number representing the instance.

Instruction List 
language

A program written in instruction list language (IL) is composed of a series of 
instructions executed sequentially by the controller. Each instruction is composed of 
a line number, an instruction code, and an operand. 

Ladder editor Specialized TwidoSoft window used to edit a Ladder program.

Ladder language A program written in Ladder language is composed of graphical representation of 
instructions of a controller program with symbols for contacts, coils, and blocks in a 
series of rungs executed sequentially by a controller.

Ladder list rung Displays parts of a List program that are not reversible to Ladder language.

Latching input Incoming pulses are captured and recorded for later examination by the application.

LIFO Last In, First Out. A function block used for stack operations.
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List editor Simple program editor used to create and edit a List program.

Master controller A Twido controller configured to be the Master on a Remote Link network.

Memory 
cartridge

Optional Backup Memory Cartridges that can be used to backup and restore an 
application (program and configuration data). There are two sizes available: 32 and 
64 Kb.

Memory usage 
indicator

A portion of the Status Bar in the TwidoSoft main window that displays a percentage 
of total controller memory used by an application. Provides a warning when memory 
is low.

Modbus A master-slave communications protocol that allows one single master to request 
responses from slaves.

Modular 
controller

Type of Twido controller that offers flexible configuration with expansion capabilities. 
Compact is the other type of Twido controller.

Monitor state The operating state of TwidoSoft that is displayed on the Status Bar when a PC is 
connected to a controller in a non-write mode.

Offline operation An operation mode of TwidoSoft when a PC is not connected to the controller and 
the application in PC memory is not the same as the application in controller 
memory. You create and develop an application in Offline operation.

Offline state The operating state of TwidoSoft that is displayed on the Status Bar when a PC is 
not connected to a controller.

Online operation An operation mode of TwidoSoft when a PC is connected to the controller and the 
application in PC memory is the same as the application in controller memory. 
Online operation can be used to debug an application.

Online state The operating state of TwidoSoft that is displayed on the Status Bar when a PC is 
connected to the controller.
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Operand A number, address, or symbol representing a value that a program can manipulate 
in an instruction. 

Operating states Indicates the TwidoSoft state. Displayed in the status bar. There are four operating 
states: Initial, Offline, Online, and Monitor.

Operator A symbol or code specifying the operation to be performed by an instruction. 

PC Personal Computer.

Peer controller A Twido controller configured as a slave on a Remote Link network. An application 
can be executed in the Peer Controller memory and the program can access both 
local and expansion I/O data, but I/O data can not be passed to the Master 
Controller. The program running in the Peer Controller passes information to the 
Master Controller by using network words (%INW and %QNW).

PLC Twido programmable controller. There are two types of controllers: Compact and 
Modular. 

PLS Pulse Generation. A function block that generates a square wave with a 50% on and 
50% off duty cycle.

Preferences A dialog box with selectable options for setting up the List and Ladder program 
editors.

Program errors 
viewer

Specialized TwidoSoft window used to view program errors and warnings.

Programmable 
controller

A Twido controller. There are two types of controllers: Compact and Modular. 

Protection Refers to two different types of application protection: password protection which 
provides access control, and controller application protection which prevents all 
reads and writes of the application program.

PWM Pulse Width Modulation. A function block that generates a rectangular wave with a 
variable duty cycle that can be set by a program. 
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RAM Random Access Memory. Twido applications are downloaded into internal volatile 
RAM to be executed.

Real-time clock An option that will keep the time even when the controller is not powered for a limited 
amount of time. 

Reflex output In a counting mode, the very fast counter's current value (%VFC.V) is measured 
against its configured thresholds to determine the state of these dedicated outputs.

Registers Special registers internal to the controller dedicated to LIFO/FIFO function blocks.

Remote 
controller

A Twido controller configured to communicate with a Master Controller on a Remote 
Link network. 

Remote link High-speed master/slave bus designed to communicate a small amount of data 
between a Master Controller and up to seven Remote Controllers (slaves). There 
are two types of Remote Controllers that can be configured to transfer data to a 
Master Controller: a Peer Controller that can transfer application data, or a Remote 
I/O Controller that can transfer I/O data. A Remote link network can consist of a 
mixture of both types.

Resource 
manager

A component of TwidoSoft that monitors the memory requirements of an application 
during programming and configuring by tracking references to software objects 
made by an application.   An object is considered to be referenced by the application 
if it is used as an operand in a list instruction or ladder rung. Displays status 
information about the percentage of total memory used, and provides a warning if 
memory is getting low. See Memory Usage Indicator.

Reversible 
instructions

A method of programming that allows instructions to be viewed alternately as List 
instructions or Ladder rungs.

RTC See Real-Time Clock.

RTU Remote Terminal Unit. A protocol using eight bits that is used for communicating 
between a controller and a PC.

Run A command that causes the controller to run an application program.
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Rung A rung is located between two potential bars in a grid and is composed of a group 
of graphical elements joined to each other by horizontal and vertical links. The 
maximum dimensions of a rung are seven rows and eleven columns.

Rung header A panel that appears directly over a Ladder rung and can be used to document the 
purpose of the rung.

Scan A controller scans a program and essentially performs three basic functions. First, it 
reads inputs and places these values in memory. Next, it executes the application 
program one instruction at a time and stores results in memory. Finally, it uses the 
results to update outputs.

Scan mode Specifies how the controller scans a program. There are two types of scan modes: 
Normal (Cyclic), the controller scans continuously, or Periodic, the controller scans 
for a selected duration (range of 2 - 150 msec) before starting another scan. 

Schedule blocks A function block used to program Date and Time functions to control events. 
Requires Real-Time Clock option.

Step A Grafcet step designates a state of sequential operation of automation.

Stop A command that causes the controller to stop running an application program.

Symbol A symbol is a string of a maximum of 32 alphanumeric characters, of which the first 
character is alphabetic. It allows you to personalize a controller object to facilitate 
the maintainability of the application.

Symbol table A table of the symbols used in an application. Displayed in the Symbol Editor.

Threshold 
outputs

Coils that are controlled directly by the very fast counter (%VFC) according to the 
settings established during configuration.

Timer A function block used to select a time duration for controlling an event.
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Twido A line of Schneider Electric controllers consisting of two types of controllers 
(Compact and Modular), Expansion Modules to add I/O points, and options such as 
Real-Time Clock, communications, operator display, and backup memory 
cartridges.

TwidoSoft A 32-Bit Windows, graphical development software for configuring and 
programming Twido controllers. 

Unresolved 
symbol

A symbol without a variable address.

Variable Memory unit that can be addressed and modified by a program.

Very fast 
counter:

A function block that provides for faster counting than available with Counters and 
Fast Counters function blocks. A Very Fast Counter can count up to a rate of 20 KHz. 

Warm restart A power-up by the controller after a power loss without changing the application. 
Controller returns to the state which existed before the power loss and completes 
the scan which was in progress. All of the application data is preserved. This feature 
is only available on modular controllers.
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A
Action zone, 184
advanced controller operations, 99
Analog modules

Configuring parameters, 136
Analyze Program, 72
Animating a program, 252
Animation tables

Adding variables, 261
How to animate, 266
Opening and saving, 264
reading and writing values, 259

animation tables
editing variables, 257

Animation Tables Editor, 51
Commands, 256

Animations Table Editor
using for debugging, 254

Application
Restoring, 83

Application Browser, 24
Application name, 179
Applications

Backing up, 82
Erasing memory and backup, 86
Naming, 70
Saving, 71

applications
order of development, 66
phases of development, 67

ASCII files, 78
ASCII links, 158
   
Assistant Executive Loader, 17

B
Backup, 82
Backup cartridges, 84

C
catch input, 170
Change Base Controller, 127
clock functions, 173
Communications

ASCII, 158
Cable, 14

communications
Modbus, 157
Remote Links, 151
setting up a Remote Link network, 153

Configuration
Counters, 162
Inputs, 128
Maximum software variables, 160
Methods, 120
Timers, 161
Using the Configuration Editor, 121

Configuration Editor, 42
Configuring resources, 121
Event report, 123

Configuration editor
AS-Interface expansion module display, 
122
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Configure modem, 143
Connecting a PC to a controller

Application protection, 90
connecting a PC to a controller, 89
Connecting ladder elements, 221
constants, 165
Controller Operations, 94
Controller operations, 88
Counters

Configuring, 162
Outputs TH0 and TH1, 170
Reflex outputs, 170

counters
very fast, 169

Cross References Viewer, 50
Cross referencing, 103

D
date/clock functions, 173
Debugging

Animating a program, 252
Animating a table, 266
Phase of development, 69

Defining symbols
Object Browser, 47

Device Properties, 126
drum controllers, 164

E
editing a program

Ladder programs, 205
Editors and viewers

Ladder Editor, 34
editors and viewers

Ladder Viewer, 32
Erase, 86
Executive Loader Wizard, 17
Expansion

Configure Module, 135
expansion

deleting, 134
Expansion memory, 84
Expansion module

adding, 133
288
Expansion modules
Deleting, 134

Extended Ladder Palette, 199

F
fast counters, 168
find

Ladder programs, 211
List programs, 248

Find Symbol, dialog box, 46
Forcing values, 262
Frequency meter, 171

I
Init, 96
Initial state, 55
Input Configuration, 128
Instruction List language

Entering instructions, 236

L
Ladder diagrams

Programming grid, 184
Ladder Editor

Commands, 200
Extended Ladder Palette, 36

Ladder Palette Toolbar, 198
Ladder programs

creating, 185
searching, 209
using Cut, Copy, and Paste, 206

Ladder Viewer
Insert, edit, and delete rungs, 189
Using Edit menu, 205
With Ladder programs, 188

LIFO/FIFO Registers, 163
List Editor, 40

Commands, 234
opening, 233
Using the Edit menu, 242

List Instruction Toolbar, 236
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List Language
overview, 229

List language
Creating a List program, 231
Undo, 250

List programming
Edit menu, 242
guidelines, 240
searching, 246
Using Cut, Copy, and Paste, 243
using the List Editor, 233

List Rung Editor, 39

M
Marking a ladder block, 208
master controller, 151
Memory

Backup cartridges, 84
Expansion, 84

Memory allocation, 271, 272, 274
Memory requirements, 271, 272, 274
Memory usage, 271, 272, 274
Modbus links, 157
Modification in RUN, 267
Monitor state, 56

O
Object Browser, 47
Offline state, 55
Online state, 55
operating states, 55
Operating System

Update, 17
Operation

Offline and online, 54
Options

Add Modem, 143
Backup cartridges, 84

options
adding, 138
deleting, 139

Output configuration, 132
Outputs TH0 and TH1, 170
   
P
Page Setup, 107
Passwords

Change password, 64
Setting, 62

PLS/PWM dialog box, 166
Preferences, 28
Print dialog, 111
Printing

List programs, 115
printing

comments, 110
configuration, 112
cover page, 109
cross references, 114
header/footer, 108
Ladder programs, 116
overview, 106
page setup, 107
Print dialog, 111
symbols, 113

Printing an application
Cross References, 114
Overview, 106

Program Errors Viewer, 49
Programming grid, 184

Zones, 184

R
Reflex outputs, 170
Registers

Dialog Box, 163
remote controllers, 151
Remote links

About, 151
remote links

adding, 155
Renaming an application, 179
Repeat, 207
replace, 212
resources, 119
Restore, 83
reversibility, 77
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RTC
correction factor, 98
RTC Configuration dialog, 98

Run, 96
RUN mode

Modifying a Program, 267
Rung Header, 37

S
Saving an application, 71
Scan mode, 177
Schedule Blocks, 173
security

application protection, 61
password protection, 61

Selecting Ladder or List programming, 30
serial port

setup, 140
Set Time dialog box, 97
Setting the RTC, 97
shift bit register, 175
starting TwidoSoft, 59
step counter, 174
Stop, 96
Stop mode

Modifying a program, 269
Symbol Editor, 44
Symbols, 74

Find, 46
symbols and addresses

displaying, 191

T
Test zone, 184
Timers

Configuration, 161
Toggling ladder views, 193
Transfer an application

Backup, 82
Memory backup cartridges, 84
Overview, 80
PC => Controller, 81
Restore, 83

TwidoSoft, 12
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Typographic conventions, 13

U
Undo, 207, 213
Using rung headers, 195
Using the Ladder Editor, 197

V
validating, 124
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